Build a PC All devices in USB ports install as Unknown

Toshiba A305-s6858
Vista Home Premium SP2
64 Bit

I have 4 USB ports available, 2 on the left and 2 on the right.

I can't seem to get any of them to work any longer.

When I plug anything in on the two on the left, nothing, not a thing happens.

When I plug things in on the right, it recognizes it and it installs but tells me the device is unknown. No matter the device, it's always unknown in either port.

Until yesterday, when I removed some upper filters and lower filters associated the GearA??? it constantly was giving me that "plunking" sound like something had been plugged into a USB port and it was "not recognized". That was driving me nuts as I could not get it to stop.

I have been reading on here for a couple of days and gone through all the troubleshooting:

Cleaned drivers with Driveclean.exe in folder system32
Uninstalled the devices in device manager as instructed.
Ran SIV - Service Information Viewer
Updated chipsets and drivers
Gone thru instructions to remove upper and lower filters with Regjump
(however there are other upper filters and lower filters associated with other stuff in the Registry)
Read thru instructions and ran serviwin.
I've even been inside the computer to make sure no wires were loose.

When checking USBSTOR with serviwin here is what I get:
USB Mass Storage Driver
USB Mass Storage Class Driver 6.0.6002.18005 (lh_sp2rtm.090410-1830) Microsoft Corporation
Microsoft® Windows® Operating System
Error 1058: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.
5/14/2011 10:48:04 AM system32\DRIVERS\USBSTOR.SYS

I've tried to "start" USBSTOR, but it won't let me.

At this point I'm here with 2 laptops and 8 USB ports and can't get one port to work. ( I have an HP where the ports have stopped working too, but I can't only deal with one at a

I'm in need of some serious, get down to business help, and unafraid!

Thanks so much!!


Posts: 6,430   +186
It's another long shot but again, is easy to do, so give it a try. You have the same symptoms so try the same trick as in this thread Driver failure, unknown devices in USB controller. It worked there. Maybe for you too> <fingers crossed>

I've seen this trick work on only just a couple occasions but is easy so is also worth a try for your symptoms

Shut down computer. Unplug from the wall. Remove battery if its a laptop. Let it sit for an hour or two to discharge power. Then plug back in and try again.

Hope it may help <fingers crossed>
  • Thread Starter Thread Starter
  • #3
...was there weeks ago so you can uncross your fingers... lol

Oh, and forget what I said about the plunk sound and device not recognized popup stopping, it's NOT stopped! Just more sporadic I suppose.


Posts: 6,430   +186
...was there weeks ago so you can uncross your fingers... lol

Oh, and forget what I said about the plunk sound and device not recognized popup stopping, it's NOT stopped! Just more sporadic I suppose.
OH :( Sounds like you've already tried just about everything already :(

Only other thing that comes to mind is a general test. You could try to boot into an alternate OS from a boot CD. If ports work in this case, you know you need to reinstall Windows. If ports still don't work, would seem the computer itself is bad :dead:

You can try booting Knoppix. See step 2 in this post See [post=766270]How to recover your folders/files when Windows won’t boot[/post]
  • Thread Starter Thread Starter
  • #5
I'll give that a go. I just have a hard time believing 2 computers lost 8 USB ports in a 1 week period. And I don't know what I could have done or installed on both that did this.
  • Thread Starter Thread Starter
  • #6
I had not luck with the other operating system, maybe I didn't do it right, but I'm pretty sure I did.

I uninstalled all the USB controllers again, and scanned for hardware changes.

They reinstalled and the Intel USB 2830 is the one that shows two unknown devices just before the list of root hubs. When I uninstalled that one controller, the two unknowns were gone.

I plugged a thumb drive in the first USB port on the right side. It tried to install, but said it was unknown. I rechecked device manager, and USB 2830 is still gone, but there is another unknown, just before the root hub lists.

I plugged the thumb drive in the second USB port on the right and again it said unknowns, but it did not add another unknown to the list.

So the computer is recognizing whatever I plug in, but they are all unknown.
  • Thread Starter Thread Starter
  • #7
SIV produced a file called usbdevs.txt. Here is a tiny snipped at the very beginning of the txt file:

0000:0000=Unknown USB Device
0001=Fry's Electronics
0001:142B=Arbiter Systems, Inc.
0003=Club Mac
0004=Nebraska Furniture Mart
0017:04CA=Office Keyboard
0053:5301=GW-US54ZGL 802.11bg (zd1211rw)
0066=SCM Microsystems
0066:1001=SCM Microsystems SCR300 USB Smart Card Reader
0079:0006=Generic USB Joystick
0104:00BE=Socket USB Sync Card
0105:145F=802.11bg (zd1211rw)
0123:0001=Touchkit USB Controller for TouchScreen
0145:0112=Card Reader
0154=LW154 Wireless 150N Adapter
0200:19FF=Rocketfish Bluetooth Adapter
0204=Chipsbank Microelectronics
0204:6025=CBM2080 Flash drive controller
0204:6026=CBM1180 Flash drive controller
0218=Hangzhou Worlde
0218:0301=MIDI Port
02AD:138C=PVR Mass Storage
0300=MM300 eBook Reader
0324=OCZ Technology

isn't something odd about Nebraska Furniture Mart? What's that all about?


Posts: 6,430   +186
I don't have any good answers to your USB problem though i can provide some info/explanations.

My guess is if you open Device Manager, right click the Unknown Device, click the Details tab, you'll see Device ID listed as USB\VID_0000&PID_0000

When a USB device is connected to Windows, Windows reads its Device ID over the USB bus. (Device ID is programmed into the device when it's manufactured and both the VID and PID should be non-zero!). If, for any reason, Windows can't read the Device ID over the USB connection you see 0000 for the VID and PID values. If this problem only occcurs with one device, it's usually a device issue. If it happens with multiple devices on multiple ports it;s usually a USB controller hardware or driver and/or BIOS issue.

I don't know why you have your problem, but seems to be a hardware and/or BIOS issue (which why SOMETIMES that trick i mentioned earlier to discharge power from the computer will sometimes work to fix hardware issue with Windows unable to read Device ID from its USB ports)

p.s. that SIV file you mention, is actually an INPUT file to the SIV tool. It provides SIV info so it can try to interpret VID/PID values to tell you what your USB device is and who made it, etc. when Device ID can be read successfully

/* EDIT */
p.s #2 since your ports don't work under Knoppix either, i don't think it's a software/driver issue either. But i still can't explain why your problem would seem to occur on 2 different computers near the same time <confused>