ASDL modem Blocks some websites but not others

By monty88haynes
Oct 6, 2005
  1. I switched from a usb modem to a Dlink modem with Belkin Pre-N router recently. After hooking up the Dlink 300T, I was able to access most websites but not a few others such as, and to mention a few. I switched back to my BT usb modem and everything worked fine (I'm in London needing to read the news from home). Also some links within websites did not work, even the dlink link for a firmware upgrade. Very odd.

    I telephoned Dlink and they sent me a replacement but I had exactly the same problem. I returned the Dlink to the reseller and they sent a Hayes Zoom modem which worked fine for a few days so I thought I had the problem resolved.

    Four days later the very same problem with the dlink cropped up on the Hayes modem. Very, very strange. I've been on tech support with the manufacturers and the internet provider and I've checked all my settings on the computer. I've reset the modem to the original default setting and still the same. I do not have any parental filters or the sort turned on. My laptop works perfectly at the wifi cafe and with the usb modem. I only have problems when I connect to an ethernet modem at home. Does this have anything to do with the signal I am getting from the provider? Why would it work for a few days and then the same problem occurs? I've run anit-virus, anti-spy and system restore.

    Can anyone please help as you can understand, I am completely frustrated. Tech support guys all say that either the broadband connection should either work or not at all, and not selectively.

    Thank you for any advice.

  2. chris.baxter

    chris.baxter TS Rookie

    possible source of error

    In the past I have had similar problems because I did not choose a private network address for my ethernet - what is the ethernet address used in you router - you can find out by typing "ipconfig" at the dos prompt when your laptop is connected to the modem/router by the ethernet cable
  3. monty88haynes

    monty88haynes TS Rookie Topic Starter


    Thanks for your post and it was very good to hear that someone else has had this problem and that I am not alone. i've been on the phone all day with tech support and they told me to try different configs and my LAN connection with my ethernet modem is all fouled up. Connected to my usb modem right now. Normally when I connect my laptop to modem it just does so automatically. I'm on XP and it doesn't call for any DOS prompt.

    Any suggestion to getting my LAN reconnected?

    thanks for any help you offer.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...