1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

ASRock Extreme3 Gen3 USB port issue

By baN893 · 11 replies
Jan 19, 2012
Post New Reply
  1. Hi guys,

    I recently purchased the Z68 Extreme3 Gen3 motherboard and have been very satisfied with my choice so far. However, today I was using my computer and running some benchmarks for my graphics card. As a result of that, my AMD driver crashed and I restarted the computer as a result. After restarting my computer I have been having issues with the USB ports on my motherboard in regard to using USB devices. When booting into windows the mouse cursor would move as you might expect, however I am unable to click on anything. In order to be able to click again I need to press Ctrl+Alt+Del and click twice to open the task manager. After doing that I am able to click again on desktop icons and the windows start button but the mouse doesn't work in specific programs like Mumble, a voice chat program, and I am also unable to use the thumb buttons on my Razer DeathAdder mouse. I have tried using multiple mice with all USB ports available on my motherboard and case. Yet, none of them appear to function the way they are meant to. So the problem cannot lie with the mice. I also have connectivity issues with both my Logitech G110 Keyboard and Logitech G930 USB Headset. When in the Logitech software, the headset keeps dis- and re-connecting. So there is obviously an issue with the USB port hardware/BIOS that I am unable to account for. I tried everything I could come up with to try and solve the problem by myself. These are the following steps I have taken to try and solve my issue but none of them have resolved the issue:

    -I formatted my SSD and reinstalled Windows 7.
    -Downloaded the latest AMD drivers to see if that may resolve the issue, it didn't.
    -Installed the latest drivers for all my USB devices with no solution.

    Slightly frustrated I checked online to find other users of Z68 chipset motherboards describing the same issues. One of them explained that when he entered BIOS and disabled USB3.0 support that his mouse, plugged into a USB 2.0 port functioned properly again. So I did exactly that and to my surprise the USB mouse worked again, but now I was unable to connect any devices in my USB 3.0 slot. Which of course is not acceptable. So I did some more research and found a thread in which other ASRock users had the same issues and one of the moderators said to update their BIOS to the latest version. For them it appeared to solve the issue. So I checked my BIOS version and I had v1.20 and saw that 1.30 was the newest one. So I downloaded the latest BIOS software that installs via windows, not DOS or BIOS. Having done this successfully, I boot into windows to find to my dismay that all the issues have returned again.

    So here I am now, clueless of what to do and asking for guidance and a resolution.

    I am sincerely looking forward to your answers and suggestions,


    My specs:

    i5 2500k @ 3.3GHz
    ASRock Extreme3 Gen3
    Corsair Vengeance 8GB @ 1600MHz
    Sapphire HD 7970
    Corsair H100 Push Config
    Hard Disk(s)
    Mushkin Enhanced Chronos Deluxe 120GB
    Other drives
    WD Caviar Black 1.5TB 7200rpm
    Corsair 500R
    Other Peripherals
    Logitech G110 and Razer DeathAdder
    Operating System
    Windows 7 Ultimate 64bit
  2. Buckshot420

    Buckshot420 TS Enthusiast Posts: 297

    Have you tried resetting your CMOS?
  3. baN893

    baN893 TS Enthusiast Topic Starter Posts: 82   +10

    I haven't. I thought about it but I am not sure what that would do exactly.
  4. Buckshot420

    Buckshot420 TS Enthusiast Posts: 297

    1) I would ALWAYS flash bios from within and not in Windows. (start with this first and then continue if necessary)
    CMOS/.BIOS reset
    1) Download latest BIOS file from website and save to desktop.
    2) Disconnect power cord and press your power button 5 or 6 times (until all MoBo lights are off)
    3) remove battery from board for 30min. and replace and reboot
    4) enter bios and flash firmware with the file from your desktop

    Resetting CMOS just "Defaults" everything on your board.
  5. baN893

    baN893 TS Enthusiast Topic Starter Posts: 82   +10

    Resetting CMOS didn't do anything. Also followed the steps found on http://social.technet.microsoft.com...l/thread/a623cfa1-6415-430a-9cce-85981fe0d21f which seem to help sometimes. but not always. sounds really dumb, but it doesn't solve all the clicking issues I'm having, only a few. I've formatted both my hard drives except the 100MB partition on the master Windows drive that is reserved for OS recovery. Maybe I should format that one as well? So problem still exists. Thinking I will RMA the motherboard. Wish I could refund it, but since my roommate used part of the packaging for an art project without asking me I can only replace it... GNAR... I think it is software based the issue but since I am unable to find a solution I might replace the Mobo. it's funny that Buckshot420 is helping me out since you were suggesting I upgrade the Mobo when I was choosing my parts ^^

    Any help or suggestions are appreciated,

  6. Buckshot420

    Buckshot420 TS Enthusiast Posts: 297

    Go with a p8z68 Asus board and get the model with whatever options you want on it. I say stay with a z68 so if by chance you have an issue with your discrete/dedicated gpu you can always resort to the igpu and you can take advantage of LucidLogix Virtu. Make sure you get a board with horizontal SATA ports for your big *** board.
  7. baN893

    baN893 TS Enthusiast Topic Starter Posts: 82   +10

    Fixed it!

    Simply removed the battery from the motherboard, waited the 30 minutes, put it back in and works now. No clue how that happened but the mousebutton on my Razer is still broken.

    Thanks for your input Buckshot

  8. Buckshot420

    Buckshot420 TS Enthusiast Posts: 297

    You could have fixed it 2 days ago. Glad you got it working though.
  9. baN893

    baN893 TS Enthusiast Topic Starter Posts: 82   +10

    I know, I was just lazy and didn't want to wait 30 minutes =D I bow to you Buckshot
  10. justinsteger

    justinsteger TS Rookie

    Extreme 3 Generation 3 USB issues

    Hi, i have had some similar issues with my Asrock board. I cleared the Cmos flashed newest drivers, various installs of windows and my USB 3 port still does not work correctly. When i plug in a usb 3 device it works great, however after i reboot or shut down the PC and then turn it on again, I have to replug in the device to the back of the computer to get it to work again. If i do not do this the drive just sits there with the power light flickering abnormally... Anyone know if this is a known or fixable issue or is this bord just a POS? It seems to have a faulty Kernel Debugger as well...
  11. baN893

    baN893 TS Enthusiast Topic Starter Posts: 82   +10

    remove the battery, wait 30 min and put it back in. that fixed it for me
  12. justinsteger

    justinsteger TS Rookie

    After rereading the post, i think our issues may be slightly different. I am going to check the UEFI settings and make sure everything is set right one more time. I may try clearing the Cmos once more, although the first time i did it the battery was out for a long time. at least a few hours. I will probably need a new mobo...

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...