Asus A7N8X problems w/ Radeon 9600 Pro

By siggers ยท 16 replies
Dec 3, 2003
  1. okay, i just upgraded my system to asus a7n8x deluxe, and everything worked good. I had to reinstall win2k pro though, but thats besides the point. I got the new catalyst drivers, and everything works perfectly in software rendering. But, i cant do a THING in 3d accelerated anything. I cant even do the direct 3d test in the directx diagnostics(blank screen)!! For example: I get a blank screen in half-life when its supposed to go to the console to load; i get a blank screen before diablo2 even loads using d3d; etc... Pretty much a blank screen for everything that runs in 3d. I dont really know what could be causing this. Please any advice would be greatly appreciated! :grinthumb

    (its a sapphire ati card, if that helps any)
  2. Crazy

    Crazy TS Rookie Posts: 139

    try some older drivers

    Greets Crazy
  3. siggers

    siggers TS Rookie Topic Starter Posts: 30

    I did, the drivers the came with the card (ver: 12-006), whatever that means...3d things still dont work.
  4. siggers

    siggers TS Rookie Topic Starter Posts: 30

    i'm going to try every older catalyst version and see if any of them will work
  5. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Have you installed nForce drivers ? If yes, which ones ?
  6. siggers

    siggers TS Rookie Topic Starter Posts: 30

    to be honest, i really dont know which drivers to download from the asus website. Also, i tried my video card in a friend's pc, he has a shuttle board with a nforce2 chipset. Didnt work in his machine either.
    At this point, im beginning to believe that i got a dud card from newegg. Although i am also not sure if it would be one of those things that doesnt work at all when its broke, or just partially works (that would explain why only 2d acceleration works). But i cant really see how something like this would just not work in 3d. I mean, its a 2d/3d accelerator so if like half the card doesnt work, why would the other half?

    Ps. the older catalyst drivers didnt work in 3d at all.
  7. Sgt. Bilbo

    Sgt. Bilbo TS Rookie

    Try this: Download the reference drivers for your motherboard from Nvidia (Forceware for NForce boards) and download the newest Catalyst drivers from ATi. Board manufacturers usually tweak their drivers, and aren't always happy playing together. Here are the download links:

    Give these a shot. Install the NForce driver from Nvidia first. Then after all is completed, install the new Catalyst drivers from ATi.
  8. siggers

    siggers TS Rookie Topic Starter Posts: 30

    thanks! I actually had to install win98 se again because 2k was freezing as it booted. They dont have very new drivers for my board for 98 (drivers are from may) So, ill have to install 2k again and see if the drivers from november will let me fully use my video card.
  9. siggers

    siggers TS Rookie Topic Starter Posts: 30

    also, would adjusting the voltage on the card affect 3d in any way? If so, should i adjust it (if at all)? :confused:
  10. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    You shouldn't have to adjust voltages for your card to work well. It's only really necessary if you intend to OC.
  11. siggers

    siggers TS Rookie Topic Starter Posts: 30

    ok thanks didou.
  12. siggers

    siggers TS Rookie Topic Starter Posts: 30

    Im now using a really really old radeon 7000 card, and it works rather well in d3d & glide...for its speed.
    Well, im going to try one more thing -- putting the 9600 into a system that doesnt have a nforce chipset. Hopefully, this will tell me if the card is bad or not...if its bad ill RMA it :grinthumb
  13. conradguerrero

    conradguerrero TS Rookie Posts: 310

    i got that mobo with the regular ati 9600 without any video problems.
    did you install the nforce drivers first?
  14. siggers

    siggers TS Rookie Topic Starter Posts: 30

    yeah sure did. tried multiple times with a clean install of the new board drivers and that didnt work.
  15. siggers

    siggers TS Rookie Topic Starter Posts: 30

    well i tried the card in my mom's go. Sorry for wasting your time hah. I should have tried that first thing.
  16. DJ Riot

    DJ Riot TS Rookie

    I'm having the same problem.

    I have a Radeon Sapphire 9600 Pro on an Asus A7N8X 2.0 motherboard.

    I had to reinstall Windows because I was having d3d acceleration problems and now I reinstalled completely. Keep in mind that AGP 8X worked before the reinstall.

    I just got finished updating all my drivers and to my suprise, AGP is completely disabled. I have everything turned on in bios and I just switched them off and back on. I still can't get AGP to turn on. 1X and 2X are greyed out, and whenever I try to test the settings, it checks everything, but when I restart it sets everything but PCI read and write to off.

    What is the deal?
  17. DJ Riot

    DJ Riot TS Rookie

    Hey I got the problem fixed.

    I first reinstalled the base driver setup from the CD (and all the software) and then installed the nForce drivers.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...