ATI 9500 Freezing in games

By schacker99 ยท 17 replies
Sep 9, 2003
  1. Need Help Please

    I have been fighting an uphill battle ever since I built my computer. I have encountered two problems recently. The first is that Windows XP is not loading. I get to my desktop and I just have a mouse cursor. No icons and it doesn't allow me to do anything. This occured at some point in time when I was trying to fix issues with my video card. Which leads me to my second problem. When I am in a game (doens't matter what it is; Rise of Nations; Demo for Call of Duty; Demo for Rise and Fall of Rome) my computer either freezes up or it sends me back to my desktop and shuts of the game. I tried to fix it using an Intel Chipset update as well as re-installing my graphic card drivers. Aside from that I am stuck. First how do I get my OS back to the way it was?... and second, how can I fix my video card (which is a Sapphire Radeon 9500) without buying a new one? Which I am sooooooo tempted to do. Before my wall ends up with a computer-sized hole in it I thought I would ask around. Any and all advice is welcomed.
  2. MattG

    MattG TS Rookie Posts: 140

    Ah yes, the good ol' Computer games freezing with a Radeon card! at least i wasnt the only one.

    Some things that i found out when mine was doing this.

    I have a similar card, only the 9700 Pro.
    (its too nice of a card to just give up on isnt it? )

    HEAT. These cards get HOT HOT HOT!

    Try installing another fan, or crack open the side of the case and turn on a house fan of some sort, directing it towards the video card. This isnt a "good" practice, but will let you test if its a heat issue.

    Power. Radeon 9500+ cards require a certain amount of voltage to work properly. I cant tell you what this is off the top of my head because i cant remember, but for some reason 1.7 is ringing a bell(DONT HOLD ME ON THAT)

    Drivers! Ah...ATI stinks at making drivers, but slowly are getting better.

    When i installed the Catalyst 3.5's(the newest ones when i bought the card) my games froze.

    So i downloaded the series my friends were running on there 8500's the catalyst 2.5's. Didnt freeze for me after that, and it still is ticking good.

    And lastly, if your going to run a newer driver set, have what it wants...DIRECTx 9!

    Install DirectX9.0-certified and see if that works too.

    I would do everything software base before getting to the nitty gritty(hardware) stuff.

    Hope this helps you out!
    Good Luck!
  3. schacker99

    schacker99 TS Rookie Topic Starter Posts: 20

    Thanks for the is what I have tried

    I have an additional fan as well as having the side open

    I ruled out the problem with the power supply by buying a Antec Tru 420 Watt power supply and it still happened.

    I tried installing direct X 9 and that is when my problems with my OS started.

    Where did you download the 2.5 catalyst drivers from????

    And finally, have you had any problems with games that put forth the message..."Execption Dectected....Gathering Exception Data." And if so what did you do to correct it.
  4. MattG

    MattG TS Rookie Posts: 140

    Well, its not lack of power, its how much power the AGP slot is getting. and 1.7 is what it should be running at with that card, almost sure. i think default is 1.5.

    You can get catalyst 2.5 from ATi site, just go to download older version, or archives.

    I have never seen an error like that...if you could explain it a little bit what you were doing at the time...exact message, etc we can maybe then expand on a fix.
  5. Arris

    Arris TS Evangelist Posts: 4,730   +379

    Try forcing it to run AGP 4x rather than 8x if you have it set to 8x or auto. You should find the option for this in your bios at startup. I remember a lot of hassles with people running the 8x ATI cards on a lot of chipsets, mainly Via from what I remember, but give it a try anyway.
  6. schacker99

    schacker99 TS Rookie Topic Starter Posts: 20

    How do you change the settings to get the power for the AGP to 1.7 (from 1.5)?
  7. MattG

    MattG TS Rookie Posts: 140

    It will be located in your BIOS area.
  8. schacker99

    schacker99 TS Rookie Topic Starter Posts: 20

    So it is still freezing up.

    I installed the older drivers to see if that helped and it didn't.

    In fact now I can't even play any of Rise of Nations which I was able to do before.

    Anyone else have any thoughts???
  9. Arris

    Arris TS Evangelist Posts: 4,730   +379

    Did you try my suggestion? :confused:
  10. MattG

    MattG TS Rookie Posts: 140

    Make sure you have DX9 and try the newest of new Catalyst that came out...3.6? could be a newer one for all i know.

    Let me know if that doesnt work.

    im using that set up and it works great.
  11. lzrdlps

    lzrdlps TS Rookie

  12. lzrdlps

    lzrdlps TS Rookie

    Just as an after thought, have you checked to see if you're RAM tests OK.
  13. Elcarion

    Elcarion TechSpot Paladin Posts: 169

    It sounds like all of your problems started when you loaded DirectX9. Try clicking on Start Menu...Run...then type "dxdiag" without the quotes.
    1) Make sure the dxdiag shows that you are running DirectX 9.0b.
    2) Make sure that "Check for WHQL digital signatures" is checked.
    3) Click on the DirectX Files tab. Make sure No problems found is listed under notes.
    4) Click on the Display tab. Do you see "No problems found", "WHQL Logo'd: yes", all directx features "Enabled". You might also try running both the DirectDraw and Direct3D tests under this tab.
    5) Check the sound settings to see if you see any obvious problems there.

    Other things to consider:
    1) Motherboard chipset: Does it require specific drivers? Did you load them?
    2) Did you overclock the video card or CPU?
    3) In the BIOS: Try disabling "Fast Writes" Disable VGA Palette snoop. Make sure anything set to fast or turbo is reset to normal.
    4) Was your computer infected with a virus recently? Would you know if it had been or is?
    5) Is there any unnecessary hardware installed that your could remove? If so, remove it then see if the problem persists.
  14. Greeno

    Greeno TS Rookie Posts: 281

    Arris, You mentioned problems with VIA chipsets, he said he'd used the Intel INF, If i'm not mistaken
  15. Stalk3r

    Stalk3r TS Rookie

    I may have your answer!

    Ahh... Damn ATI.. I went through your problem for about 4 months.. and I think I have FINALLY figured it out.. Go to your display settings... click on the Advanced tab... go to the VPU Recover tab and disable both of the options.. the VPU is only needed if your video card stops responding.. which it wont.. disabling this fixed my problem and my computer no longer freezes, hangs or goes into hybernate mode when playing games anymore.. Let me know if this helps!
  16. Cooperweb

    Cooperweb TS Rookie

    I don't get the ATI vs NVidia battle when both cards are incredibly problematic.

    I also get freeze / lockup playing D3D games. Most recently Rise of Nations.

    My specs:
    Shuttle XPC SB75G2 / Intel875 Canterbury
    Intel 3.0g 800FSB
    Corsair DDR400 PC3200 2x512 (1g)
    DVD -/+ CDR
    LogiTech M700 Wireless
    2x WD 120g SATA Drives
    Shuttle Small-form 220w Power
    I.C.E Cooling system
    ATI Radeon 9600 Pro
    No floppy.

    I started out with a PNY GeForce4 4400 256 video card, but
    could not play D3D games such as RoN and Wolfenstein ET
    It would go black, freeze, then lock the system forcing a hard boot.

    I tried all the latest drivers and Omegas. Finally I loaded the older 45.23 NVidia drivers and it seemed to fix it up good.

    But then the stinking PNY gave up the ghost and I swapped to the ATI Radeon 9600 Pro. This had the same D3D problems as the NVidoa on the same two games (only 2 games I should add)
    I loaded the very latest ATI drivers (3.9) and Enemy Territory now works. But Microsoft's own Rise of Nations still locks up.
    It loads the first, second and third screen which is just production credits. When it is supposed to go to the Rise of Nations splash screen, thats when it locks.

    I loaded Mark2001 which had ran fine with the GeForce card with old drivers, it now locks up when I press Benchmark.

    DxDiag runs fine in D3D and posts no problems. All is enabled.

    Does anyone know if ATI's older drivers work with DirectX games?

    I don't care if its 1.0 Alpha as long as I can quit futzing with this over expensive, unstable and poorly coded mess of drivers.
    I wish gaming companies would port to Apple. My titanium has never glitched once.

    Anyway, I'm hoping this will finally be the forum that has some good news. Thanks in advance.

    This ha
  17. Cooperweb

    Cooperweb TS Rookie

    Well, I have an update. Pure stinkin driver problem.
    I downloaded from ATI their Cat Uninstaller and the latest driver 3.10. Whereas 3.09 would not run RoN past the open credits, it now runs with 3.10.

    I have read so many forums with this same kind of problems with suggestions so varied that I wouldn't know where to start.

    Now perhaps MS or their DirectX9 was to blame for starting it, but ATI apparently figured it out withthis release.

    Although I am a happy camper, I still assert that between NVidia and ATI, they both are problematic and deserve a flaming bag of poo on their doorstep.

    If you're experiencing a simular problem as stated in my post just above this, strip your ATI drivers off and load up their 3.10.

    Tell ya the truth, if I could have found an ancient driver release from ATI that worked like I had for NVidia, I would never have upgraded. regardless of tweaks and framerates. I would have been grateful that I no longer suffered the frustration of my thousand dollar investment crashing left and right.

    Anyway, thanks a bunch and I hope this helps the next guy.
  18. xinfinityx

    xinfinityx TS Rookie

    I too have an ATI card, it's a Radeon 9800Pro 64mb. I've tried lots of suggestions under this thread already.

    Here's my story: Everything worked fine, then I got malware which got so bad in a matter of days that my computer stopped turning on. It's hooked to my flat screen TV and all I was getting was the blue vga screen from the TV. I completely reformatted my computer, reinstalled Windows XP Pro, and the ONLY thing I changed was an upgrade from 2gb of memory to 3gb! I also added Trend Micro Security which is really getting on my nerves and I'm beginning to wonder if that's the problem, it takes up 128k memory usage! It also sucks in general, but it was free for me. I need a better suggestion on security, but that's beside the point.

    - I have DirectX9c. Is that okay?
    - I just downloaded Catalyst 2.5.
    - All of my drivers are up to date, I just tried falling back a driver under the device manager to see if that had any effect.
    -The case temperature is currently at 26C, doesn't go more than 34 on some of the higher graphic games.

    My computer specs.. built '05:

    - ASUS P4S800 478 SiS 648FX ATX Intel Motherboard
    - P4 2.8E Prescott 2.8GHz 1MB L2 Cache Socket 478 Single-Core (HEAT!!!!)
    - 3GB Memory (Crucial 184-Pin DDR SDRAM DDR 400 PC 3200 x3)
    - Antec SL400 400W ATX Power Supply
    - ATI Radeon 9800Pro 64mb Graphics Card (MORE HEAT!!)
    - 80GB 7200 RPM 8MB Cache IDE Ultra ATA133 Hard Drive
    - card reader/floppy drive
    - 22x dvd recorder
    - 52x dvd rom/cd-rw
    -CPU cooler
    - 9 case fans

    When I added the memory, I completely dusted the inside of the case, definitely made it run cooler! In the summer time I crack the side of the case open and cool it with a fan, but since we use minimal heat in the winter, it's not necessary!

    Games will run for about 20min and then freeze. I can't even do the ctrl alt del! It's completely frozen! And again, all of this worked fine until the reinstall. I'm very fresh into the reinstall and if you think it would work, I'd be willing to try another reload! The games worked the first week, I don't know what happened, but I tried doing a system recovery and it didn't work.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...