Audio Problems

LOOPOLEW

TS Rookie
HyperX Cloud2 USB Headset:

I wasn't sure where to post this so I'll just put it here.

So, since the other day the audio through my headset has not been working and I cant figure out why. I've tried everything I can think of to try and fix it. I've tried it in another device (the headset works), I've uninstalled the drivers and reinstalled them (didn't work), I've plugged the headset directly into my computers audio jack on the front (this works) which made me think it was the USB port it was plugged into, so I switched my headset to the USB port I use for my mouse and it still didn't work but my mouse did so I assumed it wasn't the port that was the problem (I also tried all other USB ports on my computer and it still didn't work). Through the audio troubleshooting there is an option to play a sound through my headset to test it, this works and I can hear the sound so I am really confused as to why I cant hear it anywhere else (YouTube, Discord, Netflix etc...). Through control panel to my headset it tells me No Jack Information Available, im not sure what this means but could be useful I guess,

I've tried countless things I've found online and nothing has worked. Leaving it plugged directly into my Headphone jack into my computer isn't an option for multiple reasons and I really need this fixed.

Could really do with some help figuring this one out, cheers.
 

Cycloid Torus

Stone age computing - click on the rock below..
Since plugging into 3.5mm works and adding 'control panel / USB extension' doesn't, I suspect that you have a wiring or connector fault in the 'control panel / USB extension'. Since the features for this fine equipment touts "Guaranteed — two-year warranty, free technical support ", I should think this is where you would go for directions on definitive test for this proprietary piece. Also, it is possible that you have extended coverage if your purchase was with a credit card that has 'buyer's protection' (on mine it is an extra year).
 
  • Like
Reactions: LOOPOLEW