Bad restore: Missing root cert., Failed vaildations, Fatal app. errors, etc.

By anonycat
Mar 10, 2008
  1. Dell Dimension 8400
    Windows XP Professional sp2

    I'm not sure which of the many things i've done messed things up, and there are too many things going wrong to list in a title. Apologies for the lengthy post.

    + none of my programs )ie: zonealarm, anydvd, bitdefender, etc.) start automatically anymore when i boot (or, at least, they are not in the system tray)
    + there are no longer any programs in the left column of the start menu (it is blank).
    + My files are hidden in the folders. If I set them to be shown... they are hidden again the next time I open the folder.
    + I cannot copy things to my cd/dvd drive (so i am unable to do a backup)
    + none of my media players (wmp, realplayer (fatal application error), powerdvd) work, except for VLC.
    + I can't start zonelab client manually ("validation failed for C:\\WINDOWS\system32\VSINIT.dll... probably missing a necessary root certificate), but it says in the security center that zonelab is running.

    -----things i've tried to fix it: -----
    + bugdoctor
    + ad-aware (says run prog from administrator account, but i am and have run it before from this account)
    + spybot (went through registry backup and ststem immunization- nearly every prog I run is acting like it is its first time running). showed no threats.
    + disk check (said: "fixing mirror copy of the security descriptors data stream") some things i try (registry cleaning tools, remote backup progs so that i can just reformat my hd and reinstall xp) cannot be done, because i am not able to download and/or install some things. That is what happened when I tried to
    + import a VeriSign certificate (internet explorer said it could not dl) and when i did successfully dl it through firefox and went through the certificate import wizard, it ended with "an error occurred during the opening of the Enterprise Trust store". :(

    i keep hitting dead ends, and I am not sure what to attempt next.

    ----how i messed up my pc:----
    i was cleaning out my pc (hadn't used it in a /very/ long time since i usually use macbook pro)... removing unwanted programs from control panel, deleting folders in program files and deleting any remaining unused/unwanted program files in HKEY_LOCAL_MACHINE\SOFTWARE & HKEY_CURRENT_USER\SOFTWARE and then updating windows and all the programs i wanted to keep.
    i updated my video card. With that, i downloaded ati catalyst controller, which required me to install .net framework 1 and 2 (and their service packs). I later decided i didn't really need catalyst control and so i removed it and the .net frameworks and their service packs from control panel.

    Everything was working great at this point, except that my pc was unconnectable. it showed my NAT was firewalled when I had all necessary ports open and I could not use file sharing or remote desktop with computers in my network. (My macbook pro is completely connectable, so I know it is an issue with my pc and not my network.).
    I remembered a long existing problem: when i try to access xp firewall it says: "cannot be displayed... associated service is not running" When i click that I want it to start, it says it cannot start.
    The 4 dependent services are listed (i cannot tell if they are active or not) and the firewall/ICS is set on automatic. When I try to start it there, it says "ERROR 1058: Tge service cannot be started, either because it is disabled or because it has no enabled devices associated with it."

    I backed up my registry keys, then i ran these commands:
    REG DELETE HKLM\System\CurrentControlSet\Services\SharedAccess /v DependOnService
    REG ADD HKLM\System\CurrentControlSet\Services\SharedAccess /v DependOnService /t REG_MULTI_SZ /d "Netman"
    I rebooted and tried to start xp firewall, but this had not worked. So I tried to merge the saved registry back, but it said that not all were able to merge.

    i then tried: cmd> "Netsh winsock reset", rebooted, and was still unable to start firewall/ics.

    Everything else on my computer was still functioning properly, but I decided that, since nothing had worked, I would just restore my computer back to before i downloaded the video card/catalyst control center/.net frameworks.

    When restore was complete and my pc had rebooted, everything was all messed up. I tried restoring it a few more times to points further down the timeline, but it all had the same result.

    Any Ideas? :-/
  2. Matthew

    Matthew TechSpot Staff Posts: 5,332   +101

    Here are a few things you can consider attempting depending on what you are comfortable/interesting in doing...

    1. Boot into Safe Mode and see how things work from there, maybe you can run repair/maintenance utilities from here, or just back your data up.
    2. Attach your HDD to another PC and run repair/maintenance utilities on the drive from there. You can also pull any data off the drive that you care to save.
    3. Run a Windows repair installation and hope for the best.
    4. Boot off a LiveCD (such as Knoppix) and store your data on another storage device.

    Ulitimately, it'd probably be best to just reinstall Windows by the way things sound.
  3. kritius

    kritius TS Guru Posts: 2,084

    have you checked in services to see if they are set to start automatically?
  4. anonycat

    anonycat TS Rookie Topic Starter

    Yeah, I've submitted to the fact that it is time for a repair reinstall.

    I've found a way to back things up and am waiting for a replacement cd-rom from Dell (my windows xp repair disc is scratched).

    Thanks for the suggestions.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...