1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

BIOS doesn't detect HDD

By vega2614
Mar 25, 2008
  1. I couldn't find a BIOS category so I figured this forum was the closest fit with my problem. In a nutshell, my Dell Dimension 4100 BIOS is claiming my drive that has been working without incident for a year is suddenly "not installed."

    I've been using a Dell Dimension 4100 P3 1 GHz for a couple of years without problems. One of my other computers randomly decided to stop working (another story altogether), so I used the Dell to do analysis on the drive. Since it was a SeaGate hard drive, I used SeaGate's online scanner to scan it for errors because I suspected it was faulty. I also did some virus scans. I restarted a little while later, and the Dell computer would get stuck on the Dell post screen. It wouldn't even go into BIOS after I hit DEL (it would freeze). So I flashed the BIOS (A11 from Dell's website) after reading some threads stating that maybe I had screwed up the BIOS (I was really confused as to why things were messed up). I still had the same issue where it would get permanently stuck after the memory testing on the post screen, and wouldn't let me access the BIOS.

    I did some more reading, and read that hardware components could be messing up the computer load process. It turns out, my CD-Rom drive was faulty or something, so when I removed it, BIOS was accessible. However, now I faced a new problem: BIOS doesn't recognize the original drive that was in the Dell, which is connected to a PCI slot via a Promise Ultra TX2 ATA controller card. So Windows won't load because my computer doesn't think there's a drive installed. The Dell tries to load PXE and other networking stuff, but of course fails. Oddly, the screen following the ATA card detection process (after post and BIOS loading), the computer lists all the IDE devices and properly identifies HDD-0 as a Maxtor 186mb drive (which it is). The Dell BIOS is pretty limited in customization. In the past, it has always successfully detected installed hardware. Under IDE Configuration, my other CD-ROM is listed (the one that isn't faulty), but under HDD-0, it says "not installed." I chose auto-detect.

    I tried the drive in question on another computer on the IDE motherboard slot (not through a controller card) and it is recognized just fine. I can't use this drive directly on the Dell's motherboard IDE slot because it's an old computer and I will get data corruption since the drive is larger than 137GB (I figured that issue out long ago). I updated the BIOS with the ATA controller card BIOS upgrade file from Promise's website. The jumper settings are set to Master. I've swapped IDE cables, PCI slots, and power cables.

    Ooops, while I was tying this, I restarted the computer after switching PCI slots for the ATA controller card, and now when I restart I get a black screen that says "Invalid Boot Diskette; Insert BOOT diskette in A:". There is no disk in the floppy drive. Could I have a BIOS virus? Does something like that exist? Could that be why the drive on the other computer failed, and then the CD-Rom drive on the Dell, and now this error?

    Thanks for any help and I apologize if this is rather long-winded.
  2. Matthew

    Matthew TS Evangelist Posts: 5,270   +104

    Try setting your BIOS to the default settings.
  3. vega2614

    vega2614 TS Rookie Topic Starter

    Thanks for the reply, but I had done that already. I loaded the default and the custom setting, and neither did anything.

    Now I don't even see the hard drive listed in the post-POST screen. I immediately see "insert boot diskette." I removed the floppy drive and it still says it, although it waits a little bit longer with a blinking cursor before the message pops up.

    I did try a different HDD (through the ATA controller card) with the computer and it still wasn't detected. I then tried attaching this HDD (20GB) via an IDE motherboard slot (the other one is occupied by the CD-ROM). The HDD was not detected in BIOS, but the CD-ROM is. Then, I removed the CD-ROM from its cable and attached it to the same IDE cable as the newly-connected HDD. Still no dice. Finally, I switched both devices (now on the same 80-pin IDE cable) to the motherboard IDE slot that the CD-ROM drive was originally attached to. BIOS detects both the HDD and the CD-ROM drive.

    I've never seen or heard about a virus that infects a BIOS from a hard drive. I really wish I knew what the source of my problem is. I think it's really odd that my hard drive on one computer would get Windows corruption (the one I was scanning with the Dell; other files are still intact), then the CD-ROM on another computer fail (the one in the Dell), and then a motherboard IDE slot stop working, completely independently on the same day. I've heard of viruses being able to destroy computer components by over-clocking them, but I never witnessed any odd performance. The likelihood of me having a virus is remote, but possible.
  4. vega2614

    vega2614 TS Rookie Topic Starter

    I honestly don't know what I did exactly, but now the computer is working. I messed around with so many things trying to get the computer to work. We'll see if it continues to work.

    I think I was getting the "insert boot disk" error because I was bypassing the ATA controller. Additionally, I think BIOS wasn't showing the HDD because it was going through the ATA controller. I was looking at the motherboard IDE connections (there isn't one for the ATA controller) in the BIOS.

    I think when I added the secondary hard drive to run some scans, I must have caused a device conflict or something. Then I flashed the BIOS, causing more problems. So when I removed the other hard drive, the computer was confused. Now both computers that I was having difficulties with are working well.

    I'll post if anything else happens.
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...