BIOS not detecting Primary/Secondary Master and Slave

Not open for further replies.
Wow, do I need help. I have been working on 2 computers all week on my spare time. I have an old Dell Dimension 4400 from 2002 that I wanted to fix up for my daughter but kept getting during installing the operating system on the hard drive "set up does not detect hard drive disks" or whatever. The drive I was trying to use was once the primary Wester Digital Drive that came in it from Dell and I upgraded to a 160 gig and made that one my slave drive. So I was going to take out the 160 gig and put it in a computer that I am building for my son and put the 40 gig back in the Dell as the Primary Drive but kept getting that message. Take it back out and put back in the 160 gig that already had the operating system and it would work fine. So that is how I found this website. I did everything others suggested. My BIOS didn't have the options that worked for so many others, I formated the hard drive, ran error check on it and so on and so on until I finally gave up and just used the 160 gig I had and went and bought another 160 at Best Buy, they have a good deal on it right now. 60 bucks. Anyway now to my new problem. I have everything for my sons computer, It has a INTEL P4 MOTHERBOARD & CELERON D 2.26GHz CPU FAN COMBO and here are the specs:

CPU: Socket 478 support Intel Pentium 4 Prescott processor; Hyper-Threading support; FSB 533/400MHz
Chipset: SiS 661GX & 964L
Memory: 2x 184-pin DIMMs support DDR400/333/266 Memory; Max capacity 2GB
Slots: 1x AGP 8X; 2x PCI slots; 1x CNR slot
IDE: 2x UltraDMA 133/100/66
Audio: C-Media CMI9761A 6-channel audio Codec
Video: Embedded Real256E 3D Graphics with 64M share memory
LAN: Realtek RTL8201BL 10/100Mbps Fast Ethernet PHY
Ports: 4x USB 2.0 Ports + 2x headers; 2x PS/2 ports; 1x Parallel Port; 1x Serial Port; 1x VGA port; 1x RJ-45 Port; 1x Audio I/O (Line-in, Line-out and Mic-in)
Form Factor: Micro-ATX, 244 x 200 mm
Package: Retail

I bought it on ebay. I hooked it up to a powmax tower. I hooked up the new 160 gig hard drive right, the DVD/CD Drive, floppy and graphics card. When I turn it on it turns on , lights up and than in the BIOS it says it does not detect the Primary Master and the Secondary Master. I don't have slaves on them. Funny thing is I will let it sit for a little go in and hit power and it will detect them for a few seconds maybe a minute and than stop. Even start to run the windows CD I have in the DVD and than just stop. I don't know what is up, I tried clearing the CMOS but that does not work. I just have to go back into BIOS to set the clock and date again and still no detection. Can anyone please help me with this. I am spending way to much time on these wife is about to kick my ****!!


Posts: 1,554   +0
hello and welcome to TS.

what brand and model is that motherboard? assuming that you did in fact do everything right, it does sound like a problem with the motherboard.

the power supply could also be causing this. what brand and model is it?
Here is the info: PC Chips M963GV

I don't know much about what is good and what is not. I guess since I took apart and put back together my Dell, I got the crazy Idea I could build one from scratch.


Posts: 13   +0

Did you try messing around with the jumper settings on you Hardrive? Because sometimes that would work. Did you try changing the IDE cables? I am not sure if this would help, but try doing a low level format(writing 0's) on your hardrive. Western Digital has their own software called Data Lifeguard Tool, which you can use to do a low level format.

Hope this helps.
Dell Hard Drives

On Dell Systems, the hard drive(s) have to be jumpered for CS (cable select).
If they are jumpered for Master/Slave they will not work.
I have replaced the IDE Cables already, the first ones were brand new and I put even newer ones on. I have tried moving the Jumper around to CS, Master and not one at all, someone told me to try that. Since it recognizes the floppy, are there drivers or BIOS updates or something I need to put on the floppy??


Posts: 24   +0
CMOS battery


Try to change the battery of CMOS with a new one.
Clear the CMOS.
Set in the Bios, the default values, then try again.

Put the CD-ROM as slave on IDE2 slot on Mobo.
Try again.

Good luck to you for the future.
Thanks for your post so far, but I have tried that stuff to. I actually read the other post and tried all the options that were suggested before I decided to post anything. So far I have tried moving the jumpers, clearing the CMOS with the battery out. On IDE 1 I had the Hard Drive and on IDE2 I had the DVD as Master and CDR as Slave. I had jumpers set as such. Than took of CDR and set the DVD to CS and has just a Master on IDE2. Than took off the cable to IDE2 and set the Hard Drive to Master and DVD to Slave on IDE1 with moving the jumpers on the devices accordingly and all with brand new cables, I have 2 sets so I swith them out. When I first tried that configuration it said it recongnized the Hard Drive but than came up with an error and than nothing else. I really don't know what to do. I don't know if it is the motherboard or what.


Posts: 24   +0
Hello to you,

Try the HDD(the 40GB) on another computer to verify if it is working.

If is working try to install an OS on that and mount the HDD on your computer.

Remove the CD-ROMS from computer and try in this way.

If it is working you have the answer at your problem.

Good luck to in your quest
Hey I did decide to put the 40 gig back into the Dell and it worked!! Don't know why but now it does and the OS is back on it. So than I took out the Brand New 160 out of the one I am building and put in the 160 that has the operating system and still nothing. So out of the 2 problems I has, one is fixed on the Dell for my Daughter. But the other one for my son still has its issue of in BIOS the Drives, none of them are detected.
OK....So check this out. I had 512 Ram in the memory. And in the 1st slot. So I had ordered another 512 and it came in a little while ago. I put that in and all of a sudden the drives started being recongized. But not everytime I boot up just some times. And when I would F8 to get to boot menu, when they were recognized they read like this.

The Wester Digital 160 is PM-PD@ PD0600HB 900GPA0
The Pioneer DVD/CDR is PS-PIHN@EP 2V2-PW 2VP-010D

So if I select the Pioneer that has the OS CD in it the cursor just blinks in the left hand corner.

If I select the Hard Drive that already has the operating system on it it cycles for a second and than this comes up:

RPL-ROM-ADR:0016 EC54 7F9C

Reboot and select proper boot device
or intert boot media in selected boot device and press a key

And when I press a key I get nothing, does nothing at all. I tried to a diagnostic with the floppy for the WD hard drive but it says that the Hard Drive is not WD, but it is.

Can anyone please help.


Posts: 1,554   +0
pcchips makes products of astoundingly low quality. having taken many of thier boards apart i am quite surprised that any of them work at all. this does sound like a serious motherboard problem.

what brand and model of power supply do you have? i have seen many cases where a weak or low quality PSU could not provide ample startup power to the system during boot, thus causing improperly detected drives and other errors. but, given the motherboard, i would still suspect that first.

i would get a quality name brand (asus, gigabyte) motherboard instead. even if the motherboard is not the cause of this particular problem, it's bound to cause major problems for you in the future.
Thanks Zep, I was talking to someone who builds computers and he told me the same thing about PCChips. I didn't know this before hand, I was just looking for my best deal. I do have a 450 Watt PS though. Now the case has 2 LED fans on it, the PS has a fan and so does the Motherboard but that should still be enough right? Anyway my friend said they used PCCHIPS before when building thier computers but stopped do to being unreliable, he is going to send me a new motherboard set...I think he said asus. Now do you think it could of been the PSU??
Not open for further replies.