BIOS won't detect 2TB HDD

By Ullr
Oct 27, 2010
Post New Reply
  1. I woudn't exactly call myself a newbie at computer hardware and setups, but i'm feeling very confused and puzzled at the moment, unsure of what to do next.

    Following a HDD failure (on my 500GB) i recently bought a new 2TB hdd, a Samsung Spinpoint Ecogreen F4 2TB. But this Hdd couldn't be detected on my Bios. I have an Abit Fatality FP-IN9 Sli mobo, with on chip sata controllers, and was using both the 500GB and a 1TB HD (non raid) concurrently with no problems at all.

    My plan is to use my existing OS on the smaller drive, leaving the larger capacity one merely for storage. But when connecting this samsung 2TB Hdd into my setup, it simply woudn't get detected in the bios setup, upon going inside and auto searching, the search "hung" on the respective sata port, like bios knew something was there, but coulnd't find it. As bios couldn't recognise it, windows had no chance.

    As well as checking the obvious sata cables and power inputs, i also tried hotplugging it from a usb caddy, avoiding the whole sata interface from the mobo's pov. Yet the drive still couldn't get detected in XP, like it usually would as "mass storage device".

    Assuming the HDD to be faulty, i sent it back, simply wating an exchange. But upon testing, i was told the drive is fully working and was given a refund instead (not what i really wanted, but oh well).

    Having done a fair bit of online research beforehand, i choose the samsung Hdd as it performed well for the price and was low in wattage. It's sata 3GB, but so is my fully detected 1TB; so the mobo clearly accpets sata 3gb. I've read of slow write/read speeds in XP of these "advanced format" drives, with the 4K sectors, but no problems where that caused them to not be detected (the samsung f4 has 512mb sector emulation also).

    So i look at my mobo, the Abit Fatality FP-IN9. I've read Abit went under a few years ago and the website's latest bios is V16 ( which i have) from 2007.

    Thats where i'm left confused. I want a new Hdd, but i have no idea if any other make/models will work, or whether im right in thinking the problem lies with an old bios on my mobo. If so, can i chuck on a new bios that's not for the fatality mobo, but still award phoenix and/or for the LGA 775 chipset?

    Had anyone encountered similar problems like this, and fixed it? Or are there other 2TB hdd's that some people use on a fatality FP9 mobo?

    please help.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...