BIOS won't Recognize new Western Digital Caviar SE

By UncleVanya ยท 4 replies
Feb 23, 2007
  1. I really hope someone can help me. Firstly, I checked with Microsoft (where I learned that in order for Windows XP to run a Large Capacity Disk meant having SP2, which I have, so I thought , "great", there should not be a problem). But after installing my new Western Digital Caviar SE 320GB, and going to BIOS to ensure that the "AUTO" option was enabled, the Cavair SE would not be detected by BIOS. Then I tried the "LBA" option, but again, no luck. So in the CMOS Setup Utility I tried the "LARGE" option in BIOS Setup, and still my BIOS would not recognize it (In BIOS it shows up as "NONE"). Previously I was running an 80GB Disk, and two seperate 40GB Disks, as well as my CD-ROM RW, and all 4 devices worked fine. Then, because I wanted more storage space, I decided to get rid of one 40GB Disk and the 80GB Disk, and upgrade to the 320GB DIsk, with my remaining 40GB Disk as the bootable drive containing Windows XP. However, everytime I install the 320GB Disk it does not show up in the CMOS Setup Utility BIOS, and it also causes my 40GB bootable Disk to disappear in BIOS as well (also detected as "NONE"). Moreover, my PC will not boot when the 320GB is installed in my tower. I get a "Disk Boot Error" on a black screen, and a message telling me to insert my System Cd, which would ultimately erase my Windows XP from my 40 GB Western Digital Hard Disk, leaving me with no options at all. Thus, I end up in a continues loop reinstalling windows, reformatting, etc., to no avail (obviously because BIOS is no longer recognizing that I have the 40GB Disk other words, it's as if I have no Hard Disk and, therefore, no Windows XP installed at all)! But when I remove the Caviar SE, everything is back to normal, and my PC boots fine. All I really want is just to use the WD 320GB Hard Disk for storage (not to contain my Windows XP, nor to be the bootable drive). My operating system is a one year old:

    Acer Aspire T120c Desktop
    AMD Athlon XP CPU
    AMD Sempron 2800+ processor
    System Memory DDR 266/333/400, 2 DIMM Slots, expandible to 2GB
    Power Management Function
    High Capacity Enhance-IDE Drive
    256 MB of DDR Memory
    Windows XP Home Edition
    Service Pack 2 installed
    Support USB 2.0 High Performance Peripherals
    No Floppy Drive

    Is it possible that my PC can not handle the size of the Western Digital 320GB Hard Disk, or is there some other updates (i.e. drivers, BIOS,etc.) that I must install first in order to get BIOS to recognize the Western Digital Caviar SE Hard Disk? Is this a losing battle because I have been working on this problem for four days now without any luck, and I would like to know if the Western Digital 320GB is just not compatible with my Operating System, so then I can stop pulling my hair out over this dilemma. I am getting rather desperate because I rely on my PC for my employment. I've contacted Western Digital 4 days ago, but still have had no response. Any help would be hugely appreciated. Thank you very much, and I hope you can end my agony. :(

  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

  3. UncleVanya

    UncleVanya TS Rookie Topic Starter

    Thanks for responding Mictlantecuhtli. Yes I did set the jumper on the back to slave (secondary device on an IDE channel), in fact that was the first thing that I did, and still the WD 320GB Disk would not show up on BIOS. I also tried setting it on Cable Select, but that did not work either. I am starting to think that my PC (AMD Sempron 2800+ Processor) does not have the needed MHZ to recognize it in BIOS. Previously I had my CD-ROM RW, two 40GB Hard Disks, and one 80 GB hard Disk installed, and all of them showed up fine in BIOS, and my PC booted without a hitch. :( Even if I try to install the 320GB Drive all by it self in the tower, it will not show up in BIOS
  4. nickc

    nickc TechSpot Paladin Posts: 923   +11

    u may need a BIOS update to get that machine to see that drive but I do know that the machine will see large hard drives, and SP2 is not what has to be done, they can be seen with SP1 or 1a.
  5. N3051M

    N3051M TS Evangelist Posts: 2,115

    i don't know if this solution will work, but if BIOS is the latest for your motherboard, you could try the WD's Datalifguard program, downloadable from their website for free:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...