1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Bizarre connectivity problem

By MrSnoobs ยท 21 replies
Mar 15, 2008
  1. Hey all. This is a strange one. My main PC is playing up with the network connection. I have this PC (XP), a Mac (G4) and a Dell D400 laptop (XP/Linux) all hooked up to my wireless network.

    The problem is that my main PC has recently started not displaying images from certain websites. Particularly effected is the BBC news website. It shows the text instantly, and the solid colour banners etc, but all images like photos never come up, and show the image not found placeholder. This occurs in IE7, Firefox and Opera. Obviously this sounds like a wireless connectivity issue BUT some sites are almost entirely unaffected and whats more, when I do the speed test at Speedtest.net I get my full download capability displayed. The connection reads at 61% signal strength with 91% signal quality. I know it is sytem specific as the two laptops work absolutely flawlessly.

    I have re-installed the adapter drivers with the newest available and this did not help.

    It doesnt make any sense!! Any ideas are appreciated as this is beginning to really annoy me.

    Thanks in advance.
  2. MrSnoobs

    MrSnoobs TS Rookie Topic Starter


    Adapter is a 3Com OfficeConnect USB adapter (54G).
    Router is an old Belkin, but as I say, the other comps work fine, so I doubt its a router specific issue.
    PC is 4200+ X2, 2GB DDR with XP SP2. Not sure what else to supply.
  3. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    so for verification; the Mac accesses the same site as the PC but the pc has no images, but on some other site(s), images do appear ?

    find this file on the pc
    \windows\system32\drivers\etc hosts​
    open the file (using notepad)

    you may find just one line that looks like localhost​
    or many lines of followed by some domain names

    If you have MANY lines of, search for the domain name that you
    are having problems with.

    a line like ads.xxxxx.com would block all adverts coming from xxxx.com

    sometimes images are found on separate servers too, like img.xxxx.com (where img could be anything)

    if you would cite an url example, I would verify the location of images for you ...
  4. MrSnoobs

    MrSnoobs TS Rookie Topic Starter

    Well I thought you may have cracked it when you mentioned the Host file. I altered it recently: I added an IP for a VPN connection I needed for work. It wasnt that necessary so I deleted the new line, but alas, I am still having problems.

    The host file only has the one line on it. Rebooted to see if it loaded at startup but no dice.

    As an example, News.bbc.co.uk loads fine on the mac/laptop but not on the windows machine. When I load up a page from the RSS feed for example it loads all the text and layout instantly like a good ADSL connection should, but the images never arrive and in the status bar it has "connecting to newsimg.bbc.co.uk" or something similar very briefly and then it gives up on the images.

    This happens on: BBC news, Ebay, Facebook. techspot (!) and flickr
    It does NOT happen on: IMDB, wikipedia or Youtube.

    Bizarre non?
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Do you still have the VPN software installed and active? Maybe try disabling or uninstalling it? Some VPN clients are very intrusive and can seriously disrupt normal networking.
  6. MrSnoobs

    MrSnoobs TS Rookie Topic Starter

    Ah, unfortunately it was a remote VPN. The server only allowed you in to edit the backend of the site if you had the IP address in the host file. I got rid of that, but still problems persist.

    Not sure where to go next! Thank you!
  7. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    try using LSPFIX to cleanup your Winsock stack

    download LSPFIX here
  8. MrSnoobs

    MrSnoobs TS Rookie Topic Starter

    Well I ran the LSP-fix utility, but this only showed 3 entries: MSWSOCK.DLL, WINRNR.DLL and RSVPSP.DLL

    These dont exactly seem like a cluttered stack. Should I get rid of any of them?

    Thanks again
  9. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    NO. Well done :)
  10. MrSnoobs

    MrSnoobs TS Rookie Topic Starter

    OK - here is an update. I remembered that I set up a VPN connection for my girlfriend to access journals from her university. On a whim, I fired it up to see what happened. Guess what: when running, I have no problems with my connection at all! I dont understand why this is. Makes no sense to me. Any ideas, as I would prefer not to have to get this running every time I am online.
  11. tipstir

    tipstir TS Ambassador Posts: 2,425   +112

    I don't run VPN tunnel always when it not in use I disable the IPSEC and PPTP. I you know the port the VPN client software usese you can disable the port, otherwise that's it.
  12. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    not entirely sure what you're saying but, consider this routing;
    my system--------my router ------ my isp --- the web
    clearly the path to whatever we ask for routes thru My ISP to the site requested

    now create a VPN connection to some university or commercial site
    my system--------my router ------ my isp --- the web
         + VPN ........the virtual connection............ VPN Target .... web access (may be)
    To protect the VPN Target, routing is no longer via My ISP to the web
    (ie: dns requests are not resolved here),
    but directly to the VPN Target to be controlled by that infrastructure, with or without
    access to the web via the infrastructure itself.

    Now *if* the VPN client is disconnected, the original routing via My ISP should resume (including DNS lookups).

    The test will be to see what connection is made for DNS lookups.

    You can install Cports to verify the ip-address used for port 53 access
  13. MrSnoobs

    MrSnoobs TS Rookie Topic Starter

    Right, I fired up CurrPorts and it all seems fine, although I am unsure what to look for. BBC news seems to be working fine now, but I am sure it will die soon. Techspot is playing up, but I cant see what to look for here.

    Any tips?
  14. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    run it from Admin Account

    double click the column heading Remote Address
    (remote connections will then be at the top of the list of connections)

    Column one is the application (with icon)
    Column seven is the Remote port (email is 110, browser is 80, dns is 53)
    Coumn nine is the ip-address

    Find your DNS address in ipconfig /all

    adjust your windows so you see windows one above the other

    get a command prompt and type
    telnet your-ip-address 53 <enter key>
    watch to see port 53 opened

    if not, then your firewall is blocking it
    if you see
    Connecting To not open connection to the host, on port 53: Connect failed​
    it's to be expected and indicates you accessed the DNS
  15. MrSnoobs

    MrSnoobs TS Rookie Topic Starter

    Hi again,

    when I ipconfig /all, I get two entries: Teredo Tunelling Pseudo-Interface and the Automatic Tunelling Pseudo-Interface. My DNS servers in the latter is in IPv6 and is fec0:0:0:ffff::3%1, which I believe is the same as, but I'm unsure. Either way, in my TCP/IP settings I have static addresses and use (router) as my DNS address.

    When I telnet it, it gives the "Could not open connection to host..." message.

    Sorry I am so useless! Is there anything more I can find out?
  16. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    your doing ok.

    you need to DISABLE IPv6; it's useless on your LAN and all public DNS addresses
    are in IPv4.

    can someone follow-up here --- I got to run out for ~3-4 hours ......
  17. MrSnoobs

    MrSnoobs TS Rookie Topic Starter

    Right, I have uninstalled IPv6, so all I have left are: Client for..., File and Print sharing, QoS packet... and TCP/IP (v4).


    No Dice. Still cannot connect to image servers. Have deleted the VPN and will update later.
  18. MrSnoobs

    MrSnoobs TS Rookie Topic Starter

    Has no one any ideas? This is so strange: internet only works when VPN for my girlfriends university is enabled. Is there no way of changing the routing?
  19. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    As I already said. Some VPN are very intrusive. They install their own firewall engine and can do anything they like with your networking.

    Remove the VPN software and all the drivers related to it.
  20. MrSnoobs

    MrSnoobs TS Rookie Topic Starter

    You are certainly right about it being intrusive, although the VPN is simply what I set up in MS: there is no third party software involved. I deleted the connection and the problem persists. Thanks for the help btw!

    Any more tips/ideas?

    Many thanks!!
  21. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    Have you flushed the cache of the browser? Also add

    ipconfig /flushdns
    net stop "DNS Client"
    net start "DNS Client" ​

    your routing is already "correct", but the DNS reference is via the university.

    btw; you've never posted the results from IPCONFIG /ALL (please do so)
  22. MrSnoobs

    MrSnoobs TS Rookie Topic Starter

    Have flushed it in the past yes, but not tried the DNS Client stop start thing before.

    Windows IP Configuration:

    Host Name . . . . . . . . . . . . : harryrig
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Wireless Network Connection 4:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : 3COM OfficeConnect
    act USB Adapter #3
    Physical Address. . . . . . . . . : 00-14-7C-66-F5-66
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . :
    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . . :
    DNS Servers . . . . . . . . . . . :

    Funny thing is that when I attempt to load a web page, the VPN connection comes up again, and if I cancel it the pages fails to load at all. When I delete it entirely, we are back to square one and the images dont load.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...