Blu-ray files not playing properly on Windows 7 64bit

By waterproof ยท 7 replies
Apr 22, 2010
  1. It's always gets that picture quality as if it was scratched and of course out of sync! I have no issue with it on Windows 7 32 bit or Vista 32 bit, my codec i thought it was the issue, so i uninstalled it and installed it again but the same thing happens, also with the 32 bit, uses the same codec as my 64bit, has no issues with the bluray files (mkv format) anyone know how i can stop this?
  2. LNCPapa

    LNCPapa TS Special Forces Posts: 4,274   +461

    They aren't bluray files if they're in an mkv. Matroska is a container for files of many different codecs - most commonly .264 + some audio format(s) + subtitles. What media player are you using for these files? Have you tried playing the files with VLC?
  3. waterproof

    waterproof TS Booster Topic Starter Posts: 208

    They're bluray rips that's available online that's been turned into mkv extension. Anyway, I do use VLC to watch the videos, that's the problem with it, same with Media Player has the same issues, don't think it's to do with the file, it plays perfect on 32bit Windows 7/Vista.
  4. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Funny how MS W7 32/64-bit Media Player or MCE doesn't support B-Ray out of the box. You need to install and run Power DVD. I got one laptop that has W764HOP on it with B-Ray/DVDRW it came with PDVD8. I also have PDVD10 that supports blue-ray in 3D. Newer one needs a very fast system. On quad core it runs smooth.
  5. waterproof

    waterproof TS Booster Topic Starter Posts: 208

    Damn sounds like my system needs an upgrade, although both my laptop and my pc running vista 32bit seems happy with watching bluray, just cant seem to get it right with 64bit :(
  6. LNCPapa

    LNCPapa TS Special Forces Posts: 4,274   +461

    You're not running bluray at all. You're playing a .264 encoded video in a matroska container. It would be much more accurate to say you're having problems playing an mkv.

    Bluray has nothing to do with your current problem except for being the original source for your video file. There are more efficient ways to decode .264 files than with VLC - perhaps you should look at another player or a different decoder. Try looking into one of the WMP HomeCinema solutions and you might have better luck.
  7. waterproof

    waterproof TS Booster Topic Starter Posts: 208

    Oh ok, so I guess U gace a mkv problem, but why on 64bit but not 32bit?
  8. LNCPapa

    LNCPapa TS Special Forces Posts: 4,274   +461

    Because it's possible you're decoder is having issues or a conflict on your x64 side. Have you tried with another player or codec?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...