Blue screen occurs after occasional automatic updates

By Phanixis · 30 replies
Jul 15, 2010
Post New Reply
  1. System Specs:

    Motherboard: Asus A8N32-SLI Deluxe
    Processor: Athlon 64 X2 Duo
    Ram: 2 GB
    Power Supply: Thermaltake 600W
    Hard Disk: 1 Seagate Barracuda SATA (Boot)
    1 Seagate Barracuda EIDE (Data)
    DVD Drive: Aopen EIDE
    DVD Burner: Sony EIDE

    I have a been having a very unusual problem, which I believe may be hardware related. Here is what happens:

    Windows is running an automatic update. Usually it works fine, but sometimes I will lose my internet connection. To restore my internet connection, I have to shut down my computer, and unplug my cable modem to reset it. Once that cable modem is reset, I start my computer to restore internet connectivity. However, in some instances, it will bluescreen, giving the following message: PAGE_FAULT_IN_NONPAGED_AREA

    When this happens, I have to boot into safe mode, and run system restore, often twice(use last known good configuration does not work). If I don't run system restore, the bluescreen error repeats with the same message. Once I have restored the system, it acts normally again until the next problem manifest.

    In some instances, including todays instance, I cannot power the computer back on immediately after the crash. I such down several lights and my HL-5040 printer, and eventually got power back to the computer. I was able to repair it normally after that.

    There is one symptom I find interesting: upon restoring the system, many files loaded on my data hard drive, that does not contain Windows or any essential Windows files, that were copied to it between the system restore date and the bluescreen crash vanish. I find it odd that system restore would delete files on my data hard drive unrelated to Windows(in this case, I had just downloaded self-extracting .exe. of firefox a few days ago to my data drive, upon restoring to the middle of last month, it vanished from the drive. I had not yet used this .exe to install the latest version of firefox. The .exe of an older version of firefox that I was using was located in the same directory, it remained intact).

    I have started messing around with the SDK debugger and dump files, but I really do not know what I am doing. I only have two dump files, one dated last month(probably the restore date), and one dated March this year. Nothing dated today, which is one the most recent bluescreen has happened. The only thing I leanred from the dump files is the ntoskrnl.exe was involved in the crash.

    This problem has been plaguing me for a while, and I am tired of it and want it fixed, but it is so hard to pin down. I do not know if it is a hardware problem, and which piece of hardware it is related to. I have reasons to suspect the power supply, the mobo, and both hard disks.

    Any help with this problem would be greatly appreciated. I have attached the most recent .dmp if any know how to use these properly.


    Attached Files:

  2. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    According to your dump file memory corruption is your issue. Therefore our advice is for you to run the free and safe Memtest on your RAM.

    See the link below and follow the instructions. There is a newer version than what is listed; use the newer. If you need to see what the Memtest screen looks like go to reply #21. The third screen is the Memtest screen.

    Step1 - Let it run for a LONG time. The rule is a minimum of 7 Passes; the more Passes after 7 so much the better. The only exception is if you start getting errors before 7 Passes then you can skip to Step 2.

    There are 8 individual tests per Pass. Many people will start this test before going to bed and check it the next day.

    If you have errors you have corrupted memory and it needs to be replaced.

    Step 2 – Because of errors you need to run this test per stick of RAM. Take out one and run the test. Then take that one out and put the other in and run the test. If you start getting errors before 7 Passes you know that stick is corrupted and you don’t need to run the test any further on that stick.


    * Get back to us with the results.

    *** If Memtest shows no errors then find the voltage specs of your RAM and compare it to the voltage setting in your BIOS. Do they match?

    * By the way, have you updated to Service Pack 3?
  3. Phanixis

    Phanixis TS Rookie Topic Starter Posts: 53

    Thanks for your help.

    I followod your instructions and download memtest, burned it to a CD, and I ran the program overnight. Memtest was able to make 11 complete passes. It found no errors. I left it in the default configuration. The one big thing I noticed is that it did not seem to be testing ECC. Should I turn that option on?

    Also, how would I go about finding the voltage specs on my RAM?

    Thanks again for the help.
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Find the manufacture (i.e., Kingston, Crucial, Corsair, etc.) and type (i.e. DDR2, DDR3) and model and go to the manufacture's website and you will find the voltage specs.

    You could try running memtest per stick. Occasionaly bad RAM has been known to pass.
  5. Phanixis

    Phanixis TS Rookie Topic Starter Posts: 53

    Ok, I have two ram chips loaded on the motherboard, 1 GB each. Once is a Kingston PC3200 chip, rated for 2.6 V, the other is also a PC3200 chip(but not made by Kingston), and I will need to crack the case to read the make off that chip.

    The real problem I am having is that I am unable to determine the operating voltage of the RAM. I search through BIOS, but the only voltages I could find are those related to the Power Supply rails, I couldn't find the RAM voltage, and equally important, a way to change it should the operating voltage be wrong.

    Also, with regard to memtest, you are telling me that although a passed the test with both RAM chips loaded, I might be able to get memtest to locate failures by removing one of the RAM chips. If one of the RAM chips was fautly, wouldn't it cause errors regardless of whether or not there is a good RAM chip in the other slot?

    Thanks for the help.
  6. Phanixis

    Phanixis TS Rookie Topic Starter Posts: 53

    Ok, I have cracked the case to get some more details on my ram, the information I provided earlier was slightly incorrect.

    There are actually three RAM chips, two that work as a pair, and then a single RAM chip.

    The RAM pair is made by Centon. They are a 1 GB Dual PC3200 set. They operate at 2.6 V.

    The single RAM chip, which I remember purchasing from Kingston, has no make listed on its tag. The specs for it are as follows:

    1 GB, DDR DIMM Q, AOTQD STK 6728978
  7. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Download the free utility SIW (System Information for Windows). Once installed double click the icon and a screen will come up. On the left is a list of items you can have SIW give information about. Click the memory icon under hardware.
  8. Phanixis

    Phanixis TS Rookie Topic Starter Posts: 53

    I downloaded SIW. I found out two things:

    The memory with no make on its tag is Samsung Memory, an M3 68L2923BTM DDR PC3200, not Kingston Memory. This may mean that its operating voltage is not 2.6 V as in the case of Kingston. I have not been able to find this particular make on Samsung's site, or even a reasonable estimate for its intended operating voltage. SIW says it is currently operating at 2.5V.

    SIW correctly identifies the Centon memory as it was listed on the chip tags. This memory is also running at 2.5V, so 0.1V off the manufacturer specifications.

    I hope this helps you resolve my problem.

  9. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Believe it or not an increment of voltage will cause issues. Though usually the motherboard will set the voltage at the lowest RAM voltage present.

    What did the timings look like between your sticks? Also, when you get a chance run memtest per stick.
  10. Phanixis

    Phanixis TS Rookie Topic Starter Posts: 53

    Ok, I have several questions:

    If the 0.1 V difference is the source of my problems, how do I go about fixing correcting it?

    In regard to memtest, the Centron RAM chips are designed to work as a pair, two 512MB chips that act as a single 1GB chip. They are actually both labeled as a single half of a 1GB RAM chip. Should I test the Centron memory individual or together?

    I downloaded Speedfan from this site just to make sure my system wasn't overheating. Most of my system parameters seem fine, except for the negative rails: the system is reporting -8.7V for the -5V rail, and -1.8V for the -12V rail. This doesn't seem right. If the voltages were that far off, my system shouldn't even work. What is going on here?

    Thanks for all of your help.
  11. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Woa, that is way off for your psu. The safe range of voltage is + or - 5% A psu is the bacfkbone of any system and if it is not putting out the correct power you'll have all kinds of issues. What make is your psu?
  12. Phanixis

    Phanixis TS Rookie Topic Starter Posts: 53

    It is a thermaltake PSU, 600 watts. I will probably need to crack the case to get the exact model number.

    I agree the negative voltage rail numbers are off. They are so far off I am not even sure if I believe speedfan. The system should flat out not work if those numbers are true.

    Let me see if I can double check those values in BIOS. If this isn't the problem, I will need to know how to fine tune the RAM voltage.
  13. Phanixis

    Phanixis TS Rookie Topic Starter Posts: 53

    I made yet another mistake, I do not have a thermaltake PSU. I have a Corsair HX620W PSU.

    Also, I checked BIOS. Apparently, Asus didn't feel negative rail voltages were that important to monitor, because BIOS only gives me the positive rail voltage values. So I can't confirm the SpeedFan results, which I would like to reiterate, make no sense. I the negative rails were that far off, I would expect smoke and ugly noises, not the occasional BSOD.
  14. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    That Corsair is a excellent power supply especially since it is one of their HX models. The more I think about it I am not so sure the negative rails figure in much as do the positive rails.

    I may need to look into it further.
  15. Phanixis

    Phanixis TS Rookie Topic Starter Posts: 53

    I have been searching the net regarding the negative rail dilemma. I am not sure if I understand everything correctly, but supposedly the negative rails are a holdover from older motherboard designs, and modern ATX power connectors do not even have negative rails. So the motherboard has no way of reading the negative PSU rail values and monitor programs just make up numbers.

    I have placed an inquiry with Corsair regarding this problem. For now we should probably assume the negative rails are fine, and deal with the other problems, such as the RAM voltage and memtest. So back to the original two problems: is it possible to correct for the 0.1V RAM voltage deficit, and do I need to memtest to two Centron memory sticks together or separately?

    Thanks for the help.
  16. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    About the negative rails that sounds about right in the newer tech. Again, if your positive rails were off that would be a serious issue.

    As for voltage settings, again, the motherboard should set the installed memory to the lowest specs.

    Try running your system with just the Cenrton.
  17. Phanixis

    Phanixis TS Rookie Topic Starter Posts: 53

    Sounds like a good plan. I will see if the voltage changes. I can also run memtest while the Samsung stick is removed.
  18. Phanixis

    Phanixis TS Rookie Topic Starter Posts: 53

    I pulled the Samsung memory, but SIW still reports the Centron is operating at 2.5V. I run memtest on both Centron sticks this evening, unless you suggest I should run memtest on the Centron sticks individually.

    In regard to the negative rail values, I found the manual for my Corsair power supply. According to the manual, the Corsair has no -5V rail, so SpeedFan is making up numbers for at least that rail. It still has a -12V rail, but I highly doubt SpeedFan's value of -1.75V for that rail is correct.

    Edit: I found a site claiming the Centron runs at 2.5V and not 2.6V, so maybe the Samsung runs 2.6V and the Centron runs at 2.5V. Still, might as well run a memtest while the Samsung is out, and then test the system on Samsung only tomorrow.
  19. Phanixis

    Phanixis TS Rookie Topic Starter Posts: 53

    Ok, I just ran 21 memtest passes on the pair of Centon sticks. No errors were found.

    I have switched to the Samsung memory stick. SIW still says the memory is running at 2.5V.

    I will try and run memtest this afternoon on the Samsung stick. If that doesn't show any problems, we need some new ideas.
  20. Phanixis

    Phanixis TS Rookie Topic Starter Posts: 53

    I just ran 13 successful memtest passes on the Samsung stick. So unless you know of a way to manually adjust memory voltage, I seems I am out of options for diagnosing the system memory wise. For now, I will keep the Centron sticks out of the system, until the next crash of this type. Its about the only option I have left if memory is the cause.

    How certain are you that the memory is the cause? One thing I have noticed about most of my bluescreen crashes, is that internet connectivity is usually involved. My last two bluescreen crashes occured after I lost internet for no clear reason. The previous bluescreen crash was the result of a very long and data intensive download. Do you think a faulty network adapter could be the causes of these errors?

    I am interested to hear what you think about these issues.

    As always, the help is appreciated.
  21. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    As per the minidump read the issue was cited as memory corruption and memory corruption can cause all kinds of issues.

    Post your latest minidumps.
  22. Phanixis

    Phanixis TS Rookie Topic Starter Posts: 53

    Unfortunately, there only seem to be two located in the minidump folder, the most recent of which I had posted. I will post the other in this reply(it doesn't let me repost the one I posted at the beginning of this thread).

    Attached Files:

  23. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Your error is 0x0000000A: IRQL_NOT_LESS_OR_EQUAL
    Typically due to a bad driver, or faulty or incompatible hardware or software. this error condition means that a kernel-mode process or driver tried to access a memory location to which it did not have permission, or at a kernel Interrupt ReQuest Level (IRQL) that was too high. (A kernel-mode process can access only other processes that have an IRQL lower than, or equal to, its own.)

    ALCWDM64.SYS is the cause of your crashes according to this minidump which is a driver for your onboard Realtek AC97 Audio.
  24. Phanixis

    Phanixis TS Rookie Topic Starter Posts: 53

    Good too know. I will need to update that driver for the AC97. Odd that the two minidumps are the result of unrelated problems, and odd that I only have two minidumps total, as I have had far more crashes.
  25. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Keep in mind as stated before: Memory corruption can cause all kinds of issues.

    Why you are not getting any more minidumps is strange. See if the following helps in the creation of minidumps:

    1. Right click My Computer > click Properties > click Advance tab

    2. The Advance Screen at the bottom right has Error Reporting. Click this on.

    3. Click Enabled error reporting and also check both boxes underneath: Windows operating system and Programs.

    4. Now click Choose Programs and click All Programs. Then click Okay and that screen will close. At the next screen click Okay and that will close.

    5. You are back to the Advance screen. Find the Start up and Recovery which has underneath it System startup, system failure, and debugging information. Click the Settings box.

    6. Another screen will open. You want the System failure section. Enable all three boxes.

    7. Under these boxes is Write debugging information. Choose the option Small memory dump (64kb). Click OK and that screen will close.

    8. Click OK one more time and you'll be finished. Now the ability for your system to write minidumps should be enabled.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...