Boot failure - insert system disk

By Loetje · 4 replies
Dec 25, 2010
Post New Reply
  1. COMPAQ Presario from 2005. MSI 7184 motherboard. 2 SATA disks, one optical IDE drive. XP. Has been working fine for 5 years. Then got ‘boot failure – insert system disk’. Booting again fixed it, but not for long, it is solid now.

    Going into setup (AWARD, rather few options) I see only the optical disk (which is on an IDE controller) being recognized, the other ports showing ‘None’. Detecting the disks makes no difference. I can hear the disks go ‘click’ on power up and they spin. I tried the following:

    1) Switched cables (using the existing cables). Switched the system disk to the other (secondary disk) SATA slot. Switched cables again. Took out the secondary disk. Switched slots and cables for the remaining system disk. For the rest of the story I did not connect the secondary disk again.
    2) Reset MB config. Looks like it was running with the defaults as I saw no changes in the disk and controller enabling settings
    3) Took out the battery. For good measure. I don’t think this resets a lot.
    4) Put the system disk in another PC. It booted fine.
    5) Connected an old system disk with W98 on it, but to the IDE cable. Booted fine.
    6) Found the latest (2006) BIOS version on an HP website and flashed it, using the W98 disk. The update went fine, according to the software.
    7) Booted from an XP CD (mine, not the original one), went into repair, tried FIXBOOT and FIXMBR.With the original system disk in it, of course.
    8) Booted from my CD and pretended a Windows install. Hit F6. But I do not have any SATA drivers, if they would have been needed at all (anyone know?) and the XP disk did not provide any help here.
    9) Finally found an SATA disk and connected it to the board. Same problem.

    I would not have posted this if I could find another MSI 7184 board, but I can’t. It is even difficult to find a MB with a socket 939 and the options I need.

    Question: Did I miss anything? I do not have a known, working SATA disk other than Unlikely that 2 cables went failing at the same time. The system disk boots in another box. Another, known good, disk gets the same boot failure.  Serial ATA controller, right?

    Thanks for any help, new ideas or a replacement board for this machine. The HP product number is SR1579FR, btw.
  2. Loetje

    Loetje TS Rookie Topic Starter

    RE.: Previous

    I forgot: I am in the south of France
  3. captaincranky

    captaincranky TechSpot Addict Posts: 13,031   +2,558

    I think you meant to say, "I am een zee souce of Frahnce".

    It's also possible that the SATA drivers have been corrupted.

    Does the SATA controller even show up in BIOS?

    Do you have the option to run your HDDs as IDE? (This would be under the "integrated peripherals" section of an Award BIOS)

    One thing that isn't clear, did this machine come with "restore discs", or an actual Windows disc?

    If it originally had restore discs, then the SATA drivers would have been slip streamed into those discs. This explains why you can't find them. You could also check Compac's website, to see if the drivers are offered for this machine.

    With that out of the way. It's certainly possible for your SATA controller to have failed, given the age of the machine. In fact, if I were dealing with this issue, I probably might be thinking along those lines by now also.

    At five years of age, it's also possible, (but perhaps not likely), that the system battery has failed. Other symptoms of that might be the clock changing time. You are likely correct that, "it doesn't reset much". The run setting of the BIOS in a pre-built computer, isn't that far off of the defaults.
  4. Loetje

    Loetje TS Rookie Topic Starter

    Need to have SATA

    Hi Captain Cranky,

    I see the 4 slots for the SATA ports in the BIOS and there is a line on turning on the IDE/SATA controllers.

    The HDD’s do not have the slots for the IDE bus, so can not connect them to the IDE controller.

    I do not have the restore disk. The PC is not mine and the person owning it does not have it. I did not look at the COMPAQ site for any SATA drivers – just looked for the latest BIOS. I will make another effort to locate them, assuming they are needed.

    Thanks for the reply.
  5. Loetje

    Loetje TS Rookie Topic Starter

    No SATA drivers

    There are no SATA drivers posted for this products on the HP site.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...