Brand new Hitachi HDD not showing in BIOS, but shows in Device Manager and Disk Management

By koat88
Oct 12, 2016
Post New Reply
  1. Ordered THIS drive from Newegg. Received it yesterday and mounted it to my case, hooked it up with a SATA cable to motherboard, and a SATA power cable from my power supply. Noticed the drive wasn't showing up in the BIOS, however it was appearing in Windows Disk Management as (Disk 1), my main dive (Disk 0) is a 250GB Samsung 750 EVO SDD. Also it was showing as Unknown Disk with 0GB of space in Windows Device Manager. I then opened Disk Management, and as soon as it opened it automatically prompted me to initialize the drive as GPT, I attempted to do this and got the error message "The specified disk is not convertible because the size is less than the minimum size required for GPT disks." I then attempted to initialize it in MBR mode, then received this error message "The system cannot find the file specified."

    So far I have tried using different brand new sata cables, tried different motherboard sata ports, and tried uninstalling/reinstalling the drive and drivers. None of this has seemed to work. I am wondering if it is just a bad drive. Please help me out if you can. Thanks for reading!

    Here are the rest of the specs on my system (Which I just built last week)

    Windows 10
    MSI Z170A SLI Motherboard
    Core i3 6100
    MSI ARMOR GTX 1060 6GB
    16GB GSkill Ripjaws V
    250GB SSD (Samsung 750 EVO)
    750W EVGA Supenova B1 Semi-Modular PSU
  2. koat88

    koat88 TS Rookie Topic Starter

    Guess ill just RMA it.
  3. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    So did you RMA it? I'm curious if this took care of the issue

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...