1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Brand new laptop: Wireless worked at the start, now it doesn't

By Route44 · 10 replies
Aug 17, 2011
Post New Reply
  1. Long story short: Received my new laptop on Monday and I installed Windows 7 and the Drivers on Tuesday. I was able then to connect to the internet wirelessly in another room in my house.

    My router is a 6 year old + wired Linksys G router and in order to provide wireless in my home I set-up a TrendNet Access Point N a year and a half ago. Though there are times that I need to periodically reboot we can access the internet anywhere in the house on our laptops.

    The laptop at the beginning connected fine recognizing the TrendNet and the signal was strong. I then installed Windows Updates, Microsoft Essentials and the latest Adobe Flash. By the way, the W7 firewall was enabled from the beginning.

    After a time I shut it down but when I came back this system will not connect at all.

    1. It shows that the system is connected to the Access Point with a strong signal but when I go to connect to the internet wirelessly it constantly says that there is a problem.

    2. Diagnosis says it’s my modem, access point, or router. So I reset them at least five times but nothing has changed. Besides, my two PC's have no trouble connecting to the internet. Two Lenovo laptops have no trouble connecting to the internet throughout the house. I even fired up my 8 year old Toshiba Tecra S1 using a TP Link USB adapter at the opposite end of the house and it connects.

    3. Diagnosis diagram shows connection from Access Point to laptop but no connection from laptop to internet.

    4. I did a system restore as I only installed the Adobe Flash and Microsoft Essentials. When it finally rebooted the only thing I reinstalled was MSE. I even set things to default. But the problem persists.

    5. The Device Manager recognizes my wireless card and reports that it is functioning properly.

    6. With one exception the Intel Wireless Pro Drive/Software diagnostics tool reports that every test passed including Signal Test which gives an Excellent quality rating.

    7. What it has failed is the Ping Test.

    * I would appreciate any help you can give because I am really out of my element here. This laptop is for my son who will be entering college this fall and so I need it to be able to access wirelessly. By the way it does connect via ethernet cable.
  2. jobeard

    jobeard TS Ambassador Posts: 12,494   +1,431


    if it shows the current IP address as 169.x.x.x then the issue is not finding
    (or being blocked from sending/receiving ) the DHCP service in the router.

    ALSO, if you see an IP address like 0db8:85a3:0000:0000:8a2e:0370:7334
    then you have IPv6 enabled on the laptop;
    1) google for disable ipv6
    2) apply the solution for your {XP,Vista,Win/7} laptop

    reboot and reconnect
  3. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 11,974   +74

    Your response is much appreciated. I am in the process of carrying out your advice. It appears ipv6 is enabled. Question: Should I leave ipv4 enabled?

    Also, in setting up this laptop I also set up a Home Group. Why? I haven't a clue. Would this cause the system to enable the ipv6 setting?

    UPDATE I deleted the HomeGroup)

    1. MS has a real nice tool that disables IPv6. It is quick and easy.

    2. Ran IPCONFIG/ALL after doing so and only IPv4 is enabled.

    3. The Wireless Internet Connection shows connectivity with IPv4 and no network access with IPV6 Connectivity. Media Sate: Enabled. SSID: TrendNet. Signal Strong at 87.0 MPS

    4. Yet the Intel Wireless Tool states That the Ping Test still fails: No Response: default gateway, DHCP server.

    5. When Windows makes a map of Wireless Network Connection -Trendnet it shows connection from the Laptop to TrendNet to gateway but then a Red X between the Gateway and the World Wide Web (in global form). When I click on this Red X the diagnosis says it couldn't identify the problem. The there are times it shows that the Gateway and the WWW are connected!

    *** Now here is the real kicker. The Intel Wireless Tool ran diagnostics and said the adapter was not connected and proceeded to fix it. Yet I still couldn't connect. So I tried connecting to a neighbor's Netgear that isn't encrypted with just two bars showing and I connected to the internet!

    And I can't connect three feet away.
  4. jobeard

    jobeard TS Ambassador Posts: 12,494   +1,431

    ABSOLUTELY. Any router/access point can do IPv4, very few do IPv6
    NO, deal with that latter - - that's a Print/File sharing settings
    this means you have connected system->gateway - X - ISP(WWW)
    this would appear to be your real problem and accounts for the PING issue too
    that confirms your connection to the Internet is the issue, not your system (after the removal of IPv6))
  5. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 11,974   +74

    Sorry, when I said there is no network access with IPv6 I was referring to after I ran Microsoft's utility that disabled it. Prior it was enabled as the IPCONFIG/A showed with this kind of address that you gave as an example: 0db8:85a3:0000:0000:8a2e:0370:7334

    I am looking into jettisoning my current set-up and going with a Wireless N system. Still, it really bugs me why two Lenovo Edge laptops and my old Toshiba that I mentioned can connect and this with a much better wireless card can't now but did so in the beginning.

    So if the system is not the issue and the internet connection is an upgrade to Wireless N as I mentioned is probably a wise move.

  6. jobeard

    jobeard TS Ambassador Posts: 12,494   +1,431

    When a laptop has BOTH wired & wifi, it can get confused.

    Always DISABLE the device you are not using before attempting to use the other one.

    Meanwhile, disable the wifi and get a wired connection to your router.
    This will show that the basic router is SANE or INSANE. This should be easy and
    you should be able to ping (which is google's DNS address).

    Use your browser to access the router config page and verify the WiFi is enabled.

    Now, disconnect and disable the wired NIC, enable the WiFi.
    Attempt a connection to your SSID;
    • did you see it?
    • can you connect to that SSID?

    Now get the command prompt and ping again.
    If A+B are good and you can ping google, then ping google.com. (trailing DOT)
    This one forces DNS lookup for the website address and success here means your browser should be working too . . .
  7. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 11,974   +74

    Again, thanks for the response. Your advice is very much appreciated. This will take me some time because this is absolutely new territory for me. I can tell you that the wired connection does work on the laptop and that the router itself is a wired one.

    I forgot to mention that last night I was having issues with my Linksys. It was going haywire causing my AP to blink rapidly and my PC couldn't connect and that is connected via ethernet cable.

    As I think I might have mentioned I have been finding myself having to reboot it more and more.

  8. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 11,974   +74

    jobeard, I wanted to give you an update. After attempting to ping my TrendNet N Access Point through 2 PCs and four laptops via the browsers IE, FireFox, and Chrome and not being able to connect with any I decided to jettison my wired Linksys G and this Access Point.

    Amazingly 3 out of four laptops could still connect wirelessly.

    Anyway, I now have a new Netgear N600 dual-band wireless router and now all laptops can connect including my son's at the 5GHz band.

    Just wanted you to know and thanks.
  9. tipstir

    tipstir TS Ambassador Posts: 2,839   +193

    Good to hear you okay now. Trend-net stuff seem to give all sorts of issues. I've told trendnet several times but their management don't get it. DNS issues and drops in WiFi just cause issues. I see you had gone with Netgear I decided to go with Cisco Linksys E4200 and Cisco Linksys RE1000. No issues.
  10. Rocket

    Rocket TS Rookie

    Route44, the problem was not your LAN. You didn't have to replace anything. I have the exact same problem with my wireless laptop, even though it works wired. Your other computers ensured you several times that your network was working properly and that your one laptop stopped working. Mine stopped working when one day I decided I wanted WPA2 personal AES encryption instead of the ordinary WPA-PSK with TKIP encryption. This thows the wireless adapter into a tail spin for some reason. I have the Intel(R) Centrino(R) Wireless-N 1000 and a D-Link DIR-615 wireless router and the exact same issue you had.

    When the diagnostic told you the problem was in the router and modem and to reboot them, this was wrong as usual and you set out to prove it by rebooting them and nothing changed (because nothing was wrong with them, your other laptops proved it).

    I have not found a solution for this problem but its hardware related and Realtek needs to take ownership of the problem because its the Wireless LAN adapter that has stopped talking to the Realtek PCIe ethernet controller. I have since changed back to wpa-psk TKIP settings, though less desireable because it is a lower security setting, and that part works consistently.

    P.S. No amount or system restoring will change your wireless adapter settings, you have to change them manually every time.
  11. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 11,974   +74

    Actually I believe the number one problem is that the laptop I spoke of was/is old and it was/is failing. Not only did I try it with the TP LInk adapter but with the factory settings with the onboard NIC as well as a Belkin PCI card without any luck not only at home but other places as well. As for my old modem and router they were dropping in and out regardless of the system attached either through the ethernet cord or wirelessly.

    I have purchased a brand new Lenovo Thinkpad T430 and all is good with my Netgear router and Motorola modem. Connections are so much faster and consistent.

    *** Let me know if you ever find a solution.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...