BSOD / Page fault / ntoskrnl.exe

By LeifGR ยท 4 replies
Apr 25, 2007
  1. My first post to this forum (joined today), so hope I get this right.

    My wife has a laptop that has suddenly developed a problem.

    When using an external projector, the machine will - most of the time and in varying situations - blue-screen with messages akin to PAGE_FAULT_IN_NONPAGED_AREA. This is a new problem, as she has been using the same projector with this laptop for years. The error seems to be related to switching the laptop's output to/from the external projector.
    The error message I got when trying to recreate my wife's problems is:
    Address 8045ABB3, base at 80400000, Date Stamp 45ec3c8f - ntoskrnl.exe

    Toshiba Portege 2000 running Windows 2000 Professional, version 5.0.2195 Service Pack 4 Build 2195.
    Processor x86 Family 6 Model 11 Stepping 1 GenuineIntel ~746 Mhz
    Memory 256Mb
    Video adapter: Trident Video Accelerator CyberBlade XP Ai1 v5.9030-008M.22ICD, driver: Trident 5.0.2195.139, date 1/28/2002

    What I have tried
    Ran WinDbg (result attached)
    Searched forums for issues related to ntoskrnl.exe
    Checked that the video driver is the latest one recommended by Toshiba (it is)
    Ran a disk check and defrag
    I am unable to run a memory test as the Portege has no floppy or CD drive, is not capable of booting from a USB stick, the PCMCIA CD drive I have that it will boot from does not seem to read CD-ROMs created on my main system and I can't find my USB floppy...

    It seems logical that the problem would lie with the video adapter, but as I said it is the right one. Can these things just get corrupted spontaneously? How do I check?

    My wife depends on this system to do her freelance lecturing work and any help would really be appreciated. Handing it over to the local PC shop is likely to screw more things up than it will solve...

    WinDbg result
    A few minidumps
    msinfo32 output

    Attached Files:

  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    You have a significant boot error, that could be a failed hard drive, or failed memory, or bad CMOS battery. This error is not for people who not deal with it routinely. The error message usually pops up when there is an error in the boot.ini file. The entry for NT is either missing or incorrect. You can edit the boot.ini file and check the entry for NT is correct, for example for an IDE disk the entry should look something like
    multi(0)disk(0)rdisk(0)partition(2)\winnt="Windows NT workstation"

    You can sometimes check to see if the disk and partition are correct. If you have recently added a new disk or altered the partitions try changing the disk() and partition() values.
    Some kind of failure usuallyu caused this, but it could be a major hardware failure or a simple bit of software corruption.

    Whatever it is, you are most likely going to need a major fix. If you have the full version of Windows 2000, you can insert it and run it in repair mode.

    You can insert a new hard drive, and install all your software.

    Then put the bad hard drive in a desktop as Slave, using an adapter. Then rescue all the data by drag and drop to the desktop hard drive.

    If you have a friend who is a good technician, he or she can probably trudge through everthing and create a fix. The problem is, not too many people remember the technical details of Windows 2000 Professional.

    If you are sure everything is OK on the hard drive, then you may just have corruption of the actual NTOSKRNL.EXE, you can copy NTOSKRNL.EXE off of the installation CD onto the %systemroot%/system32 directory.

    Another choice would be to upgrade to Windows XP Home, but the OEM version will wipe out everything on the disc.

    Others more skilled on this forum, or more experienced with Windows 2000 may be able to create simpler fixes.

    This could also be caused by an infestation, or corrupted files related to the projection software, but I doubt it.
    If the computer is three years old, or more, I would replace the CMOS battery as well.
  3. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

  4. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

    All the dumps crash at srescan.sys, which is a part of Zonealarm. See if there's an update for Zonealarm. If you're only using the Firewall then you don't need this file.

    BugCheck 50, {f000ff54, 0, 8045abb3, 0}
    Probably caused by : srescan.sys ( srescan+5fb1 )
    Image name: srescan.sys Timestamp: Tue Jan 16 07:16:30 2007 (45ABFD3E)
  5. craiu

    craiu TS Rookie

    Uninstall Zonealarm, kill srescan

    Hi guys,

    I had exactly the same problem on my laptop and managed to trace it down to Zonealarm. Unfortunately, uninstalling ZA wasn't enough - for some unknown reason, srescan (and other ZA files) was left in system and I had to remove it manually, from disk and registry.

    Once srescan was gone, everything worked like a charm.

    Instead of Zonealarm I installed Kerio and we've lived happily ever since. :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...