1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

BSOD while playing Warcraft III

By Keven ยท 8 replies
Mar 3, 2009
  1. Hi, Im randomly getting BSOD:s while playing Warcraft III. So I have downloaded Windbd and loaded the crash dump files that i get when it crashes:

    Microsoft (R) Windows Debugger Version 6.11.0001.402 X86
    Copyright (c) Microsoft Corporation. All rights reserved.

    Loading Dump File [C:\WINDOWS\Minidump\Mini030309-01.dmp]
    Mini Kernel Dump File: Only registers and stack trace are available

    Windows XP Kernel Version 2600 (Service Pack 3) MP (2 procs) Free x86 compatible
    Product: WinNt, suite: TerminalServer SingleUserTS
    Built by: 2600.xpsp_sp3_gdr.080814-1236
    Machine Name:
    Kernel base = 0x804d7000 PsLoadedModuleList = 0x8055d720
    Debug session time: Tue Mar 3 04:13:19.766 2009 (GMT+1)
    System Uptime: 0 days 7:15:08.737
    Loading Kernel Symbols

    Loading User Symbols
    Loading unloaded module list
    Unable to load image RtkHDAud.sys, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for RtkHDAud.sys
    *** ERROR: Module load completed but symbols could not be loaded for RtkHDAud.sys
    * *
    * Bugcheck Analysis *
    * *

    Use !analyze -v to get detailed debugging information.

    BugCheck 1000008E, {c0000005, ae38309b, aa97f70c, 0}

    Probably caused by : RtkHDAud.sys ( RtkHDAud+7d09b )

    Followup: MachineOwner

    1: kd> !analyze -v
    * *
    * Bugcheck Analysis *
    * *

    This is a very common bugcheck. Usually the exception address pinpoints
    the driver/function that caused the problem. Always note this address
    as well as the link date of the driver/image that contains this address.
    Some common problems are exception code 0x80000003. This means a hard
    coded breakpoint or assertion was hit, but this system was booted
    /NODEBUG. This is not supposed to happen as developers should never have
    hardcoded breakpoints in retail code, but ...
    If this happens, make sure a debugger gets connected, and the
    system is booted /DEBUG. This will let us see why this breakpoint is
    Arg1: c0000005, The exception code that was not handled
    Arg2: ae38309b, The address that the exception occurred at
    Arg3: aa97f70c, Trap Frame
    Arg4: 00000000

    Debugging Details:

    EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - Instruktionen p "0x%08lx" refererade till minnet p "0x%08lx". Det gick inte att utf ra en minnes tg rd. F ljande fel returnerades: The memory could not be "%s".

    ae38309b 8990ac000000 mov dword ptr [eax+0ACh],edx

    TRAP_FRAME: aa97f70c -- (.trap 0xffffffffaa97f70c)
    ErrCode = 00000002
    eax=00000000 ebx=aa97f9ec ecx=88f75028 edx=00000001 esi=8932a6e0 edi=88f75574
    eip=ae38309b esp=aa97f780 ebp=aa97f784 iopl=0 nv up ei ng nz na pe nc
    cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00010286
    ae38309b 8990ac000000 mov dword ptr [eax+0ACh],edx ds:0023:000000ac=????????
    Resetting default scope




    PROCESS_NAME: war3.exe

    LAST_CONTROL_TRANSFER: from ae33debf to ae38309b

    WARNING: Stack unwind information not available. Following frames may be wrong.
    aa97f784 ae33debf 00000000 88f2eee0 8932a6e0 RtkHDAud+0x7d09b
    aa97f9e0 ae2f497d ae2f4872 00000000 ae2f497d RtkHDAud+0x37ebf
    aa97fa04 ae2f49cf 88eee398 88f2eee0 e1a52d8c portcls!PcDispatchProperty+0x130
    aa97fa2c f67b0f5c 00000004 88f7b2f8 88f7b2f0 portcls!PropertyItemPropertyHandler+0x2b
    aa97fa90 f67b0ed9 88eee398 0000000c e1a52d8c ks!KspPropertyHandler+0x616
    aa97fab4 ae2f26a9 88eee398 0000000c e1a52d00 ks!KsPropertyHandler+0x19
    aa97fac8 ae2ff70f 88eee398 0000000c e1a52d00 portcls!PcHandlePropertyWithTable+0x1b
    aa97fb00 ae2f274d 88f2ee60 8a04c030 88eee398 portcls!CPortPinWaveCyclic::DeviceIoControl+0x1e5
    aa97fb1c f67b0f1f 8a04c030 88eee398 aa97fb44 portcls!DispatchDeviceIoControl+0x49
    aa97fb2c ae2f28c0 8a04c030 88eee398 8a04c0e8 ks!KsDispatchIrp+0x126
    aa97fb44 ae2f2881 8a04c030 88eee398 aa97fb78 portcls!KsoDispatchIrp+0x43
    aa97fb54 ae735100 8a04c030 88eee398 00000000 portcls!PcDispatchIrp+0x5f
    aa97fb78 804ef19f 8a04c030 00000004 88eee398 RtkHDAud+0x42f100
    aa97fb88 abc5f774 e1847bb8 00000000 88eee398 nt!IopfCallDriver+0x31
    aa97fbd8 abc622a2 88eee398 88f7b2f8 e1542998 sysaudio!ForwardIrpNode+0x1b2
    aa97fc30 f67b0f95 895a0408 88eee398 aa97fc64 sysaudio!CPinInstance::pinDispatchIoControl+0x153
    aa97fc40 804ef19f 895a0408 88eee398 806e6410 ks!DispatchDeviceIoControl+0x28
    aa97fc50 8057f982 88eee4e0 891ae2a8 88eee398 nt!IopfCallDriver+0x31
    aa97fc64 805807f7 895a0408 88eee398 891ae2a8 nt!IopSynchronousServiceTail+0x70
    aa97fd00 80579274 00004d10 0000438c 00000000 nt!IopXxxControlFile+0x5c5
    aa97fd34 8054162c 00004d10 0000438c 00000000 nt!NtDeviceIoControlFile+0x2a
    aa97fd34 7c90e4f4 00004d10 0000438c 00000000 nt!KiFastCallEntry+0xfc
    0012f434 00000000 00000000 00000000 00000000 0x7c90e4f4


    ae38309b 8990ac000000 mov dword ptr [eax+0ACh],edx


    SYMBOL_NAME: RtkHDAud+7d09b

    FOLLOWUP_NAME: MachineOwner


    IMAGE_NAME: RtkHDAud.sys


    FAILURE_BUCKET_ID: 0x8E_RtkHDAud+7d09b

    BUCKET_ID: 0x8E_RtkHDAud+7d09b

    Followup: MachineOwner

    Im using the lastest Realtek HDA Audio drivers (R2.17), and i have tried 2 earlier versions aswell and still experiensing the same problem...
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Well 0x8E errors are almost always caused by hardware though sometimes by drivers.

    The RealTec driver RtkHDAud.sys was cited as the probable cause but as you note in your post you've tried several versions.
  3. Keven

    Keven TS Rookie Topic Starter

    I have just ran Memtest86+ 2.11 and get no errors.
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Are you updating directly from Realtec or did you update these drivers via Asus' website?
  5. Keven

    Keven TS Rookie Topic Starter

    Directly from realtek...
  6. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Try updating from Asus for your motherboard. I've seen where people have tried to update from Realtek and experience the same issues as you butwhen they go through their mothrboard manufacturer's website it works.

    Give it a try.
  7. Keven

    Keven TS Rookie Topic Starter

    I have installed the asus drivers and it still crashes with the same BSOD message...
  8. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Attach that minidump.
  9. Neonic

    Neonic TS Rookie Posts: 24

    I had a similar problem with World Of Warcraft, the game would only run in windowed mode ( -windowed in the program shortcut). The error would refer to my soundcard drivers in the same way (Audigy 2). I just noticed the Stop error u got is almost identical to the one i was getting.

    I tried many things to fix it, the problem went away after i did 2 things:

    1) Removed Graphic Driver and did a full clean with DriverCleaner & Reinstalled Drivers
    2) Loaded Failsafe options in my BIOS. *I think this is actually what fixed it but cant be sure.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...