BSOD Win32k.sys, ntkrnlmp.exe, appwiz.cpl

By darkan9el ยท 7 replies
Jan 17, 2008
  1. Hi all, I have recently restored XP in a PC. I have also added some crucial memory (2x512Mb) this makes it 2Gb in all. and I have also added a samsung Spinpoint 500Gb HDD. The PC has a PSU rated at 315w not sure on the +12 rail but can look it up. the PC also has a FX5900 which requires power. I'm think part of the problem could be an under-powered system. The motherboard is an ASUS P4C800 Deluxe

    since recovering, I have got some BSOD and a flaky add and remove problem.

    I have looked at the minidump files and to be honest I'm not really sure what I'm looking at. several dumps refer to win32k.sys and also ntkrnlmp.exe the rest reference memory corruption.

    The BSODS are 8e, 0a and I think 22 or 24 error codes.

    The appwiz.cpl issue comes up as:
    any advice or help will be appreciated

    Regards Lee

    Attached Files:

  2. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    When i read several minidumps with so many varied minidump errors my first suspicion is faulty RAM. The last minidump you gave said memory corruption.

    Did these errors occur after you put the Crucial in? Crucial is excellent memory but their Ballistix opfferings in PC 3200 and 4000 from 2005 were yanked from the market because so many people experienced RAM failure after 6 months.

    I was one of them and I ran my memory configuration in 4x512 = 2 GB.

    Run ChkDsk.

    Run MemTest.

    Have you scanned for viruses, malware, spyware?
  3. darkan9el

    darkan9el TS Rookie Topic Starter Posts: 20

    Hi, I personally, have 2 gig of crucial ballistix in my system and I had to send some back, which, considering its supposed to be high quality confused me a little. the memory i received as replacement has been in my system for a few months now and runs very well.

    The memory I have installed in the PC that has these issues is crucial PC3200 but standard crucial.

    I haven't run memtest yet but will be doing on Saturday, I'll remove the crucial memory and scan the older memory first, then remove them if they are ok and scan the crucial memory, I suppose it could also be a conflict between different makes of memory?

    I will run a chkdsk, but I did that before the recovery and it came up fine,

    As for Malware I installed AVG free and let it scan the system on first install. I did notice on one of the minidumps it referenced some avg files.

    Bit of History on this PC
    I was recovering the system because this guy was getting errors, but he did a silly thing and made all the system32 files read only (go figure!) but he had access issues with his files anyway, I suspected malware mainly but I think in his frustration he did the majority of the damage. So I removed what files I could; mainly pictures, and recovered the system. I am always a bit dubious about recovery systems, they never seem to recovery cleanly.
    I installed the memory before I recovered the system and didn't have any issues during recovery. Everything in the device manager is installed correctly; no exclamation marks, so drivers and hardware appear to be functioning normally. I did have cause to remove a program I installed after the recovery but that was just one of my utilities I use, this was when I got the appwiz issue.
    I am still mulling over the idea that these issues are PSU related, I think considering his spec the PSU is a under powered and it didn't look like a quality PSU that would have a good amperage on the +12 rail I'm guessing it probably gives about 10a will find out more Saturday.

    Regards Lee
  4. darkan9el

    darkan9el TS Rookie Topic Starter Posts: 20

    Hi just a bit of feedback from todays testing.

    Ok the memory installed was called 'Ram bo' (very witty) it was PC3200 and the timings were 3338 I installed some crucial memory PC3200 and the timings were 3338. So, at the moment I have all four slots filled and this is the configuration. The memory is running in dual mode and both memory pairs are matched pairs.

    • Slot one (Blue) = Ram Bo
    • Slot two (Black) = Crucial
    • Slot three (Blue) = Ram Bo
    • Slot four(Black) = Crucial

    I Ran microsoft's memtester first and the results came back with no errors.

    Next i ran memtest this came up with errors, 121 to be exact, on the first pass at the end of test 5. I did it again and it came up with 16 errors again at the end of test 5

    I removed the 'Ram Bo' memory and tested just the crucial memory(no errors)
    I replaced the Ram Bo' memory with the crucial memory and tested (no errors)
    I put all my ballistix memory into all four slots (no errors)
    I put two of my ballistix memory sticks in with the crucial (no errors)
    I put two of my ballistix memory sticks in with the Ram bo (no errors)

    I've pretty much done all the configurations possible and the only time I get memtest errors are when both the Ram Bo memory and the Crucial Memory are installed together. So I'm thinking its just one of those things, Its not that any memory is faulty its just that the Ram bo and the crucial PC3200 don't work well together.

    I wonder if I can alter the timings to a slower pace to see if that effects the errors. Any recommendations?

    Leaving just the crucial memory in and going to boot into windows now and see if we can get any windows errors with the add and remove module.

    Ps: checked the PSU and it has 17A on the +12 rail and the voltages are all good so I'm going to drop that as a possible cause... for now!

    regards Lee
  5. darkan9el

    darkan9el TS Rookie Topic Starter Posts: 20

    Been using windows since last post and system was rock solid (using only the new crucial memory)

    Been playing with Office 2007 and Photoshop CS3... no crashes!
  6. mscrx

    mscrx TS Rookie Posts: 310

    I think its just a question of compatibility and it seems that the crucial ones are not the best friends of the other guys.
  7. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Good to hear! It certainly sounds like you've done your work. By the way, are those Crucial Ballistix by any chance?
  8. darkan9el

    darkan9el TS Rookie Topic Starter Posts: 20

    Route44: No, the crucial I installed on the buggy system were just standard crucial from

    I have also found the Ram Bo memory site... I think!

    I have noticed the Ram Bo runs with v2.5 and the crucial is 2.6v although I did mix the standard memory with my ballistix and it ran fine and their respective voltages were v2.6 and v2.8.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...