BSODs 0x24 and 0x4E with an ASUS P5Q-E

By liver ยท 5 replies
Sep 26, 2008
  1. Hello,

    I've come here as my last solution... since Microsoft support and ASUS support couldn't help me... If any of you could help me, I'd be very grateful!

    I have been experiencing problems since I constructed this new computer 2 weeks ago. My problem is that, often, when copying a folder from my IDE Samsung hdd to my SATA-II Seagate hdd, I get the Stop error with the code 0x24, indicating the Ntfs.sys driver.
    Also, often when deleting a folder from the Seagate drive, after all the files have been deleted and all that is left to remove is the empty folder, I get the Stop error 0x4E. I must say that, in each case that I had these errors, the FAILURE_BUCKET_ID and most of the STACK_TEXT was the same for all errors of the same type! For the 0x24, the FAILURE_BUCKET_ID was Ntfs!NtfsDereferenceQuotaControlBlock+11, and for the 0x4E it was nt!MmZeroPageThread+250.

    My system hardware specs are:
    Asus P5Q-E motherboard
    Intel Q9550 processor
    2x1GB Corsair TWIN2X-8500C5D 1066 Mhz (I left the default configuration in BIOS for these)
    Gigabyte Geforce 8600GT
    Seagate SATA-II 500GB (AHCI enabled in BIOS)
    Samsung SP2514N 250GB IDE (set as master, connected to the Marvell88SE61xx IDE port on the board)
    ASUS IDE DVD-RW (set as slave. connected to the Marvell port through the same cable as the Samsung HDD)
    Corsair 450W PSU
    I don't do any overclocking

    My system drivers and BIOS installed:
    I'm using Windows XP SP3
    BIOS version 1.1.0.L70d (this is what the board came with)
    Marvell SCSI/RAID controller v1.2.0.60
    Intel Matrix Storage Manager v800103
    Intel P45 ICH10R Chipset v9001009

    Things I've done to try to solve the problem:
    Ran CHKDSK. There were no problems found.
    Installed the latest drivers - the problem was not solved.
    Scanned for viruses and I didn't find any. (Scanned with Kaspersky)
    Checked the RAM with memtest86+ (3 passes), checked the Seagate HDD with Seatools... there were no problems found.

    I have yet to install the latest BIOS, because from what I saw on the ASUS site, most of the improvements listed were only for memory compatibility. But my Corsair memories are fully supported, as it is said in the User's Manual.

    I really hope you could help me. I've been struggling with this issue for almost 2 weeks! :(

    [B][U]NTFS_FILE_SYSTEM (24) [/U][/B]
    Arg1: 001902fe
    Arg2: bad23910
    Arg3: bad2360c
    Arg4: ba59cb9d
    Debugging Details:
    EXCEPTION_RECORD:  bad23910 -- (.exr 0xffffffffbad23910)
    ExceptionAddress: ba59cb9d (Ntfs!NtfsDereferenceQuotaControlBlock+0x00000011)
       ExceptionCode: c0000005 (Access violation)
      ExceptionFlags: 00000000
    NumberParameters: 2
       Parameter[0]: 00000000
       Parameter[1]: 00000005
    Attempt to read from address 00000005
    CONTEXT:  bad2360c -- (.cxr 0xffffffffbad2360c)
    eax=00000001 ebx=879ee558 ecx=e13d9d64 edx=e1332818 esi=bad23a58 edi=80546934
    eip=ba59cb9d esp=bad239d8 ebp=bad23a08 iopl=0         nv up ei ng nz na pe nc
    cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000             efl=00010286
    ba59cb9d 8b5004          mov     edx,dword ptr [eax+4] ds:0023:00000005=????????
    Resetting default scope
    PROCESS_NAME:  System
    ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at "0x%08lx" referenced memory at "0x%08lx". The memory could not be "%s".
    READ_ADDRESS:  00000005 
    BUGCHECK_STR:  0x24
    LAST_CONTROL_TRANSFER:  from ba578c44 to ba59cb9d
    [B]bad23a08 ba578c44 88006100 e13d9d64 88006260 Ntfs!NtfsDereferenceQuotaControlBlock+0x11
    bad23a30 ba527587 879ee558 bad23a58 bad23a63 Ntfs!NtfsDeleteFcb+0x108[/B]
    bad23a7c ba548e7c 879ee558 88006100 e13d9cc8 Ntfs!NtfsTeardownFromLcb+0x1fd
    bad23ad4 ba5237a4 879ee558 e13d9d90 e13d9f28 Ntfs!NtfsTeardownStructures+0x125
    bad23b00 ba5466b5 879ee558 013d9d90 e13d9f28 Ntfs!NtfsDecrementCloseCounts+0x9e
    bad23b84 ba546454 879ee558 e13d9d90 e13d9cc8 Ntfs!NtfsCommonClose+0x398
    bad23c24 804ef18f 88006020 8794d3f0 00000002 Ntfs!NtfsFsdClose+0x21f
    bad23c34 b0e44d00 8794d400 882271d0 88489b08 nt!IopfCallDriver+0x31
    WARNING: Stack unwind information not available. Following frames may be wrong.
    bad23cdc b0e474e3 0026b948 8794d3f0 804ef18f klif+0x12d00
    bad23d30 805bb466 00489b08 00000000 88489af0 klif+0x154e3
    bad23d4c 805266ca 88489b08 00000000 00000000 nt!ObpRemoveObjectRoutine+0xe0
    bad23d64 8050a88a 806e6aa8 879eac20 80561db4 nt!ObfDereferenceObject+0x4c
    bad23d8c 8050c0c9 e345b590 00000000 89e33da8 nt!MiSegmentDelete+0xec
    bad23dac 805cff64 00000000 00000000 00000000 nt!MiDereferenceSegmentThread+0xa7
    bad23ddc 805460de 8050c022 00000000 00000000 nt!PspSystemThreadStartup+0x34
    00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16
    ba59cb9d 8b5004          mov     edx,dword ptr [eax+4]
    SYMBOL_NAME:  Ntfs!NtfsDereferenceQuotaControlBlock+11
    FOLLOWUP_NAME:  MachineOwner
    [B]IMAGE_NAME:  Ntfs.sys[/B]
    STACK_COMMAND:  .cxr 0xffffffffbad2360c ; kb
    FAILURE_BUCKET_ID:  0x24_Ntfs!NtfsDereferenceQuotaControlBlock+11
    BUCKET_ID:  0x24_Ntfs!NtfsDereferenceQuotaControlBlock+11
    Followup: MachineOwner
    [B][U]PFN_LIST_CORRUPT (4e)[/U][/B]
    Typically caused by drivers passing bad memory descriptor lists (ie: calling
    MmUnlockPages twice with the same list, etc).  If a kernel debugger is
    available get the stack trace.
    Arg1: 0000008f, The free or zeroed page listhead is corrupt
    Arg2: 00062008, new page
    Arg3: 0007f188, old page
    Arg4: 00000000, 0
    Debugging Details:
    BUGCHECK_STR:  0x4E_8f
    PROCESS_NAME:  System
    LAST_CONTROL_TRANSFER:  from 8051cbb4 to 804f9f33
    [B]bacc37f8 8051cbb4 0000004e 0000008f 00062008 nt!KeBugCheckEx+0x1b
    bacc3840 80698b94 89e404b0 00000000 00000044 nt!MmZeroPageThread+0x250[/B]
    bacc3dac 805cff64 80084000 00000000 00000000 nt!Phase1Initialization+0x1288
    bacc3ddc 805460de 8069790c 80084000 00000000 nt!PspSystemThreadStartup+0x34
    00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16
    8051cbb4 cc              int     3
    SYMBOL_NAME:  nt!MmZeroPageThread+250
    FOLLOWUP_NAME:  MachineOwner
    [B]IMAGE_NAME:  memory_corruption[/B]
    FAILURE_BUCKET_ID:  0x4E_8f_nt!MmZeroPageThread+250
    BUCKET_ID:  0x4E_8f_nt!MmZeroPageThread+250
    Followup: MachineOwner
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Boy, you did everything I would have suggested except MemTest should be run with a minimum of 7 PASSES. I don't know if this will help but perhaps the following information can help:

    0x0000004E: PFN_LIST_CORRUPT
    This indicates that the memory management Page File Number list is corrupted. Can be caused by corrupt physical RAM, or by drivers passing bad memory descriptor lists. Your read-out shows corrupted memory.

    0x00000024: NTFS_FILE_SYSTEM
    A problem occurred within NTFS.SYS, the driver file that allows the system to read and write to NTFS file system drives. There may be a physical problem with the disk, or an Interrupt Request Packet (IRP) may be corrupted. Other common causes include heavy hard drive fragmentation, heavy file I/O, problems with some types of drive-mirroring software, or some antivirus software. I suggest running ChkDsk or ScanDisk as a first step; then disable all file system filters such as virus scanners, firewall software, or backup utilities. Check the file properties of NTFS.SYS to ensure it matches the current OS or SP version. Update all disk, tape backup, CD-ROM, or removable device drivers to the most current versions.

    I wonder if your IDE set as Master isn't causing conflict with your SATA. I have seen this often where an IDE/SATA conflicts. Why, I don't know but as I said I've seen it before.

    Also, are you doing any overclocking? If you are try easing back on your timings.
  3. liver

    liver TS Rookie Topic Starter

    I will run Memtest for at least 7 passes, as you suggested.

    About the IDE set as master, should I make it be slave? Can it be slave if the other IDE device, the DVD, is set as slave too?
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    I suggest running your DVD and your Samsung HD separate from each other.
  5. liver

    liver TS Rookie Topic Starter

    The cause was an incompatibility between the Intel Q9550 and the BIOS (v901 or later). I solved it by setting CPU Margin Enhancement to "Performance Mode" instead of "Optimised Mode" (default setting).

    Thanks for trying to help.
  6. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Thanks for getting back to us. This information is helpful for other people.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...