Cannot access a Windows XP PC from a Windows 7 PC

By Mark56 ยท 4 replies
Apr 1, 2011
Post New Reply
  1. Tried every fix I can find, there has to be a way to do this.

    Windows XP Pro SP3 (very old and slow PC) can see the shared files on the Windows 7 Home PC on a wireless home network. But not the other way around.

    Everything is set as it should be, both have the same workgroup name and different computer names. I have plenty of experience fixing other problems but this one has got me well and truly stuck.

    Any suggestions would be most appreciated.
  2. Mark56

    Mark56 TechSpot Paladin Topic Starter Posts: 1,886

    I have made some advance with this now. The windows XP machine had the exceptions disabled in the firewall. Now that is enabled I can ping the XP from the win7 PC.

    Now when I try to access the XP machine from the win7 PC it says I don't have permission, yet all the permissions are set for the Shared Documents folder and the C: drive on the XP PC. What else could it be?

    I set this up with my own XP and win7 PC's and it worked simply by setting the name of the Workgroup to the same on both PC's and making it a Work share instead of Home on the win7, I didn't have to change anything else.
  3. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    XP/SP3 needs the LLTP service running
  4. Mark56

    Mark56 TechSpot Paladin Topic Starter Posts: 1,886

    Thanks for that but it already is. Just for the record It's LLTD (not P) Link Layer Topology Discovery and is included in SP3.

    I've been back on the PC's and double checked all permissions are set and even tried creating an new user account on the win7 PC with the same name and password as the account on the XP, but no change.

    I am told that another person who worked on the old Win XP PC made a lot of changes but what could he have done that would stop access to the shared files from the win7 PC?

    Is there something in the registry that could have been changed to completely block access on a network?

    A reinstall may be the only way out of this mystery but I would like to learn from solving this problem.
  5. Mark56

    Mark56 TechSpot Paladin Topic Starter Posts: 1,886

    Just for the record this is the fix that did it.

    It was a registry edit on the XP machine that was not set to the default of 0, how it got changed is a mystery.

    HKEY_LOCAL_MACHINE/SYSTEM/CURRENTCONTROLSET/CONTROL/LSA Change value of "RestrictAnonymous" from 1 to 0

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...