Cannot Delete: Access Denied

By Klorox ยท 9 replies
Jan 31, 2007
  1. I am having trouble deleting a .pdf file on a server drive. It was created last week after a document scan and immediately became unreadable, deleteable, moveable, etc. The file is saved on a shared drive on our server. I have tried deleting in safe mode, using Unlocker Assistant and MoveOnBoot, deleting from the command prompt, and other such fixes. The main problem this file is causing is that our nightly backup is stopping at this file, which means 90% of our data is not being backed up. This is a problem as this is a law office. Does anyone have any ideas on how to get rid of this file?

    Thanks in advance.
  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Try rebooting in Safe mode, then attempt a delete while in Safe Mode. That usually works with PDF files.
  3. Klorox

    Klorox TS Rookie Topic Starter

    I have tried that, but it did not work. Does the fact the file is saved on the server alter the permissions to delete the file?
  4. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Shouldn't, but it might. Have you looked at Adobe tech support for this issue. There used to be some good stuff there.
  5. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    right click file
    make read only
    click apply
    now try to change extension to .bak
    if it does ,bobs your uncle, if you can't delete after that reboot then delete

    got to have admin rights
  6. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Give this utility a try, it`s usually very good at getting rid or stubborn files.

    If that doesn`t help, please supply the exact and full filepath to the file.

    Regards Howard :wave: :wave:
  7. scherzo

    scherzo TS Rookie Posts: 27

    I had a very similar problem with corrupt file. and the solution was very simple, IF the folder the corrupt pdf file is in has ANY settings which try to read the file first and as you say the file 'became unreadable, deleteable, moveable, etc' it is likely because WINDOWS is trying to read the file, before you ask it.

    In the folder the corrupt file is stored, select 'VIEW' at the very top, and uncheack 'status' bar. Close the folder, open the folder again and try deleting it.

    If that doesn't work, there maybe more 'auto read' settings windows is trying to acomplish before you have selected the file

    hope this helps
  8. fyz

    fyz TS Rookie


    If the pdf files are still useful, I think you can try to recover them first. There is a tool called Advanced PDF Repair. I have used it to repair many corrupt PDF files successfully. Its homepage is Maybe you can have a try.

  9. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    be sure to login to the server console to attempt the delete; don't try it over a
    mapped share.
  10. tipstir

    tipstir TS Ambassador Posts: 2,475   +126

    Login as the admin of the server don't do it remotely go directly to the server box. Isolate the file in it's own folder and remove other files from that folder. Rename the file to x.pdf.

    open cmd session and do this on the file

    attrib - *.pdf
    erase /f *.pdf or erase /f /a:h *.pdf

    Try those commands where the *. is your file name.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...