Cannot install any Microsoft Corporation files

By cleft5 ยท 6 replies
Aug 24, 2006
  1. I have a major problem that I am desperate to solve, please help me.

    Okay, so when I try to install any mircosoft files on my computer I get an error message tell me I cannot install those files. I cannot install Windows Media Player, or the latest directx updates, or any files from the Microsoft Corporation. So when I install one of the files this is what comes up:

    Error creating process <C:\DOCUME~1\myusername\Local Settings\Temp\IXP000.TMP\Install.exe>. Reason: C:\WINDOWS\system32\advpack.dll

    I only get this error when I try to install Microsoft Corporation files, so I can install other files. This error has been haunting me for the longest time. I need some help, so if anyone out there can help me out I am pleading with you to do so. Microsoft has been no help at all, so hopefully someone here will take the time out to help me, Thanks in advance.
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Probably the advpack.dll is corrupt or missing.

    Put your Windows cd into your cd drive, when the installation window appears, click exit.

    Click start/run and type sfc /scannow into the run box and press the enter key. Note the space between the sfc and the forward slash.

    Windows will now check for any corrupted or missing system files. If it finds any, it will replace them from the Windows cd.

    Regards Howard :wave: :wave:
  3. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    How are you trying to install?

    So are you trying to install directly from within your browser from the Microsoft site, or do you first download the update (save option) and run the install later?

    There could be a problem with using a different browser than Internet Explorer - it seems to me MS have ways of making life very difficult if you dont. Also certain operating system updates are now only permitted if your PC passes a 'genuine MS operating system' test....

    Hope you are not falling foul of this tightening up on piracy....
  4. cleft5

    cleft5 TS Rookie Topic Starter

    Okay so the first thing I do is download whatever I am trying to install and then try to install it but I still get this problem. I have also tried to install directly from the browser but the same problem occurs.

    I have passed the genuine windows test and this problem existed before Microsoft started that program.
  5. cleft5

    cleft5 TS Rookie Topic Starter

    Is their any way for me to go through this process if I don't have my Windows cd. At the moment I am searching like crazy for it but I have yet to locate the Windows Cd, thanks for the help.
  6. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

  7. lilstomper

    lilstomper TS Rookie

    I have a fix to your problem!!

    Hi Cleft5,
    I found your thread when I had experienced the same problem, again, last night. Lately I have made purhases of some high graphic video games and made downloads that required me to have the Microsoft .NET 2.0 FRAMEWORK, installed.
    I was certain that I had it installed but the games were not working right so I decided to look at my Programs installed under my Control Panel.

    Microsoft .NET 2.0 FRAMEWORK was not installed, so I tried to install it, the
    X64 version. That is when I got the error, again!! I did some research, and I finally landed in the right place. It isn't a Trojan or a missing file, per say. Yeah that file isn't there because the program isn't loaded.

    I am willing to bet that you attempted to load the .NET 2.0 FRAMEWORK or SDK, X64.
    I was desperate to find out which one I needed, so I looked under my past installations through Microsoft and it had said that I had downloaded a Security UPDATE for .NET 2.0 ASP FRAMEWORK X86. well there was my answer! I no longer had the program loaded, because of some reason and I attempted to load a version that was not compatible for my Computer, thus the error!

    So, I went back into Microsoft and downloaded: Microsoft .NET Framework Version 2.0 Redistributable Package (x86), and GUESS what? No Error this time!
    NOTE: Unless you are a developer and/or write webpages there is no need to download the SDK version or any SDK, unless you already have an SDK FRAMEWORK installed.
    I recommend you don't both with the hassle, it only creates problems you're not able to deal with unless you have the training.

    Now remember I had said that my download history had said I had downloaded a Security Update for this package, after you finish downloading the [COLOR="red[U]"].NET 2.0 FRAMEWORK[/U][/COLOR], it will remind you to do the same, BUT it doesn't give you a link to go to nor does it tell you the download number to do a search on it, but my history had it! It is KB917283.

    When you are done downloading the initial .NET 2.0 FRAMEWORK, there will be a page that comes up after it saying "Thank you for downloading..." at the TOP of that page, and you can search the entire Microsoft database, so just put in KB912783 and hit GO and it will take you to a page labeled, NDP 2.0 ASP.NET Security Update. At Mid-Page it has THREE downloadable versions of .NET 2.0 Security Updates. You need to download NDP20-KB917283-X86.exe.

    After you are done doing all of this then you need do a System Restart. Once you are done with that you need to go back to Microsoft's download page and have it do a search for you to see, now if there are any New PRIORITY downloads your system needs.
    NOTE: .NET 3.0 FRAMEWORK can cause system disruption, if you attempt to remove it from your system, it will also remove .NET 2.0 FRAMEWORK along with it!!! So don't doenload it unless Microsoft or another program tells you, you need it.

    I hope that this fixes your problems, I have had no problems since I fixed mine. I woiuld be interested in finding out if it worked for you, post a thread when you get a chance!! Alos if you have any questions you want to bounce off of me you are welcome to, I am always up to a challenge.

    Best of luck,

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...