Cant access Belkins router page

By lazycow29 ยท 5 replies
Jul 13, 2006
  1. After A LOT of trouble with thanks to techspot members i have set up my wireless network an have finally sorted out my alptops problems... i am one step away though from getting the internet on my laptop...

    I need to access the belkin router set up page... address ... but it wont load. I only went on it the other day and now it wont let me access it. I am close to tears as i have come so far... can anyone help??
  2. fastco

    fastco TS Booster Posts: 1,123

    Are you sure of the router setup page? I thought it was
    Not sure if they changed it.
  3. Peddant

    Peddant TS Rookie Posts: 1,446

    I agree with Fastco,my old Belkin used

    If that fails,try resetting as HERE
  4. lazycow29

    lazycow29 TS Rookie Topic Starter


    nope i tried that... wont work... that other one was an alternative according to belkin
  5. lazycow29

    lazycow29 TS Rookie Topic Starter

    by doing the reset ive lost my network connection!! All the time my brother spent sorting it out is gone!!
  6. lazycow29

    lazycow29 TS Rookie Topic Starter


    No Ur God Its Worked... I Ave It... I Love U!!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...