Can't delete a certain avi  file??

By needhelpz ยท 9 replies
Aug 18, 2002
  1. now i dunno if this fits into this room or not but someone may be able to help , now this is a really simple thing i cant delete a file!, its the ali g movie an it just wont delete , its keeps saying that its still in use but i dont think that i have it running though anything,like something on boot up? , my os is winxp , weird ..anyone lol?
  2. StormBringer

    StormBringer TS Maniac Posts: 2,244

    I had a similar problem once, although the error I got was "disk is full or write protected" and I also got the error you have a few times as well with it. This was also an AVI file. I finally got rid of it using Norton's Wipe Info.

    Wipe Info will get rid of the file completely and it doesn't ask any questions.
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    If you are using something like KaZaA, it will not let you delete the movie sometimes unless you close KaZaA. There are a few other programs like that.

    Some other reasons for this behavior are secruity permissions (not being an adminstrator) and possibly services that are running in the background such as antivirus programs etc..
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    UPDATE: I had this problem earlier with a few avi movies that I'm needing to change their directory. I don't know DOS so I wanted to avoid the shutting down explorer and moving them that way through the cmd thing. So what I did was start up in safe mode and tried that way, couldn't directly do it, but if I removed them to the recycle bin and then into the directory I wanted that worked (although with a different filename, don't ask me why (disk isn't corrupt either)).
    So I was talking to Goalie (forum member) about this over AIM and as I was trying to tell him about it (after he told me to use the search feature which I already knew to do) I came across the notion that it always seems to be .avi files that cause this program. So I suggested to him I think it may be something related with the divx codec, and I figured he wouldn't buy that so I explained why I thought that - because windows always likes to load up the first frame of the video for the thumbs.db file.

    AND BINGO, just as I had typed that I thought (and Goalie almost instantly replied too) to delete the thumbs.db file and give it a shot. Yep that works. So if you don't want to go though all the bs of an attempt in safe mode, or killing off explorer and typing in text commands delete thumbs.db and give it a shot.
  5. Goalie

    Goalie TS Booster Posts: 616

    Another Pseudo-solution for this may be to disable that quick preview- no need then to load for the thumbs.db file.

    This is, of course, untested hypothesis. Windows may be stupid and continue loading that first frame. Either way, it appears that Windows isn't properly closing the file when it does that.
  6. Godataloss

    Godataloss TS Rookie Posts: 482

    I had this problem a few months ago- cant find the old thread, but this is what I did- Click Start>Run, type REGEDIT and click Ok. Then make your way to this InProcServer32 key:
    HKEY_LOCAL_MACHINE >SOFTWARE >Classes > CLSID > {87D62D94-71B3-4b9a-9489-5FE6850DC73E}> InProcServer32

    Right click the InProcServer32 key and choose Delete. And that's all there is to it. This will prevent Windows from loading shmedia.dll when you work with video files and thus you should no longer have problems deleting or moving any video files. Also if you have a video file you can't delete now, deleting this key will allow you to do so. If not, log out and log in again to delete the file.
  7. Goalie

    Goalie TS Booster Posts: 616

    Ahh, but disabling that can disable other functionality of windows.

    Our "solution" only forces a regeneration of the file.

    Potayto, potahto. Guess it all depends on what you value in functionality
  8. scotiawhiskers

    scotiawhiskers TS Rookie Posts: 24

    I've had this a few times - I usually find that using task manager to shut down all instances of explorer.exe, then taskmanager>file>run (new task) as explorer.exe will free the file for deletion. No registry messing about and no reboot! Only had 2 occasions when it has been totally stuck, found then that moving everything else out of the folder and deleting the folder or doing a copy to another folder seems to clear it. After copying, both versions will delete. Don't ask me why, I'm not Bill Gates!
  9. Godataloss

    Godataloss TS Rookie Posts: 482

    Anyone know if SP2 addressed this?
  10. Johann

    Johann TS Rookie

    Found a solution (at least for me)

    1. Download a freeware application called File Assasin from or just Google it.
    2. Run the installation (very quick).
    3. Open the application - open your Recycle Bin - Drop and Drag the problematic file into the File Assasin window (there are instructions there).
    4. Check the 'Delete File' box and any other of the boxes you wish to, then click on Execute on the bottom right.

    This should do it. All the best.

    Kuala Lumpur, Malaysia
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...