Can't fix registry problem (\WINDOWS\SYSTEM32\CONFIG\SYSTEM)

By numbed84
Apr 24, 2009
  1. Hi, I've encountered the extremely annoying \WINDOWS\SYSTEM32\CONFIG\SYSTEM problem. I've followed the instructions on Microsoft support Article Q307545 (can't post the link as I'm a newbie here), but I couldn't proceed to step four (opening System Restore). If I try to boot normally, chkdsk opens to scan one of my partitions, the scan is completed and no errors are found, and then suddenly the computer restarts. If I try to boot safe mode (including with command prompt), the computer too eventually restarts. I've tried using UBCD4Win to move/replace the registry files like the Microsoft support site states, I've ran a full virus/malware scan, and I've tried using the RegResWiz tool to restore my old registry, but I've still encountered the restarting problem. I also tried opening System Restore by command prompt through UBCD4Win but there was no response.
  2. gguerra

    gguerra TS Guru Posts: 319

    Try this. I recently found it after having boot problems (I wont get into) and it saved the day. It is supposed to let you edit the registry (among other things) from a boot cd. It will also let you transfer files. All you need is a burner.

    Paragon Software
    Rescue Kit 9.0 Express (Free)
    the Pro version costs $99
    Direct download link

    When you run it it will ask for serial number which you can get by clicking on the link provided
    It will then burn the software to CD which you use to boot with. Follow the instructions.

    Let me know if it worked

    Of course there may be other ways to fix your problem. Since I dont know the details (please provide more) I cannot specifically tell you what to try.. If you simply want to access the disk and copy file to/from you hard drive you could always boot the Windows setup disk and go to recovery console or slave the drive in another computer.
  3. numbed84

    numbed84 TS Rookie Topic Starter

    Aftermath of repair install...

    Ok, so I tried doing a repair install. During the installation process, these errors popped out:

    'sub component COM+ raised on exception while processing the OC_COMPLETE_INSTALLATION setup message.
    d:\nt\com\com1x\src\complussetup\comsetup\csetuputil.cpp (line 3406)
    Error code= 0x8007007f
    The specific procedure could not be found.
    Failed to load the library C:\Windows\system32\catsrv.dll'

    'An error occured loading [several of the same error popped up for- C:\Program Files\Common Files\System\directdb.dll; C:\Windows\system32\netcomm.dll; C:\Program Files\Outlook Express\msoe.dll; C:\Program Files\System\wab32.dll]. The file may not have been installed or it has been corrupted'.

    Now after the repair install, I can boot sucessfully, but none of my programs work + my USB speed seems only on 1.0 (I'm backing up the stuff on my external HDD and it's damn slow). It's a similar error for all programs:

    '(PROGRAM)- Entry Point Not Found
    The procedure entry point (SPECFIC FILE) could not be located in the dynamic library link (SPECIFIC DLL)'.

    Is my PC beyond repair, and do I have to resort to reformatting my HDD?
  4. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...