Can't get into display properties

By qmd
Oct 12, 2009
  1. Hi, a short while ago I had to replace my graphics card (6600GT), and ended up replacing it with an MSI HD 4670

    my problem is now that the card is in and working if I right click on the desktop and choose properties the display options screen doesn't open. I can't get into it through Control Panel either. I thought it was maybe off screen if the desktop was extended, but it doesn't appear in task manager either.

    There is a slight problem with drivers atm but not sure if it is connected: when I boot into XP I get a dialogue box saying "fail to load nvcpl.dll" as a result I have run driver sweeper in safe mode to remove nvidia display drivers, and reinstalled the ATI ones - no change.

    I have tried uninstalling the ATI Catalyst software as I thought that may be getting in the road somehow but no change.

    The most annoying thing is that I normally don't have a screensaver on as I don't leave my monitor on when I'm not using it, but had for a particular night set a screensaver to whatever the lowest time interval is, so now I can't change that...

    if anyone has any suggestions I will be all ears.

    edit: just noticed if I have no browser windows open, then for a split second I can see part of a window open when I try to get into display properties, then it vanishes.
  2. Kcircyrd

    Kcircyrd TS Rookie Posts: 216

    That appears to a driver install issue. That could be caused by a defect in the drive itself.
    Have you tried going into the Device Manager and removing or disabling what you have, then rebooting and trying a new install... or going back to the previous driver on their website?
  3. tweakboy

    tweakboy TS Guru Posts: 467

    Yes I agree, have you tried blind install from device manager..

    Go to safe mode and use driver sweeper from and clean ATI ,, then reboot into normal mode and install latest Catalyst drivers WHQL ,,,, gl
  4. qmd

    qmd TS Rookie Topic Starter

    cheers for the replies, haven't had a chance to do anything about this until tonight - however I am now not able to boot into safe mode, I'm guessing that it doesn't like IDE emulation mode (SATA boot disk) do I have to go into safe mode to run driver sweeper?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...