Can't get to BIOS

By Christos21
Dec 2, 2014
Post New Reply
  1. Hi there! I am new here and I need some help regarding a new desktop I just bought.
    MOBO is Gigabyte GA-970A-DS3P and GPU ASUS R7 260X connected with HDMI on TV.
    I set up the desktop with win7x64 ultimate.
    Problem is when the pc boots and I repeatedly press DEL button to get on the BIOS settings and I see nothing but BLACK on the screen and the mouse cursor which it can controlled through the mouse, though it boots up normally on windows. Any help?

    note: I installed all drivers after I installed win on both MOBO and GPU
  2. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    Are you using a USB keyboard? See if you can find a PS/2 keyboard and try that.
    Spykezxp and nickc like this.
  3. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Are you sure that 'delete' key is the right one to access the BIOS?
  4. Christos21

    Christos21 TS Rookie Topic Starter

    Problem solved, the problem was that I was using HDMI connection from the GPU. So I tried the VGA and I am now able to see the BIOS. Thank you anyway.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...