Can't host WC3 and everything - Port Forward Problem

By nosebleedXD ยท 13 replies
Mar 21, 2009
  1. kk, so i dunno what happened today all of a sudden, i can't host anything

    like i was playing warcraft 3 this morning, and found out no one can join my games

    i got my friends to help and stuff and they couldnt join my games in warcraft 3

    then i realized when i host for other games, nothing works

    i went to cmd and ipconfig/all it and checked if my static ip had changed, but no it hadn't

    i went to my router page and deleted everything and re forwarded it all, but still, my ports are blocked

    i don't know what to do now =[
  2. Piggles

    Piggles TS Rookie

    I too am having problems hosting WC3, so, instead of making a whole new thread I'll just reply to this one. I'm running Vista and I've tried everything.

    Been able to host for 4 years, I lost this ability suddenly.

    Checked portforwarding (I have a D-Link with an ip of, my router is unchanged, still allowing all battle-net/wc3 connections. Same for my windows defender.

    The gameplay option still reads 6112, as it always has.

    If anyone can lend a hand or tell me that avira/avast have in-built firewalls, else I'm completely stuck.

    Games appear to be viewable, but impossible to join.

  3. nosebleedXD

    nosebleedXD TS Rookie Topic Starter Posts: 233

    =[ port forward ftl

    im using linksys btw
  4. Piggles

    Piggles TS Rookie

    Ye olde final bump...
  5. nosebleedXD

    nosebleedXD TS Rookie Topic Starter Posts: 233

    i found out my problem

    you gotta go to DMZ and enable it

    set it to your static ip

    btw i use linksys =]
  6. Piggles

    Piggles TS Rookie

    Enabling DMZ helped me in no way.
  7. jdillman1502

    jdillman1502 TS Enthusiast Posts: 120

    If placing your pc in the DMZ corrected the problem, then the issue is with the port forwarding of your router.

    Piggles, have you checked to see if your windows firewall is on? If it is, are there expections for the WC3 ports?
  8. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    if you use the DMZ setting, then you've basically opened everthing to the Internet.

    your sole protection will then be the firewall which will still need to be configured to
  9. nosebleedXD

    nosebleedXD TS Rookie Topic Starter Posts: 233

    oh really? crap, i should turn it off then, but if i turn it off it wont work anymore =[

    btw my firewall is off at all times
  10. jdillman1502

    jdillman1502 TS Enthusiast Posts: 120

    Your router may be starting to go bad. I've had a few instances where a customer was hosting their own email, so we had port 25 forwarded to the server, but no mail was comming in. Deleted the port forward, recreated it, then it work fine for about a day and the mail stopped again. Ended up just replacing the router. So, just because the port forward is in the router, doesn't mean that the port is actually open.

    I usually use this website to see if the ports are acually open.
  11. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    OUCH! This all points to firewall management OR a bad router.

    for testing purposes only, disable the firewall and connect the system directly to the modem. IF that runs, then you have poor management of
    1. router port forwarding OR
    2. opening ports on your firewall
    so add the router back into the chain and leave the FW disabled
    now manage the port forwarding until it works
    go back and enable the firewall and ALLOW the same ports you used in the router
    port forwarding.

    If testX runs but the next one doesn't, then you need to ensure the router or firewall
    is properly configured.

    come back with results ---

    btw: I'm out of town next week so someone else will need to follow-up
  12. Piggles

    Piggles TS Rookie

    Disabling firewalls/blockers/antivirii didn't help me host, it was the first thing I tried.

    Yesterday I dug out an old modem, installed the software and found I could host. Though, for various reasons, I won't be able to use the modem as a permanent solution.

    Now I've switched back to my router, and hosting has ceased. Therefore it's almost certainly a router problem.

    Tested port 6112 (the hosting port) at (jdillman1502's) port test link, test read: [ip] isn't responding on port 6112 (dtspcd).

    In my router's portforwarding options it says it has the Battle-net ports open (6112 included).

    Edit: I'll try deleting all unnecessary portforwards and re-apply Battle-net.
  13. nosebleedXD

    nosebleedXD TS Rookie Topic Starter Posts: 233

    kk i went to that site to check if my ports are forwarded

    right now my DMZ is enabled, i know i can host in WC3 atm but that site says its not responding to the port 6112

    well anyways joebeard, i will try your method, thanks
  14. nosebleedXD

    nosebleedXD TS Rookie Topic Starter Posts: 233

    kk i found out its just wc3 i can't host for some reason
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...