Can't play online

By twite ยท 4 replies
Sep 4, 2006
  1. Hi, i installed farcry on my new computer, and when i try to log on to to play online, it just sits their unresponsive. I have tried to disable my firewall (zonalarm), and windows firewall. The odd thing is that this same problem occured on my old computer when i was using im using cable, so i dont think it has anything to do with my internet connection, I am connected through a wireless router. I have tried making a new account at figure this out

    Also, when installing it didn't ask me for a serial, which i thought was kinda odd.
  2. Rik

    Rik Banned Posts: 3,814

    You need to check what listening ports the game uses then make sure they are open on your router. Refer to your routers manual.
  3. twite

    twite TechSpot Paladin Topic Starter Posts: 937

    If i plugged it in directly to the modem will i still have this problem? I dont have the software or manual for the router anymore, so the modem is my only option.
  4. Rik

    Rik Banned Posts: 3,814

    Give it a try!! That's what i'd do.
  5. twite

    twite TechSpot Paladin Topic Starter Posts: 937

    Ok, i plugged it into the modem and still nothing..
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...