Catalyst Control Center

By JStogdill ยท 9 replies
Jan 18, 2010
  1. I installed Gygabtyes HD Radeon 4650 1 gig AGP 8x card. I installed the drivers from the disc and the CCC also. However, I can't seem to get the CCC application to open. Any suggestions?
  2. IvanAwfulitch

    IvanAwfulitch TS Booster Posts: 218   +11

    What have you tried? Can you be a little bit more specific? There are a lot of ways to open a program.
  3. JStogdill

    JStogdill TS Rookie Topic Starter

    I inserted the cd and ran the Install Drivers option. When it was completely done installing everything off of the cd, I right clicked on the desktop and went to properties. From there I selected the Settings tab and then Advanced. I then selected the ATI tab and proceeded to get an error, telling me that it wasn't compatible with my graphics accelerator or something like that. At this point I uninstalled everything, booted into safe mode and ran a utility to uninstall the drivers. I then reboot and installed the drivers only, then reboot and installed CCC only and reboot. I am still unable to get the Catalyst Control Center to run.
  4. IvanAwfulitch

    IvanAwfulitch TS Booster Posts: 218   +11

    Did you try running it in basic mode first? That may make a difference. You can also try going the Start, All Programs route and select the CCC from there to see if it will open.

    Another question...did you install the CCC and then reboot to let the changes take effect?
  5. JStogdill

    JStogdill TS Rookie Topic Starter

    I am not sure what you mean by "Basic mode first". I did try running it from the start menu and got the same result and I did reboot after the CCC was installed...
  6. IvanAwfulitch

    IvanAwfulitch TS Booster Posts: 218   +11

    When you opened it for the first time, you told it that you wanted it to run in Advanced mode so you could edit the aliasing options and all that wonderful junk. Perhaps you needed to start it in Basic mode first.
  7. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    Are you getting any error message? CCC needs .NET Framework 2.0 to run. Is it installed?
  8. JStogdill

    JStogdill TS Rookie Topic Starter

    The only error that I am getting is that my graphics accelerator isn't compatible. Not those exact words, but close.
  9. JStogdill

    JStogdill TS Rookie Topic Starter

    .NET Framework 2.0 and 3.5 are installed
  10. EXCellR8

    EXCellR8 The Conservative Posts: 1,835

    Uninstall CCC and just use ATI Tray Tools if you keep having problems. It's basically the same thing but condensed into a small app that runs in the background; from the taskbar. If you need to adjust fan speeds download the latest build of RivaTuner too.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...