CD/CD RW Drives stopped working...

By Goofy Newfie ยท 5 replies
Mar 27, 2003
  1. For some reason, my optical drives will not function. Nothing was changed on my system, which really puzzles me. I tried uninstalling them in device manager with no success. Once while rebooting, I got an error message saying that they were not Atapi compatible, and to press F1 to continue. What's the deal here? Any advice/instructions are, as always, appreciated.
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    How about reistalling IDE controller drivers?
  3. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Check that the cables are connected properly.
  4. Goofy Newfie

    Goofy Newfie TS Rookie Topic Starter Posts: 199

    The cables are attached properly. I am going to try reinstalling the drivers for the IDE controllers.


    Here's what I tried:

    reinstalled IDE controllers/drivers
    installed brand new IDE cable
    performed system restore

    Could the secondary IDE on my mobo be shot? It's only 4 months old, and I have not done anything to it since I bought it ( no cable changes/removals, no hardware changes).

    I am going to try and hook up one of the optical drives to the primary IDE as a slave and see what happens.
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You can hook up your HD to the second channel. If the controller is bust, the HD won't work either.
  6. Goofy Newfie

    Goofy Newfie TS Rookie Topic Starter Posts: 199

    D'uhhh. I am just not thinking in the right frame of mind in handling this problem. I will give it a go.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...