Cmos Checksum Bad

By OnyXiuS ยท 16 replies
Nov 10, 2008
  1. Ok, so im an ***** and tried to update my BIOS. I downloaded the update from the Intel official site and followed directions. The update was the type of update you can do while windows is running, so i gave it a shot not really knowing anything about what i was doing. The program ran fine, installed fine i guess, and was restarting my computer. It took awhile to log off, but i sat and watched it until it powered down. Computer rebooted, and i get a CMOS Checksum Bad Error.
    My motherboard is an Intel D845PT. Ive tinkered with the BIOS for ages, and even tried the IFlash BIOS update with a floppy, only to find out this model of MOBO doesnt even use Iflash, or its not compatible. And yes, im using a fairly new CR2032 Battery. MY COMPUTER BOOTED JUST FINE, AND WORKED JUST FINE BEFORE REBOOTING TO UPDATE BIOS! Anyone have any ideas how to fix this?
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

  3. OnyXiuS

    OnyXiuS TS Rookie Topic Starter

    I got the BIOS update from Intel. I had to dig a little deep though. I followed the instructions and everything..I was planning on building a gaming PC anyway so i might as well ditch the 50$ Mobo and start anew. Thanks for the consideration though :p
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Oh, so that's it?
    I suppose yes, anyway $50 who cares, get a really good gaming one this time :grinthumb :)
  5. vonss

    vonss TS Rookie

    Hello, sorry to interrupt, but I have basically the same problem. Here it goes nothing:

    Trying to fix a bug in my Elite Group ECS P4M800Pro-M , that did not reported the processor's temperature correctly as said the BIOS I downloaded from ECS's official site. Well, I uptated from Windows, using the AMI WInflash program, it worked fine, rebooted, BUT, after that update, the options to change my processor and memory FSB/MHz were blocked!. At this point, some strange warning message appeared in my CMOS-POST saying: "This BIOS do not support the processor's FSB of 166MHz (which was the speed I had it OC'ed) and it forced me to press "Y" or reboot the system, I accepted and everything worked "fine". Once I was inside Windows again I flashed the the previous version that I downloaded from ECS's site, to check if that unlocked that settings, but with no success-. The only difference in flashing this time was that I checked the option "Load CMOS default". Now, every time I start my PC, it gives me the error:

    CMOS checksum Bad
    CMOS Date/Time not set
    F1 to enter SETUP

    I press F1, enter the BIOS setup, but when i try to save any change or no change at all saving and rebooting, my PC freezes. But the really weird thing is that i can use the "Discard changes and exit" and my PC boots up windows normally. But i need to try to fix that, because at the moment, buying a new motherboard for me, sadly is not an option.

    I already did (I think) all the usual steps and checks to fix it, the battery the BIOS reset Jumper, etc. I would greatly appreciate ANY help you could give me. Thank you very much in advance.
  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    BIOS Name---------BIOS for P4M800PRO-M (PCB:1.x)
    Release Date------2007/06/26

    From here:
    Is that the one you are using?

    By the way, here's their disclaimer ;)
  7. vonss

    vonss TS Rookie

    Hey, thanks for the quick reply.

    I'm using the one for the V 2.0, which is what my Motherboard says, I mean, when I look at, it, physically, the letters next to the processor. But programs like CPU-Z and Everest say is the V 1.0. So I'm not sure, maybe that's thre problem.

    By the way, I know I messed up, no need to rub it in my face lol xD

    Thanks again for any help.
  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    No I wasn't rubbing it in your face
    I have to quote like that, in case others view the thread (ie you did it already)
    I'm just being thorough.

    Anyway, usually it's a matter of going to the latest version (where-ever, ie use their utility, probably already done ;) )

    Then update

    It's better to do Bios updates before installing Windows though

    Also read: How to flash/update your BIOS
  9. vonss

    vonss TS Rookie

    You know, is weird because, if I download the latest BIOS for my MoBo and I try to use it with the AMI Winflash updater that came with my MoBo, it gives me an error, like the ROM ID is invalid, something like that, but if I use the AMI Winflash that I downloaded, it lets me flash the BIOS. So I'm not sure what the hell is going on here.
  10. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I'd say download the Dos boot Bios updater, don't update Bios in Windows
    The web (manufacture) has the best one to use
  11. adweston

    adweston Banned Posts: 242

    Never flash a bios while you're overclocked...
  12. alokgovil

    alokgovil TS Rookie

    I am not an expert myself, so take what I say with suspicion.

    My understanding is that the format of the data in the CMOS memory could be different for different flash versions. So you would need to restore default or fail-safe values into CMOS and save them.

    I guess you are past this step, that's why this thread...
  13. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Thanks fellers, but been done ;)
  14. vonss

    vonss TS Rookie

    Hmm, would you mind linking me, please? I don't want to mess up again :( and I always felt weird flashing the BIOS from DOS... is like... harder.

    Thanks for the heads up... xD

    Yeah, that's my intention, but I don't see how I can do that. I mean, I don't have the ROM of my original BIOS.

    I don't understand what you mean xD
  15. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I was saying you have tried Bios defaults, to the other members, not you!

    Also flashing in Dos and how to do it...
    Hmm, I cannot be responsible for this (ie it can stop your computer from booting again!)
    You need to follow the manufacturers direction on this
  16. vonss

    vonss TS Rookie

    Oh, my bad xD

    Haha, all right, I'll give it a shot xD
  17. vonss

    vonss TS Rookie

    Is fixed, don't ask me how, cause I'm not really sure what I did xD. One problem less. Thanks for the help folks.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...