CMOS Checksum Failure

By acidosmosis
Apr 30, 2003
  1. "CMOS checksum failure"

    I was working on this customers PC today (for the third time). He bought this computer for $50 off some college kid. I put in a video card for him and setup the Internet on his computer.

    It is a 350mhz K6 with a PCChips motherboard.

    I swear I hate older computers. The mouse is a serial mouse and the computer was built by whoever with a serial connection installed installed on one of the brackets that is connected to the motherboard via a cable (notice I'm not sure what you call this thing lol -- wasn't working on PC's back when 350mhz processors came out). I checked this and plugged the mouse into the COM1 set of pins on the motherboard and also tried the COM2 pins. After rebooting on both spots the mouse still did not work. I had the other Tech guy take a look at the PC and I rebooted after he said COM1 should work and now I am getting the message:

    "CMOS checksum failure" or something very similiar (eh.. forgot the EXACT message).

    Well I replaced that battery with an exact duplicate that we happened to have laying around (the numbers matched and everything). That didn't work either, so I told the guy (owner of the PC) to go to Radio Shack and see if they had any.

    If this doesn't work, I'm going to be a bit upset.. I had a bad day as it is. hehe dangit!!

    Anyway, in the case that the new battery doesn't work what do I do?

    Also... any idea why the mouse is not working? It was working the other day.
  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    You are right in saying it is the CMOS battery - This is the most likely cause.

    You can pick up new ones at Wal-Mart, K-Mart and most retailers that sell a variety of batteries for cheap). If a new battery does not fix it, here are some more ideas from my experiences.

    Dead Battery - The most obvious cause.

    Bad CMOS settings - When you change the battery, it is necessary to enter the BIOS setup and "Save and Exit". If it continues to do this, you may want to try setting up the BIOS to "Clear ESCD configuration data" or something along those lines. This resets the CMOS stored device data.

    Bad board, bad PCI device or real-time clock - It is possible the board is bad or the real-time clock is bad. This is capable of producing the same error. I've seen instances where a bad PCI device has produced these errors to.

    Bad CMOS - While is unlikely, you could have a bad CMOS. You may want to flash it with a new BIOS version (if you can). Since we do not know what is causing the problem, I cannot really guarantee the reliability of a BIOS flash. There may be some sort of major, underlying problem with your cache or the ROM itself.. And this runs the risk of toasting the board. BUT - This may fix the probelm and should be considered as an option if all else fails.
  3. StormBringer

    StormBringer TS Maniac Posts: 2,244

    Don't forget the CMOS battery holder. I've had to replace quite a few of them.
  4. computergal

    computergal TS Rookie

    I broke off the clip holding the CMOS battery in place in my daughter's IBM 300PL Desktop PII 400. Is there any way to hold that battery in place without having the holder replaced? I don't think so, but thought I'd ask.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...