Computer doesn't recognize Mad Dog cd-rom

By petitchat ยท 4 replies
Jan 2, 2005
  1. I have a Mad Dog Dominator Cd burner that I installed (on my PC with Windows XP). When I turn on my computer, it only recognizes that I have a cd-rom drive maybe one in every 20 times. During start-up, when I hear it spinning, I know it will be one of the times it's going to work. The burner works fine at these times until I have to shut my computer off for some reason. Please help! :giddy:
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    It could be you don't have enough power to the drive (doubtful, yet possible), so can you hook it up so its your only cd drive (if you have multiple). Or it could be that you have a dead drive (IMO the more likely senario).

    Does the BIOS recognise it? Does the drive open when you hit the button?
  3. petitchat

    petitchat TS Rookie Topic Starter

    thanks for responding about maddog cd-rom

    :monkey: Hello! The drive does open when I push the button, whether my computer is recognizing it or not. It's my only cd-rom. When i turn on my computer, sometimes it recognizes it during start-up and usually it doesn't. As long as I don't turn off my computer during the times that it is recognized, it works just fine. When I go into "My Computer", there is no icon for a cd-rom drive during the times it isn't recognized. The hourglass comes on for quite a while, like it's searching for my cd-rom, but eventually gives up. I stupidly threw away the box, so I don't have a UPC code anymore. I tried to get help from the mad dog web site, but they require a UPC before you can even ask a question. I don't know what IMO or BIOS mean. Sorry.
  4. tekmon

    tekmon TS Rookie


    recently a client of my purchased one of these from office max, he said they they did not have a selection but was the only brand carried there, so they may have that UPC.

    I hooked his external drive up via USB cable is this the case with you?
  5. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Have you tried doing a firmware update?

    You can get these HERE

    Regards Howard :wave: :wave:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...