Computer stuck on HP logo after installing Ubuntu

I am using an HP Pavilion 20 All-In-One

I used a USB to install Ubuntu and went through the basic start-up options. I selected to finish installing Ubuntu while erasing everything else on my computer. After Ubuntu finished installing I was given a message saying that I needed to restart my computer for everything to go into effect. Now everytime I restart my computer it gets stuck on the HP logo and refuses to boot.

**Things I've Already Tried**
- Unplugged the computer and held down the power button for 15 seconds
- Ran a DPS Self-Test and received a completion code of 0
- Tried booting from the USB again

Any help would be greatly appreciated, I've tried nearly every solution I can find online.
 

Setfree

Posts: 40   +7
I had an issue with a Dell desktop which a Dell tech could not help me with. It froze at the Dell Bios screen. I resolved my issue by re-seating the graphics card (which in your case would be more involved of course). Also, sometimes a usb device needs to be unplugged before reboot. Hope this helps.
 
Last edited: