Computer won't boot

By JohnAFC ยท 14 replies
Aug 30, 2015
Post New Reply
  1. I have a Sony Viao laptop running Windows 7.
    I upgraded the RAM from 1GB to 2 GB. Now the computer will not boot properly.

    When I press the power button the VIAO screen shows up and then the select boot mode screen flashes up momentarily and it then returns to the VIAO screen.

    If I hit F8 repeatedly the boot mode menu stays on screen and I can choose "start normally" and everything is fine. Safe mode works fine too, but I shouldn't have to do this, should I?

    Any suggestions as to how I can get it to boot normally on its own would be much appreciated.

    Incidentally, putting the old 1GB ram stick back in does not help.
  2. JohnAFC

    JohnAFC TS Rookie Topic Starter

    Further digging around on the Internet suggests that this may be a keyboard problem.

    This seems very plausible in my case as access to the RAM slot is via removal of the keyboard. However I do not know how to investigate this problem on my computer. The computer is a Sony VIAO vpcm12m1e.

    Any suggestions for what I should try would be much appreciated. As far as I can tell the keyboard is properly plugged in, but beyond that I am stuck for troubleshooting ideas.

    Thank you.
  3. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +250

    If it was a netbook you might need to get to the ram via lifting the keyboard but even then I doubt that you actually needed to remove the ribbon cable. With a laptop access to the ram is almost always via a removable cover underneath. It's a popular upgrade and manufacturers try to make it as easy as possible. I don't think this is related to the keyboard unless you have really messed up the upgrade.

    Sorry, I see on second look I see that it is a netbook and you have given the model number which is helpful.
  4. JohnAFC

    JohnAFC TS Rookie Topic Starter

    Thanks for the reply. However, I have just taken the keyboard off by removing the ribbon cable and the netbook boots fine. If I reattach the keyboard it does not boot.

    I went into the BIOS menu and pressed Esc to exit and the exit without saving dialog kept popping up and disappearing as though Esc was being pressed repeatedly.

    I don't think I messed up the upgrade as all I did was lift the keyboard without detaching and swap the old RAM stick for the new one...
  5. JohnAFC

    JohnAFC TS Rookie Topic Starter

    Actually I think the Esc button sticking is significant as pressing it repeated causes the boot menu to appear and disappear, which is my main symptom...

    The keyboard seems clean and the key works fine so not sure what is causing it.
  6. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +250

    Did you need to unclip the connector attaching the ribbon cable to the motherboard? If so try carefully unclipping and reattaching the cable making sure that it goes properly into the connector before you clamp it. Those connectors are very delicate and any damage is really bad news. Take your time and be sure that you know what you are doing. The ribbon cables are also very delicate. The design is poor considering that Sony used to market Vaios as a premium brand.
  7. JohnAFC

    JohnAFC TS Rookie Topic Starter

    I didn't need to unclip it, but given the length of the ribbon and the position of the RAM I did give it an inadvertent tug or two while unclipping the RAM.

    The ribbon does not seem to have a clamp, it just slots in and out of a socket on the motherboard.

    I have just gone on to a java script based keyboard event testing website and all the keys seem fine except for escape which registers tens of key down events for each press and occasionally doesn't register any all...

    Does this sound like something that can be fixed? Or does it sound like I damaged the keyboard connection?

    Thanks again for your help.
  8. JohnAFC

    JohnAFC TS Rookie Topic Starter

    On closer inspection there is a small kink in the connector ribbon which just touches on of the wires within the ribbon.

    On the picture at the link above the kink is on the inside of the 90 degree bend in the cable. Is this likely to be enough to damage it? Would a damaged cable give the symptoms I am seeing or would it usually be more disastrous?
  9. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +250

    I'm just recovering from repairing a Nintendo DS lite. I slightly damaged a ribbon cable in the process and had to order a new screen. Just a tiny bit of damage made it non-functional. Take the keyboard out and look very carefully to see if there is any damage to the little printed circuit lines that you can see on the ribbon. Any break would be likely to cause issues. Even having the cable slightly out of alignment in the connector could be causing the problem.
  10. JohnAFC

    JohnAFC TS Rookie Topic Starter

    I can't see any damage to the printed circuit lines, but the bit I have bent does just cross one of them, so I guess I could be broken. There is very little play in terms of alignment with the connector, so I think that when it is plugged in it is plugged in correctly.

    I've seen replacement keyboards for 10 bucks and others going for 600. If I can get my hands on a cheap one I guess it would be a simple test. But all the ones I can see for sale at the moment are far more than the netbook is worth...
  11. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +250

    Try spitting on the end of a cotton bud and rubbing it gently over the end terminals on the ribbon cable in case a bit of grease from your fingers has spoilt the connection. I have a netbook that I bought second hand but went for a Samsung which was the only one I could find where there was a sensible hatch underneath to upgrade the ram. Mine has 2Gb ram and an SSD drive. It is running Windows 10 and although it's still no racehorse I do like it.

    Sony Vaios were such an ongoing car crash that spares are usually cheap to obtain on eBay. Don't spend much on one but watch out that the keyboard layout is right for your region. In the meantime if you have a usb keyboard to plug into the netbook you should be up and running right away.

    I just noticed that you said there was no clamp on the connector. That doesn't sound correct. You don't just push the ribbon in and out because they need to be secured in place to maintain a good connection. We need to check that out in case the connector is missing a piece.
  12. JohnAFC

    JohnAFC TS Rookie Topic Starter

    Cool thanks. I'll try that. I don't think that dirt on the connector is an issue as the problem started before I had ever unplugged it, but I may well have knocked something loose.

    I'll have another look later to see if I am missing a clamp or anything, but it does just seem like it slots in and out. The ribbon is a pretty tight fit in the slot.

    Thanks again for your help.
  13. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +250

    Surprisingly no clip involved.

    Try plugging in a usb keyboard if you can borrow one. All supposing that it works you can be pretty sure you need a new keyboard.
  14. JohnAFC

    JohnAFC TS Rookie Topic Starter

    I'll borrow a keyboard from work tomorrow and see what happens. I'm guessing that it will be fine, as it boots up fine without the keyboard attached, but is obviously not much use once it has done so.

    I guess the question is whether my keyboard is broken, repairairable or incorrectly configured... Hopefully I can find a cheap enough replacement to just buy it and hope for the best.

    Thanks for all your help with this. I'm not too scared of getting my hands dirty when it comes to computers software and hardware, but whenever I do do anything it's the first time I've tried it, so your experience is much appreciated!
  15. JohnAFC

    JohnAFC TS Rookie Topic Starter

    Problem "solved". I just pulled off the Escape key and everything works fine. I can't reattach it, mind you, and from the various tests I did with it half on half off I'm not sure that it would continue to work if I could, but the computer now boots fine.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...