1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Configuring a second SATA Drive... not seen by bios

By bluestblue ยท 5 replies
Aug 30, 2005
  1. Hi,

    I have had some trouble with my Maxtor drive, seems to be a pretty common problem, which I am replacing with a WD 250GB drive.

    The Maxtor drive (also 250GB) failed with a Block: 0 Unrecoverable data error, however the Bios still was able to see it and provide the Brand and ID. I was also able to run the Dell Diagnostics on it. I'd like to see if I can get any data off the old drive, because, of course I don't have any good backups. I know, stupid and all too common!

    The new drive was added and plugged into the SATA0 position, the old maxtor is plugged into the SATA1 position. The machine recognizes the new WD drive, I've installed XP and am adding the rest of my programs... so far so good.

    My question is on the secondary/slave drive. It is no longer recognized in the Bios. When I reboot I get an error and have to press F1. The system then boots. When I enter the Bios it shows the new western digital in SATA0, but doesn't show a drive in SATA1.

    Is there anything else I need to do to get the secondary drive recognized? Can you think of anything that might help? I'm not really a hardware person, so it is quite possible I'm missing something very obvious!

    I'm also interested in advice to get the data back if I can access the drive. I have heard a utility by runtime called GetDataBack might work as well as booting with Knoppix which I've heard may succeed in cases like these where windows XP fails.

    Any help in getting the system to recognize the maxtor as a secondary drive, or guidance on data recovery would be GREATLY appreciated!

  2. vanbroo

    vanbroo TS Rookie

    SATA drive data recovery

    Try NTFS Dos, I used it to recover files on a Maxtor SATA HDD with error 7..
  3. bluestblue

    bluestblue TS Rookie Topic Starter

    A couple of questions...Will it work even if the BIOS doesn't see the Maxtor disk or do I have to solve that first? Also, where can I get NTFS Dos? Is it included with XP?

  4. vanbroo

    vanbroo TS Rookie

    NTFS Dos for SATA drive recovery

    You can test the BIOS recognition with the Hard drive diagnostic ( access by F12 on the Dell start menu )

    Most of utilities don't see the SATA drive ( lack of AHCI and RAID drivers )

    for NTFS DOS see : http://www.ntfs.com/products.htm
  5. Bob108

    Bob108 TS Rookie

    SATA drive boot problem

    General advice: If you are working on a single PC and don't need RAID capability (run more than one disk simultaneously), DO NOT get a SATA hard drive. They are more expensive, a bit slower (in my experience), require extra cables (more expense + hassle), and can result in FAR greater hassles (like never being able to get it to boot.)
    I tried all the things below, scoured the internet for a solution, contacted tech support at Symantec, Maxtor, Dell, the BIOS supplier, Syba (SATA PCI card makers), and the card driver supplier. I worked solid for 3 days. I could never get the SATA drive to boot properly. I sent it back and ordered an IDE drive.

    If you plan to go ahead anyway (or are already into it), try these things (in this order):

    (Most of these things assume you are cloning your old IDE HD to a SATA HD and can't get the new SATA drive to boot. I would try running the SATA drive alone at first, and if you get that running, then try with both your old and new drives together, if you want.)

    1) run FDISK with Win98 boot floppy and see if the correct partition (NTFS) is your active partition (an "A" designation). If not, make the correct partition active. DO NOT delete any partition unless you really know what you are doing. If you try making another partition active and it doesn't work you can always run FDISK again and change it back. (Some said this worked for them, but I didn't find anything amiss in my system.);

    2) run WindowXP install CD and do a repair install;

    3) change every conceivable relevant setting in BIOS

    4) re-run Ghost 2003 cloning with the switch -NOIDE or -FNI interactively from inside Windows (see switch summary below from Symantec website. I recall "advanced" or something similar, as you progress thru Ghost, will give you options somewhere to do this. One of these switches worked for some people; the other one worked for some others.) Repeat steps 1-3 afterward.

    5) re-run Ghost 2003 clone with the switch -NOIDE or -FNI from floppy (Use Ghost Utilities, Ghost Boot Wizard to make a boot floppy with Ghost on it. Run a:> ghost -noide.) Repeat steps 1-3 afterward.

    6) Disconnect & re-connect SATA cable (not power). Remove motherboard battery for more than 1 minute. Reinsert. (Don't forget to reset date & time.)

    7) update all relevant drivers. Sorry, I lost the URL for this one, but call 1-800-800-BIOS (2467) and they can tell you a web address that will check all your drivers and tell you which ones need updating. You can then download the drivers you need from the same site. (Was free until Sept 1, 2005.) These guys (the phone number) can also tell you if you have the latest BIOS (see next step.)

    8) Update your BIOS. (This will generally cost $60. See tel num in step 7.)

    If all this fails, send the blasted thing back.

    From Symantec http://service1.symantec.com/SUPPOR...003 for Windows 2000/NT/Me/98/XP&csm=no&tpre=
    Ghost is compatible with the new Serial ATA (SATA) standard.

    If you are experiencing problems like Ghost hanging, locking up, or freezing when loading or while "initializing TCP/IP" once Ghost loads, the problem lies with the interrupt handling for the Intel 865 Chipsets and later. Upgrading to the latest version of Norton Ghost 2003 or Symantec Ghost 8.x resolves the problem. Also, see the Technical Information section below for information about an update to Symantec Ghost 7.5.

    Depending upon the mix of SATA and IDE drives installed to your system, one of the following switches should resolve the problem:
    If you have an IDE and an SATA drive, or only IDE drives:
    -FNI Forces Ghost to use the BIOS to gain access to the IDE drive.
    If you have an SATA drive and no IDE drives:
    -NOIDE Disables access to IDE devices.
  6. vanbroo

    vanbroo TS Rookie

    SATA HDD Booting

    Yo !!!! I have just repaired my Dell 8400 with Intel AHCI/RAID controller. I replaced my damaged Maxtor by two brend new ones.

    Don't forget to set the second drive online with Setup.

    Win 98 and most of Win XP CD do not have AHCI or RAID drivers, download them and add them during Installation process with F6 + floppy disk

    au plaisir
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...