Connected to wireless Internet but can't browse

By tawin · 8 replies
Sep 11, 2012
Post New Reply
  1. When using my Windows XP SP2 Laptop and Desktop, it says that I HAVE excellent connection to the wireless internet but I CANNOT browse or download content.
    When using my Andriod phone I CANNOT connect to the wireless internet.
    When using my Mac laptop and Iphone I CAN connect to the wireless internet.
    I HAVE internet connection and I CAN browse the internet when I DIRECTLY connect the modem to the Windows laptop.

    Network adapters
    Broadcom 802.11b/g WLAN (Laptop with Windows XP OS)
    Belkin surf and share wireless network adapter(Desktop with Windows XP OS)

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : end-d8a69b2a798
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection 2:

    MediaState. . . . . . . . . . . : Media disconnected
    Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
    Physical Address. . . . . . . . . : 00-1B-24-9D-5C-77

    Ethernet adapter Wireless Network Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Broadcom 802.11b/g WLAN
    Physical Address. . . . . . . . . : 94-44-52-B4-83-08
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . :
    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . . :
    DHCP Server . . . . . . . . . . . :
    DNS Servers . . . . . . . . . . . :


    • Obtain IP and DNS automatically is set. Tried setting it manually to and the problem is still there.
    • I did ping and it showed 4 replies
    • I already did flushdns and registerdns
    • I already did netsh in ip reset reset.log and netsh winsock reset catalog and reboot

    I’m not that experienced at troubleshooting my computers so please bear with me.
    I am not familiar with some networking acronyms.
    Please instruct me as simple as possible. Step by step.
    When you need more info please tell me also on how to get that info from my computer.
    Thank you very much.
  2. alexe3831

    alexe3831 TS Enthusiast Posts: 29

    First off, have you tried going into your routers online management panel and making sure the SSID and Security key are valid? Also I have had issues with Bradcom adapters in the past, but unless all the computers you own use a Bradcom adapter I seriously doubt that is the problem. If you have the Belkin Monitor Software already installed on one of your computers you can use that to access the settings for your router, but if not let me know and I will walk you through how to do it manually.

    Let me know if you find any obvious errors in your settings, and any questions you have just either leave a reply here, or send me a PM, either way.

    Best of Luck
  3. tawin

    tawin TS Rookie Topic Starter

    My SSID and Securty key are both correct. I dont think the adapters are the issue. I dont think I have belkin monitor software installed in my desktop. What will I do with the settings in my router?
    I dont know if there is an error in the settings there or its just normal. I opened my router's management panel through the browser and I saw this

    Model Wireless AP Router
    Chipset Broadcom BCM5357 chip rev 1 pkg 8
    CPU Freq 300MHz
    Flash RAM Size 8MB

    Time Not Available
    Uptime 0 days, 07:22:25
    CPU Load (1 / 5 / 15 mins) 0.06 / 0.05 / 0.01
    Total / Free Memory 28.91 MB / 19.16 MB (66.27%)

    MAC Address 08:10:74:68:83:F6
    Connection Type DHCP
    IP Address
    Subnet Mask
    MTU 1500

    Status Renewing...
    Connection Uptime -
    Remaining Lease Time 0 days, 00:00:00

    Router MAC Address 08:10:74:68:83:F5
    Router IP Addresses on LAN (br0)
    DHCP - on LAN (br0)

    MAC Address 08:10:74:68:83:F7
    Wireless Mode Access Point
    Wireless Network Mode Auto
    Radio Enabled
    SSID malimban
    Security WPA / WPA2 Personal + TKIP / AES
    Channel 6 - 2.437 GHz
    Channel Width 40 MHz
    Interference Level Acceptable
    Rate 54 Mbps

    Thats all the info I can give. Thanks for your reply.
  4. alexe3831

    alexe3831 TS Enthusiast Posts: 29

    Everything looks fine from here, aside from the renewal notice, but that most likely changed to the DCHP lease information after it renewed. Ill see if I can find anything else and will post a reply if I learn something new when I ask around a bit.

  5. tawin

    tawin TS Rookie Topic Starter

    The renewal status was not changing. It stayed Renewing for the whole time. Is that the problem? What is the DCHP lease information?
  6. alexe3831

    alexe3831 TS Enthusiast Posts: 29

    This is a good explanation of what DCHP is used for, it is how your router gets the information to assign IP addresses to your different devices on the network. If it isnt renewing automatically, thats your problem right there. Without DCHP information your computer(s) wouldnt be able to connect to the internet due to the fact that it doesnt have a valid IP, which is how most sites reconize valid browsers vs, say a bot system.

    You said you have tried rebooting your router?

  7. tawin

    tawin TS Rookie Topic Starter

    Yes, I already have rebooted the router. That was the first thing I did. How else can I fix the DCHP information?
  8. alexe3831

    alexe3831 TS Enthusiast Posts: 29

    Ok on your router settings page is there an link for MAC adress settings? If so go there and check if there is an option called "MAC Cloning" enabled. Also make sure your router settings show that it is set to automatically assign IP's dynamically. To be honest I am starting to wonder if it is something with your modem, not your router, but first lets make sure theres no problems with the router.

  9. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    the issue is the WAN connection to your ISP, not the LAN side to your devices.

    Disconnect the Modem &/ router from the ISP connection (ie the Cable or DSL wire) and power off
    both devices. Wait a good minute or so and then connect the ISP connection to the Modem and after that
    power it on by itself. Do the same for the router.

    Log into the router and verify the WAN settings, the attempt release / renew

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...