Connecting Acer Aspire 3680 to internet wirelessly

By dgdleon
Aug 3, 2007
  1. I have a new Acer aspire 3680 with Vista and I'm trying to wirelessly
    connect it to the internet. I also just bought and set up a Linksys
    Wireless G router. The laptop detects and is connected to the wireless
    network just fine but the internet doesn't work (unless I plug in the
    ethernet, then it connects that way).

    It is connected to the network but just can't get online. I have another
    desktop machine connected by ethernet to the router (which is a Linksys
    Wireless G) and it accesses the internet just fine.

    I have only the most basic understanding of networks- please help-
    thanks! I saw another post on this but the description of what to do
    was over my head.
  2. CaptPajamaShark

    CaptPajamaShark TS Rookie Posts: 30

    I have an Acer aspire 3785 connected to a linksys wireless G router.

    This happens to me every once in a while. Try unpluging the power from the router and your modem for a while (at least 10 sec but more sometimes helps) then replug them in and try to connect.
  3. WiFi on Aspire 3680 w/ XP

    I recently picked up an Acer Aspire 3680-2682 (couldn't resist the $350 deal) which came loaded w/ Vista Home Basic. Hated the way Vista crawled so I dumped it an loaded XP Pro instead. I've been fairly lucky at finding and installing some of the drivers I've needed (10/100, VGA, card reader, VistaGrid, etc) but have not been able to get the built in wifi to work.
    Acer's site has a few different downloads available - all of which I've tried - and I've even tried a few from other sources. But in the end I still see the exclamation mark on the Atheros 5006X card in Device Manager.

    I consider myself to have just enough skill/knowledge to be dangerous (to myself and my own hardware!) but I don't think I've done anything to mess it up on my end. I wondered if the wifi on/off switch on the front of the laptop has any part in the difficulties I've been having...

    Has anybody else out there run into this, or similar, problem?

    Thanks for any advice.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...