Corrupt BIOS :(

By Dhakos
Jan 20, 2011
Post New Reply
  1. A few months ago I attempted to update the BIOS on my laptop in an attempt to fix some hardware errors, however when I did so I didn't have enough knowledge to know that doing it through windows was a decision I was later going to deeply regret :( the process crashed half way through leaving me with a corrupt BIOS chip.

    The laptop turns on, the lights flash on the keyboard, and thats it, nothing on the screen, the computer turns on only. Is the BIOS chip something that is easily removable in a laptop? if so then the possibility of buying a new one to either repair the old one, or simply replace it, will still be an option....
    However, if the BIOS chip is not removable... is there anything I can do to repair my BIOS? I dont get to any kind of boot screen so reflashing from any disk is impossible.

    Thanks for any advice :)
  2. Ritwik7

    Ritwik7 TechSpot Chancellor Posts: 1,672   +9

    On a desktop I've heard of a Boot-Block BIOS. his is small area of the BIOS that doesn't get overwritten when you flash a BIOS. The boot-block BIOS only has support for the floppy drive. If you have a PCI video card you won't see anything on the screen because the boot-block BIOS only supports an ISA video card. Once the PC boots using the Boot-Block, the old BIOS image is restored.

    You could try out flashing the BIOS from a CD:

    You may also try taking out the battery and boot only with the power adapter connected. Don't think it will help, but worth a try.

    If it doesn't work I suggest you contact the laptop manufacturer for details on what can be done in your case.
  3. Dhakos

    Dhakos TS Enthusiast Topic Starter Posts: 79

    Being that its a laptop, it doesnt have a floppy drive unfortunately, BUT that gives me hope that there is a good enough portion of the BIOS left to be able to boot from SOMETHING, which is good I guess.
    I can't flash from CD because it doesn't recognise the CD drive or anything, I actualy currently have a disk stuck in there because it won't eject (its a slot load disk drive, so no manual override) luckily I dont need this disk, as its a drivers disk for the laptop.

    I've tried running the laptop on mains only, and have also tried removing the CMOS battery to reset the BIOS, niether worked :(

    Contacting the manufacturer is going to be very pricey isn't it :(

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...