Corrupted directory after interrupted move.

Not open for further replies.
I'm kinda stumped here with a little problem that I've brought onto myself and I'm writing here in the hopes that someone can shed some light on how to fix this mess.

This morning, I moved a very large directory into another folder (within the same volume) and without thinking, I moved it again to a sub-directory. My XP Home system churned away for a couple of minutes and finally gave up with a error message saying that it was unable to create a directory.

Right now, the original folder appears to be where I originally moved it, except that if I try to access it, I get an "access is denied" message and the system shows it with zero bytes in size. If I go to the sub-directory (the second location I tried to move it to), I can see a handful of moved folders but they are all zero bytes in size and I get an "access is denied" message for each of them as well.

I've tried running chkdsk with the /f flag and it found nothing wrong.

Can anyone please point me towards a possible solution for this?

Thanks in advance...


Posts: 6,450   +3
You may have lost the "ownership" of those files by moving them the way you did. This is only a long shot but worth trying.

You can take ownership of these files as follows:
Boot XP-home into Safe Mode (Press F8 a few times when starting up) as an administrator. Now use Explorer to go to the folders etc. on your drive, right-click them, select Properties, click the Security tab and click OK if a security message pops up. Click Advanced, then Owner tab. In the Name list select your (administrator's) name. Mark the Replace Owner on subcontainers and objects check box. Click OK, Yes and OK.

For taking ownership of files, rightclick them, Security tab, Advanced, Owner tab. In Name list select Administrator or Admin-group and click OK. Click Add and in the "Enter the object...list" type a user or group account or Administrator. Click OK. In the group or user name list, click the account you want (e.g. Administrator), then tick the check boxes for permissions, e.g. Full Control [Allow].
Not open for further replies.