Couple issues with Ubuntu 10.10

By SNGX1275 ยท 7 replies
Dec 6, 2010
Post New Reply
  1. My first real issue is I have an external USB 500GB hd that I'm trying to transfer files to over my home network. The files transfer, but at pretty low speeds. It seems to write at maybe several megs a second for about 2-3 seconds and then it hangs for 20 or 30 seconds. The file system on the external drive is ext4 if that makes any difference. CPU usage is also pretty much pegged. I've attached a screenshot showing some info.

    The next problem is if I leave the computer alone for several hours, I can't bring it back up - screen doesn't wake back up. It shouldn't be sleeping since I set it to never sleep in the power management "control panel". I suspect this issue may be related to the graphics card (pci Radeon 7000) since sometimes I can get the monitor to wake back up but the screen is purplish and has Ubuntu repeated across the screen (clearly incorrectly) and the mouse cursor is a mostly white box full of pixels of various colors.
    I didn't see any video drivers in the software update thing, and thats about the extent of my knowledge with drivers in linux.

    Computer Specs:
    Some Intel motherboard
    Celeron 2.4Ghz
    512 Megs of RAM
    PCI Radeon 7000 gfx card

    Edit: Don't know if this helps or not, but the board does not have onboard LAN, so I'm running a PCI network card. But at this time I don't remember what card it is, I can remove it and look if necessary (or if there is some way to tell what it is within ubuntu...)

    Edit2: I guess no screenshot, I can't seem to get that to work. I'm not getting asked where to save the screenshot too, nor is it going to the clipboard (or maybe it is, but I can't get it to paste into OpenOffice Draw).

    Edit3: Managed to get a screenshot finally. Didn't do anything different, but I guess since the CPU wasn't pegged maybe that helped? Something is definitely not right with the system. As you can see CPU is not pegged now, and seems like normal load for a LAN transfer, perhaps a bit high.. But the system really feels like its under full load, it is incredibly sluggish. Firefox (and other open windows) often dim, which I'm guessing is like when windows go whitish in Win 7 when they become unresponsive.

    Attached Files:

  2. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    If you hit "Print Screen" it should throw up the screenshot utility for you to save it. Usually it defaults to either ~/home but it could be in ~/home/Pictures

    I'm not entirely sure about the file transfer issues if I'm honest. I'll have a little look for you and see if I can find anything though.

    Have a look in System > Administration > Hardware Drivers and see if it recommends a useful driver. Failing that, this link might be useful for you.
  3. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,742   +422

    I got it to screenshot finally (attached in the 1st post).

    Went to System -> Administration -> Additional Drivers (Hardware drivers wasn't there, figured Additional was the same). It just brings up a window that says no proprietary drivers in use, there is nothing in the box.
  4. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    Yeah sorry, you found what I meant though. :haha:

    Might well be worth a read of that linked webpage then, I'm afraid the older drivers are out of my league, but it might be worth asking Caravel if he/she doesn't swing by here at some point.

    I've had issues like that in the past until sorting GPU drivers, then it worked fine. Your using Ubuntu Desktop 10.10 yeah? The windows do dim when they become unresponsive.
  5. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,742   +422

    I *might* have figured out the network thing. I think I had the USB drive plugged into a USB 1.0 or 1.1 port, forgot that motherboard really sucks. I'm pretty sure the 5 port PCI USB card I have in there is 2.0 though. I stopped trying to transfer for the time being because I'm copying what I needed over the network (HFS+ external failing, was just trying to get the stuff backed up) via my MBP now.

    I'll try a big network transfer with the drive plugged into that PCI card later.

    The system was incredibly sluggish even after unmounting the external HD, but seemed much more responsive after a reboot. So it could just be lingering effects of USB 1 somehow (I know that system reacted weird in XP too if you tried much data movement with a drive plugged into the old USB).

    That still leaves the sleep issue which I think is due to the card. Is it a big chore to correctly switch cards? I have an AGP GF2MX that I could use, not gaming on the system with either card so I don't need 3d performance (nor am I using any of the crazy visual 3d stuff on the desktop). And I understand that nvidia stuff seems to work better in linux.
  6. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    I've not had any issue per-say with ATi GPU's in Ubuntu. Yeah nVidia cards are better supported with open source drivers, but the proprietary drivers work fine for newer ATi/AMD cards.

    Nothing wrong with you trying it though and seeing how it goes. :)

    Good old USB1.1, I got caught out by that with a computer I have in for repair from a friend earlier. His computer is Jurassic era, but just refuses to die! :haha:
  7. fglrx (the proprietary AMD/ATI linux driver) no longer supports any card older than the HD series (so that's all the early 7xxx/8xxx/9xxx Radeons and X series Radeons out). Earlier versions of fglrx that do support those chips don't support the latest xorg - so in a nutshell fglrx is not an option for you.

    You will have to use the xorg radeon driver, which is normally very good in fact - which makes me suspect that it may not be in use on your system for some reason.

    Can you post the output of these commands?

    cat /etc/X11/xorg.conf
    cat /var/log/Xorg.0.log
    cat /etc/modprobe.d/blacklist.conf
    glxinfo | grep direct
    lspci -v
    -Edit: one more:

    cat /etc/modprobe.d/radeon-kms.conf
  8. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,742   +422

    Actually, I took the lame way out. Had a pretty complex paper to read for a class, then have a final on the 9th. That on top of trying to get data from a dying torrent drive to another machine I wanted to run the torrents on temporarily I just swapped cards and reinstalled Ubuntu 10.10 to get it back up asap.

    Started the transfer last night, and determined the drive was plugged into the USB 1 port. Checked my USB PCI card though and it is 2.0, so I hooked up the drive to that. Last night the estimate was 18 hours for the transfer (only 100Mbps NIC in it), this morning it was down to 7. So looking good so far. Also the monitor had been shut down as per the power management settings and it woke back up properly today, this was something that wasn't happening with the ATi card in there. Hopefully it will continue to work.

    I apologize for wasting your time. But I'll post back if I run into any further problems.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...