cpu spikes every few seconds

By NeoEsper ยท 18 replies
Feb 14, 2006
  1. Every five seconds or so, my cpu performance jumps up by around 20%... this started maybe 3 weeks ago or so, but I have no idea what would have caused it. After defragging, deleting files, running virus check, etc, I still came up with nothing, and no one seems to know whats wrong.

    So with a little exploring I ran into the program "Process Explorer", and tried that out... well, through that, it looks as if one process is causing the spike: ntoskrnl. However, after looking at this a little bit, it seems to be an important file, but also one that shouldn't be running at this time.

    Is this the problem at all? If so, what can I do about it? If its not the problem, does anyone have any idea what else it can be?
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    In process explorer, look up the exact path of the executable. A process with that name should not be running - most likely it is some malware hiding behind the scary name.
  3. N3051M

    N3051M TS Evangelist Posts: 2,115

    yeh.. i'd agree.. download adaware and spybot (maybe hijackthis if you want), update and scan...

    to check the origin of the file in process explorer rightclick the process>properites>image
  4. DragonMaster

    DragonMaster TS Rookie Posts: 327

    Maybe you have too much background apps... Graphic card, sound card, keyboard, etc.
  5. NeoEsper

    NeoEsper TS Rookie Topic Starter

    Alright, ran spybot and adaware fixed the stuff those came up with; however, neither solved the problem. I will double check that I got the latest updates, and try again tonight.

    As for what it says in processexplorer... Under properties for 'System', the image tab tells me nothing: the Version, Time, and Path are n/a, while the Command line and current directory are empty; the user is NT AUTHORITY/SYSTEM

    When I click 'Module' of the ntoskrnl thread (the one that is spiking), the description lists it as 'NT Kernal & System', and it is located under C:\\WINDOWS\system32

    Perhaps I will also try to d/l hijackthis and see if that catches anything different...
  6. N3051M

    N3051M TS Evangelist Posts: 2,115

    alright.. get yourhjt log attached as a file here, and then we'll see if it needs cleaning up..

    ntoskrnl in the %WINDOWS%/system32 folder is legit, and it is important (part of the bootup process, which may mean that you may need to reinstall it (need to research more first..) however, this info might interest you...


    hope it has some bearing of help to you..
  7. DragonMaster

    DragonMaster TS Rookie Posts: 327

    You could also copy / paste the log here:

    We told you to run anti-spyware programs, but you should also use an anti-virus if you don't already.
  8. NeoEsper

    NeoEsper TS Rookie Topic Starter

    Attached is the log file from HJT...

    Lots of crap on there...
  9. DragonMaster

    DragonMaster TS Rookie Posts: 327

    Hi, I copied the file in hijackthis.de and everything seems fine. There are just "Good", "Unknown"(Viewpoint and Epson) and "Unuseful" ones. ntoskern is not in the list tho.

    Maybe you should run msconfig?
  10. NeoEsper

    NeoEsper TS Rookie Topic Starter

    Well, I went into MSConfig and restarted in Diagnostic mode, and the problem went away. I'm thinking maybe I can isolate the problem by doing a selective startup - but I am not sure exactly what I can turn off and cannot. I'm guessing the only things I need on are what the diagnostic startup has (3 "essential" items in the Services tab, nothing else). So if I run a selective startup and make sure I have these items on, I wont screw anything up, will I? (Sorry if this is a stupid question, I just dont know much about msconfig, and I dont want to be disabling something that it turns out I need...)
  11. DragonMaster

    DragonMaster TS Rookie Posts: 327

    What's in MSconfig?

    Some are completely unuseful.
  12. NeoEsper

    NeoEsper TS Rookie Topic Starter

    Whats in MSConfig? Well, a lot of things, especially in the 'startup' and 'services' tabs. Some of this stuff I know I can turn off (like messengers, for example) but others I have no clue. So, I'm attaching a few jpegs of screenshots I made of my msconfig; you really dont need to waste your time telling me what everything does, but my question stands as before: what do I NEED to startup? Just the 3 items listed as essential in Services? (DCOM Service Process Launcher, Remote Procedure Call Locator, Remore Procedure Call). I'm sure there are other things that are fairly important to run along side those, but as long as I can know what I can keep on and off, then I can certainly use trial and error to figure out exactly what is causing my problem (in theory).

    *note, I had to cut the services tab into 3 seperate jpegs for size reasons, and I didn't include the WIN tab... if its necessary I will
  13. DragonMaster

    DragonMaster TS Rookie Posts: 327

    Well startup is mostly what we want to look at.

    Remove the Epson registration, it's there for nothing.

    qttask is QuickTime's annoying taskbar thing. If you don't want it, you'll have to either go in QuickTime's options and disable it or remove QuickTime and use "QuickTime Alternative" instead. (Can do the same with RealPlayer)

    jusched is Java's autoupdater. If you don't need it, go in the Control Panel, Java, Updates and disable auto-updates.

    NeroCheck, don't know if it's useful, I disable it.

    SOUNDMAN, if you don't play with your onboard card sound config often, disable it and enable the Windows mixer in the Multimedia control panel.

    The minimum that's required are the McAffee and ATi programs.

    SYSTEM.INI, nothing useful here. It's just for old apps configuration.
    Services, better not play there.
  14. NeoEsper

    NeoEsper TS Rookie Topic Starter

    Well, I played there. And through process of elimination I have limited my problem down..

    I turned off SYSTEM, WIN, and Startup, and just worked with Services. In the end, I found that when I had 2 services on that were not essential my cpu spiked, but I needed both on at the same time.

    All 5 total that are on:

    DCOM Service Process Launcher (essential)
    Plug and Play
    RPC Locator (essential)
    RPC (essential)
    Print Spooler

    So, any clue why plug and play and print spooler could be causing my problem?
  15. N3051M

    N3051M TS Evangelist Posts: 2,115

    if print spooler is keep on going that means that you have a problem with something wanting to print... plug and play would be like usb devices and such so maybe check your printer, drivers and settings?? and also programs thats trying to print or maybe change usb ports or something... worth a thought
  16. DragonMaster

    DragonMaster TS Rookie Posts: 327

    So you tweaked services options...

    Sometimes some programs are loading CPU for a long time when you stop some services, because they think that the services have some problems. Look in the event log, there should be a lot of red X.
  17. NeoEsper

    NeoEsper TS Rookie Topic Starter

    I didn't tweak them, I turned them off to find the errors, but they are all back on now, and my system is none the worse for doing that, as everything seems back to normal (aside from the spiking of course... grr)..

    where can I check the event log?
  18. Ressurrector

    Ressurrector TS Rookie Posts: 35

    sounds like me and you NeoEsper should combine forces cause I am having this same problem now. I'm surprised your not complaining of effects the spikes are causing. UNFORTUNATELY this thread ends without you having a resolution. BUT after reading this think I will grab process explorer report back later
  19. NeoEsper

    NeoEsper TS Rookie Topic Starter

    Well, my problem has been fixed for quite some time... it disappeared after I went through the Black Viper suggestions on what to turn off. So, I really don't know what exactly I turned off that helped matters, but that did solve the problem. Give it a try if you haven't!

    Can be found by googling Black Viper... or, I think the website is up again:


    Good luck, I know this thing is incredibly annoying, and gave me headaches for months before it was resolved!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...