1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Data recovery from drive with lost format, software recommendations please

By Sarmad
Dec 5, 2012
Post New Reply
  1. My computer (running Windows 7 Ultimate 64-bit) can no longer access my Western Digital Caviar "Black" 1 TB hard drive that's connected, but I suspect my data to still be in there, so I wonder what data recorvery tools people have used and recommend.

    This is one of the additional drives to my operating system C:\ drive. It has been formatted as NTFS and been working fine for several months until a week ago. Now it appears as the E drive on My Computer (as originally configured) but the volume label is now blank (I used to have that named as "Media"). When I double-click on it to enter the drive, I get the error message: "E:\ is not accessible. The parameter is incorrect."

    In Computer Management --> Storage --> Disk Management, the drive appears but it's File System is now indicated as RAW rather than NTFS.

    I have tried using Active Partition Recovery and that successfully lists my drive with the original label name ("Media") and as NTFS, and also lists the folders located at the root of the drive, which is why I suspect my data to still be in there and recoverable. However, when I use this tool to do a full scan of my disk, it freezes after scanning 35 MB. There are tools out there with varying reliability, so whch ones do people here recommend? (another tool I trired, I forget its name, was scanning my disk but prediced 43 days to go over the entire 1 TB, so that's out of the question!). I have been told to use a tool that can recover files onto a separate disk rather then try to repair the original disk and risk losing more of the original data.

    Any advice would be greatly appreciated.

  2. temporae

    temporae TS Rookie

    Oh crap. Something like this happened recently to me when I had backed up some data to an USB thumb drive. It worked fine for awhile, then some weeks later, my PC just couldn't read it anymore (kept saying "disk in drive needs to be reformatted/etc"...and the properties for the drive also showed it as RAW format instead of FAT32 like it would have been usually).

    I think the issue is drive corruption, which seems to be fairly common with external devices like USB drives, but odd in the case of an internal drive. The remedy for me was to try to access it from a different system, which was easy since being a USB stick I could try it elsewhere easily. If you can use another system to access the drive, preferably a Linux/Ubuntu based one; it is likely your best bet to recoup the data before its lost permanently. An external HDD kit would be ideal, and they are quite cheap also.

    Hope this helps!
  3. oliverpowell

    oliverpowell TS Enthusiast Posts: 26

    Thanks for the information temporae. Did you got success to recover data using Linux/Ubuntu system from your USB thumb drive.
    Hope you've successfully recovered your data.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...