Dead netbook except leds flash once when power supply plugged

By moeboe
Apr 10, 2013
Post New Reply
  1. Hi,

    my laptop is a packard bell dot (same as the acer aspire one zg5) equipped with a hannstar j mv-4 94v, I disassembled it to fix a wireless module problem, then when I assembled it back and put on the battery the power and charge leds flash for a second and nothing happens when I try to power it on.
    same reaction happens when I plug on the power supply or put on the battery.
    even the battery doesn't seem to charge anymore (its indicator just flashes for a second as I said)

    here's a video:

    any help or suggestion?

  2. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 9,728   +3,703

    One of the ribbon cables may not be securely connected. Them things are a pain to deal with.

    If you hadn't previously worked on it, I was going to suggest the power supply may have gone bad. Since you worked on it and that is when the problem started, its been my experience the problem is nearly always workers error.
  3. moeboe

    moeboe TS Rookie Topic Starter

    Thanks cliffordcooley but there's only one ribbon cable and I don't see any problem with it.
    any other suggestion?

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...