Debugging Vista - not using the correct symbols

By raincloud ยท 11 replies
Feb 13, 2007
  1. Vista Home Premium, pre-installed
    32 bit
    Gateway GM5410E, purchased less than 2 weeks ago.
    Processor: Intel Core 2 duo E6300
    Memory: 2048 MB DDR2 duel channel
    Vista home premium
    Video: Intel graphics media accelerator x3000 with 256 MB, integrated

    When the user turns on the slide show screen saver, or uses the filmstrip feature in Windows Photo gallery, BSOD, briefly & computer hangs.

    Gateway tech support blamed Microsoft. The store from which the computer was purchased has an identical PC & monitor. The problem doesn't occur on their setup.

    I downloaded the latest Windows debugging tool from Microsoft.

    I downloaded the symbols packages from Microsoft, x86 retail & x86 checked, x64 checked & retail symbols

    I installed the symbols to c:\windows\symbols

    This is the path I use in Windows debugger, for symbols.

    I tried this path for symbols, but the same error about not using the correct symbols.

    SRV*C:\WINDOWS\Symbols;C:\WINDOWS\system;C:\WINDOWS\system32;C:\WINDOWS\Sym bols\ACM;C:\WINDOWS\Symbols\AX;C:\WINDOWS\Symbols\dll;C:\WINDOWS\Symbols\ex e;C:\WINDOWS\Symbols\drv;C:\WINDOWS\Symbols\sys;C:\WINDOWS\Symbols\tsp;*;*h...g/symbols.mspx

    I know that the report states that I don't have the correct symbols. However, I have the only symbols available.
    I hope you can help me.


    Attached Files:

  2. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    I think Vista bugcheck code 124 is the same as XP bugcheck code 9C (Machine Check). The 4th Bugcheck parameter is 175.

    MEMHIRERR - Memory Hierarchy Error {TT}CACHE{LL}_{RRRR}_ERR

    RRRR 0111 Memory Transaction Type Bits (evict)
    TT 01 Data
    LL 01 L1 Cache

    The problem is related to data access error at L1 Cache memory. Probably it is related to faulty CPU.
  3. raincloud

    raincloud TS Rookie Topic Starter

    thanks for the diagnosis

    Thank you very much.

    Finally, I was able to load the symbols.

    I've attached the report.

    Thanks again.


    Attached Files:

  4. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    It is hardware problem and windbg cannot format the BP4 (ie 00000175, Low 32 bits of MCi_STATUS MSR). We have to decode it manually.

    I am using Windows XP and I have problem to load Vista Debugging symbols. How do you fix the windbg symbol problem?
  5. raincloud

    raincloud TS Rookie Topic Starter

    Vista debugging

    1. I cleared the workspace.
    file > clear workspace
    2. I created a new symbol path.
    file > symbols path
    3. I created an image path.
    file > image file path

    I am running Windows DeBugger on Windows XP Pro SP2

    From where did you obtain the BugCheck symbols for Vista?

    What is the BP4?
    [ windbg cannot format the BP4 (ie 00000175, Low 32 bits of MCi_STATUS MSR) ]

  6. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    I searched google and someone reports exactly the same problem when they upgrade from XP to Vista. Probably it is related to the sound card driver and video card driver. However there have no solution.

    Bugcheck code 124 is hardware related (WHEA Windows Hardware Error Architecture) but it maybe caused by device driver error. Vista is still new and a lot of device drivers maybe incompatible to Vista. According to your problem description, the same hardware and software configuration of another PC has no problem. It is the evidence of hardware error of your PC.

    I still have problem at loading the Vista symbols at XP SP2. BP4 stands for bugcheck parameter 4. Actually the BP4 of bugcheck code 124 is MCi_STATUS (ie Machine Check Status). You can download the CPU hardware manual from Intel or AMD. Decode the meaning of MCI_Status 00000175.

    Arg4: 00000175, Low 32 bits of MCi_STATUS MSR for the MCA bank that had the error

    Refer the following AMD manual.
    I double check AMD and Intel CPU information and the machine check status information is almost the same.

    Refer the following url if you want to know more about WHEA. According to this document, ETW event is logged. Do you find any usual system event log?
  7. raincloud

    raincloud TS Rookie Topic Starter

    debugging symbols problem

    I doubt that the problem is with a device driver. The computer is a brand new Gateway. The system came with Vista installed. The vendor has an identical setup on which the problem does not occur.

    Try the steps I listed in #5, above.

    I am very new to DeBugging.

    Yes, the event log notes the occurrence. "Problems & solutions" has no solution.

  8. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    The vendor has an identical setup on which the problem does not occur.

    It is good excuse this is hardware problem of your PC. Probably the CPU is bad.
  9. raincloud

    raincloud TS Rookie Topic Starter


    I agree.

  10. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

  11. ambenient

    ambenient TS Rookie

    I have been wrestling with BCCODE 124 ever since I bought Vista last Summer. I do like Vista, I prefer it to XP without a doubt; however, this error has nearly ended my patience. It's either back to XP, or a new component.

    The problem I have, is that I can't tell which component it is. I've heard that BCCODE 124 is related to audio, some say it's a hardware problem so I don't know what to believe. I refuse to guess, buy a new CPU and still have the same problem.

    I am struggling with deadlines enough as it is and my crashes have become more and more numerous of late.

    I used to have a SoundBlaster Audigy 2 ZS - I would get about 3-4 crashes a week. I upgraded to an X-Fi in January, the errors ceased for a little while but soon returned after a couple of weeks. Currently, I am getting around 5 a day - which is just unacceptable.

    Sometimes I just get a plain BSOD, sometimes I get a BSOD with "IRQL_LESS_OR_NOT EQUAL" - something like that.

    My system is fairly new, I bought it all last summer. E6750, 2GB Crucial Ballistix, Asus P5K, Corsair 520W PSU, etc, so it's as strong as it is new.

    What actions should I take? I've tried all the normal stuff like taking RAM out, disabling onboard sound, re-installing graphics card, sound card, etc. My CPU is overclocked from 2.66GHz to 3.2GHz, but that's pretty safe for an E6750 I'm told.

    I appreciate any help/advice given.
  12. raincloud

    raincloud TS Rookie Topic Starter

    If the steps you have tried made no difference, set your cpu to standard clocking, as a test.

    Zip the 3 most recent minidumps. Post them at this forum.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...