Dell Dimension 4400 won't turn on at all

By elleno
Mar 4, 2006
  1. Hi, I have a 2002 Dell Dimension 4400 which won't start at all - not a light, not a sound, nothing. I've tried another power cord & tried another outlet, to no avail. It's been acting up in the last few days - it would turn back on after I tried to set it to standby, so I would have to turn it off completely. I am not very computer literate, so any help would be greatly appreciated!

    Thank you!
  2. KingCody

    KingCody TS Evangelist Posts: 992   +8

    Dude... yer git'n a dell... that doesn't work!! (lol.. just kidding, i couldn't resist :) )

    but seriously, it sounds like your power supply died (not uncommon in Dell machines). I know that older Dell machines (not sure if 2002 falls into this category or not) used proprietary components (non-industry standard), which forces you to buy replacements and upgrades from Dell. For Dell power supples, they used the same connector as a standard ATX power supply, so people thought that when it died, they could simply buy an ATX PSU to replace it with... they would install it, plug it in, and pfff... (anybody order a fried motherboard?)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...