Dell Inspiron 2500 not booting up

By fanmaker · 35 replies
Mar 24, 2008
  1. Hi everyone.
    While I would very much like to emulate the incredible first post of acrobat, I'm afraid I'm starting from a much more limited knowledge base.
    Hopefully I'll be able to flesh out the details further down the line.
    The problem.
    I've been given from a friend a Dell inspiron 2500. It's about 6/7 years old, and has been used without any great demands over that time with few if any problems.
    She was in the middle of answering emails when the screen froze completely. Eventually giving up any possibility of regaining control, she turned off at the mains( always run on a mains adaptor). Turning back on, there was no response - no start up screen, completely dead.
    Since then it has remained untouched, till she passed it over to me.
    When I turned it on, the power and battery leds lit, the latter indicating that the battery was charging, which subsequently did charge up ok.
    The fans start, run for a few seconds then stop.
    I think I can hear the hdd start briefly, but no hdd (?)led comes on.
    If there is a cd in the player, it will run.
    I've taken the hdd out and checked it in another machine, and it's ok.
    I've taken the ram out and checked that ditto, ok, then reseated it - no change.

    I stripped the m/c, and checked the voltage of the cmos battery in situ with a dvm, and that reads 3.3volts.

    I have now acquired her Dell disks, only CDS, and one is labelled Operating System Reinstallation cd, but may or may not be a "recovery" disk. I put that in the player, switched on, but no response other than the player running for a brief time before stopping. I repeated that with various F keys depressed at different times, but no change.
    I've tried an old win98 recovery floppy in the fdd, and the drive clicks once but doesn't spin up.
    I'm assuming the screen is ok, and have a monitor I could connect, but I don't know which key to press to switch screens. Is that necessary ?

    I'm now left wondering if the internal psu has a problem, if the cpu has gone down the pan, or what else.
    Any and all suggestions welcomed.
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    computers that old can have all kinds of issues.

    1. check the main battery and test the powerpack with a known good one. (not the one you are using)
    2. check your ram with memtest 86+ for at least 7 passes

    if it is still flakey, you may have capacitors that have gone bad on the mainboard if you do not have issues with the above. It may not be worth spending $ on such an old computer.
  3. fanmaker

    fanmaker TS Rookie Topic Starter

    Hi Tedster.
    Thanks for the pointers.
    I've checked the open cct voltage on the powerpack at 19.6 volts, and it runs a Dell latitude that is also on the bench OK, so I assume that's ok.
    I googled the memtest86+ and read it up, most of which went over my head, but enough went in to give me an idea of what it is about.
    I've downloaded it to make up the cd, so that will be my next move.
    ps it may be old, but it will become my first linux machine if I can get it running.

    I've tried the memtest but get no response from the laptop.
    I can hear the cd player trying to start, several times, and the last time for about 15 seconds before stopping.
    If I can find the cleaner disc I've got, I'll see if that makes a difference.
    2nd edit
    Cleaner disc didn't make any difference.
    I now realise that I don't know if the bios will even look in the cd for any programmes, so I've downloaded the floppy version of memtest, and will try that when I can dig out another system that will write floppys.
  4. fanmaker

    fanmaker TS Rookie Topic Starter

    I've now tried both a floppy and a second burning of the cd disc from a different pc, but neither cd nor floppy would start up properly.
    I can hear each of them trying, but they dont continue to run.
    I've tried both with either the mains adapter or on the battery alone, but no difference.
  5. fanmaker

    fanmaker TS Rookie Topic Starter

    Just tried resetting the bios by removing the battery for 20 mins, but that produced no change in the syptoms.

    I have a 50mhz cro at my disposal, and wondered if there is some way I can differentiate between a duff cpu and an internal power problem.
    Any thoughts anyone ?
  6. clancy31

    clancy31 TS Rookie

    Same Issue, But Some Success

    I have had the same issue with my 2500 for quite a while and have yet to figure it out. I have, although, been able to boot the 'puter by removing the battery (main battery not cmos) and continually attempting to restart by unpluging the power supply if the bios does not fire. Some times this can be 2-3 tries or it can take 30 minutes of plug-in, power, unplug, repeat... Give this a wack and see if works for you. I just leave mine running for as long as possible, until I have to reboot, or Big Bad Bill tells me to restart.

    BTW... I have run a few different flavors of Linux on this box and it does pretty well for its limited resources and age. I now run XP for work reasons and have to reboot every so often, so I know that it does start w/ enough coercion.

    Keep us posted...

  7. fanmaker

    fanmaker TS Rookie Topic Starter

    Hi Clancy.
    Thanks for that experience.
    That idea might suggest a capacitor in the supply voltage ccts is in a poor state, and your method is forcing it to charge up.
    Anyway, I'll give it a go, and let you know the outcome.
    I've been searching for a schematic but although several site mention it, none seems to be available.

  8. fanmaker

    fanmaker TS Rookie Topic Starter

    Clancy - I didn't get anywhere so far with the power on off cycle, but I only tried it for a couple of minutes I confess.

    Another test that might be available to me. I have a Latitude C600 that works. Would the cpu survive being transferred to the Inspiron ?
    If it gave me even the post and boot up I'd know that the problem was in the cpu rather than a power problem
  9. clancy31

    clancy31 TS Rookie


    I have long suspected a voltage issue with this computer. I haven't had the time and/or meters to be able to verify my suspicion. I do notice that when I have to restart, if I move the monitor around and give a gentle shake now and again it seems to jostle something into place. This would lead me to believe a loose connection/solder joint that might need touching up. I have also been unable to find a schmatic, but have a pretty detailed .pdf for disassembly. Here is a link:[/url]

    Let me know if the CPU thing works out. I am lucky that I am able to use it when it starts. Getting it fired up is the issue, and I have issues with my issues!! ;-)

  10. fanmaker

    fanmaker TS Rookie Topic Starter

    Getting me fired up is becoming more of an issue ;) , and as for " it a bit of a shake..." ouch!
    I've just put Everest, a useful diagnostic tool onto the Latitude to find out what the cpu is, and it seems to have the same sort of spec as I would expect to find in the Inspiron - an Intel P111E 700Mhz 256k cache. While the "fine print" goes over my head, I think that's OK.
    I'll try the swap over the weekend, and let you know the result.
    Saturday morning.
    Tried the swap with no result, except the suspect cpu into the working latitude now starts up with the usual dell startup screen, but the next screen is black, with the message "system hardware failure #0010"
    The working cpu into the inspiron gives exactly the same symptoms as before.
    I'm now more suspicious of a mobo fault on the inspiron, and the above message on the latitude is merely an incompatibility issue.
    Hope your keeping up. :D

  11. fanmaker

    fanmaker TS Rookie Topic Starter

    I've just swapped everything back and forth twice, and the symptoms are constant.

    Slight hiccup, the latitude fan doesn't come on at start up, so something else to clear. Ho hum.
  12. lamo

    lamo TS Rookie

    fanmaker, try to replace memory modules.
  13. fanmaker

    fanmaker TS Rookie Topic Starter

    Hi lamo.
    One thing I have done, when I tried just reseating the ram, was to swap the stick for one that was working ok in the latitude.
    No result unfortunately. I also tried putting the ram stick into the 2nd socket, but with no more luck either.
    I'm assuming that even if the latitude ram is a bit slower, it will still produce some sort of effect, even if it's only "goodbye".

    I also tried the inspiron ram into the latitude machine as a check, and that worked OK.

    I still keep coming back to the idea that because the led that indicates processing activity doesn't come on when I first switch on, that some voltage supply problem exists.
    I'm going to diss the fans tomorrow, so that I can hear clearly what drive activity occurs. I know the cd fires up briefly, but I'm not 100% certain about the hdd.
    One curious thing, when it's switched on, (but not booted up) if I put the cd recovery disc in, the player start up and runs for about 20 secs before coming to rest. Unfortunately it doesn't do anything with it. Just sits there giving me a black look.
  14. lamo

    lamo TS Rookie

    i suspect southbridge failure. btw, i can create thread in this forum in which i will describe laptop low-level working(i.e. work of bridges, KBC controllers and,for instance typical schematics of powering up). that's of course if community will agree with that, and will ask some tricky questions :)
  15. fanmaker

    fanmaker TS Rookie Topic Starter

    Well, lamo, I for one would be most grateful.
  16. fanmaker

    fanmaker TS Rookie Topic Starter

    deleted - duplicate posting
  17. fanmaker

    fanmaker TS Rookie Topic Starter

    Clancy - can you let me have a particular observation on your inspiron.
    At what stage does the "drive activity" LED, the one in the middle, first come on ?
    Even if it's only a momentary flash, like a quick test during the POST sequence.
    (I'm expecting that to be within the first second of you hitting the start button.)

    If it does that, when does it the come on for any duration, ie actually indicating hdd doing something useful ?

    I'm now seriously considering buying a POST card diagnostic tool. They're on ebay at ~ £7 from China, or ~£12 from UK. With three laptops in the house, and support for friends PCs, it might be a reasonable purchase.
    Many thanks
  18. fanmaker

    fanmaker TS Rookie Topic Starter

    Everything has changed !

    I'm not sure if I should now start another thread, or continue with this one.
    I should be happy to take advice from more experienced members.
    The reason is that, by chance, I left the laptop switched on with the ac adapter plugged in for about 2 - 3 hours.
    When I returned, I could feel how hot the base was both under the cpu location and under the hdd,
    Puzzled why had got hotter when the machine had not got past the boot stage, and to all intents was dead as a dodo, I unplugged it and took the keyboard off and checked by touch that it really was both the cpu and hdd that were the hot spots.
    I'd guess that the cpu was about 60 degrees C, and the hdd a bit cooler, so not too extreme, so I turned the machine back on and then off, several times to get the fan working a few times.
    On the third switching on I got a two beep post code, and a set of narrow stripes on the screen.
    I repeated the on/off a couple of times, and each time it gave the same result.
    I now connected an external monitor, pressed the function and F8 keys, and got a readable boot up screen that said "no operating system detected"(or words to that effect).
    I removed the hdd, reinserted it and tried again. This time it told me the date/time were wrong.
    Re-booted and went into bios setup and corrected this, saved, and it went on to give me a correct loading of xp. :D

    During this sequence, each time I had to switch to the external monitor, as the screen continues to show just the original narrow white stripes each time I reboot.

    I left the machine running and went out to make coffee.
    When I returned about 3/4 hour later, I assume the m/c had gone into hibernation, black screen, no activity.
    I switched off, then on again, but now it is back to square one. It has cooled down, and I can't get it to reboot.
    Tomorrow I shall repeat the events as closely as I can.
    Meanwhile, I now know that the bios/cpu/hdd are OK, but it would appear that I have a curious thermal problem.
    I have come across this on another thread on the forum, but searching as I have been, I can't find it.
    I'd be extremely grateful is someone could give me a link to it, and any advise as what to do next.
  19. lamo

    lamo TS Rookie

    at last. we've found that this is a videochip or LCD faulty failure. however, this is not typical for this platform(i mean videochip faulty, but LCD cable - yes), but i can conclude the video faulty.
    fanmaker, you say, that now laptop boot up with external monitor with readable image on it, but on LCD you got stripes or squares?
  20. fanmaker

    fanmaker TS Rookie Topic Starter

    Hi lamo.

    When it first started to boot up, the lcd screen was full of many narrow stripes, some different in width and different brightness.
    When I switched to the external monitor, the image was perfect.
    It only booted up while the cpu and hdd were hot, and each time, the pattern of stripes went through a sequence, which I assume was a distorted version of the images that normally show.
  21. lamo

    lamo TS Rookie

    so, this is LCD or videochip failure. can you post a picture of this pattern?
  22. roland_xp_80

    roland_xp_80 TS Rookie

    Anybody please help me to get my bios password. I need bios password for del latitude d810.. this is really urgent.. I need to change the operating system from windows XP to windows Vista, but the boot sequence cannot be changed, it is locked. I bought this laptop from news paper, when I called the guy about the password he say that He don't take any responsability once you pay. Please help me for the password, I will not forget your kindness and hope you would help someone that is very frustated person..

    Please help me.. thanks..
    Service Tag : DKFSZ1J
    System Number : DKFSZ1J-595B
    Express SERVICE Code: 295-340-399-11

    Please help me.. thanks..
  23. fanmaker

    fanmaker TS Rookie Topic Starter

    Yes Roland. What you do is start your own thread with "bios password for del latitude d810" as the thread title.
    Then people will see your need and respond.
  24. fanmaker

    fanmaker TS Rookie Topic Starter

    :( Unfortunately so far I can't get it to start up again.
    I shall continue trying, and as soon as I succeed, I'll grab a photo and post it.

  25. fanmaker

    fanmaker TS Rookie Topic Starter

    Screen photos

    After about 6 hours "warming up", I got it to boot up. It went straight through the normal sequence, but with the laptop showing a striped screen. I could see the correspondence of the stripes to what I would expect on screen.
    When it had finished booting up, I took the first photo, then used the F keys to switch to monitor and took the second.
    I've now alterred the power settings so that it wont shut down unless I say so, to give me more time to experiment.

    Is there a setting in bios that would let me use the external monitor as the default display ?
    This might be useful if I can't fix the problem.

    I notice that only one fan comes on when the processor is working. Is this normal during light usage ?

    I've got Everest loaded as a diagnostic tool, and it shows a X against a 3D accelerator(whatever that is) and Xs against all the directX entries.
    Is this significant ?


    Attached Files:

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...